Symantec Management Platform (Notification Server)

Expand all | Collapse all

IIS script maps must be properly configured for ASP.NET

Jump to Best Answer
  • 1.  IIS script maps must be properly configured for ASP.NET

    Posted 11-17-2010 12:23 PM

    I'm getting the IIS script maps must be properly configured for ASP.NET message when attempting to install ITMS 7.1 Beta. Here's the history so far.

    - Installed the Beta successfully using a local administrator account
    - Realized that the install was completed using a local account. Uninstalled the Beta.
    - Deleted existing DB for the beta (on a remote SQL server).
    - Rebooted beta server.
    - Attempted to reinstall the beta. Received IIS message.
    - Fix (And readiness refresh) unsuccessful.
    - Uninstalled the partiall uninstalled beta. Rebooted.
    - Uninstalled/Reinstalled IIS. Rebooted.
    - Verified .NET installed and configured.
    - Attempted to install the beta. Same result.

    Any help that you can offer would be greatly appreciated.

    Thanks!

    Mike

     



  • 2.  RE: IIS script maps must be properly configured for ASP.NET

    Posted 11-18-2010 02:29 AM

    Hello Mike,

     

    As a workaround try to give the Network Service Account full control on the

    "c:\Windows\Temp" folder.

     

    Best regards

     

    Fabrice



  • 3.  RE: IIS script maps must be properly configured for ASP.NET

    Posted 11-18-2010 10:15 AM

    Fabrice,

    Thanks for the tip. Unfortnately, adding the rights did not effect the end result. I'm still stuck with the IIS script maps message.

    Thanks,

    Mike



  • 4.  RE: IIS script maps must be properly configured for ASP.NET

    Posted 04-26-2011 06:26 AM
      |   view attached

    Hello,

    I'm getting the same error while "installing" Altiris Client Mangement Suite. Are there any tricks/bug fixes or even working solutions to solve this problem?

    I even tried the "EnableNextButton" trick, but as result the configuration fails.

     

    Any help that you can offer would be greatly appreciated.

    Thanks in advance.



  • 5.  RE: IIS script maps must be properly configured for ASP.NET

    Posted 04-26-2011 07:19 AM

    Have you tried removing IIS, .NET 3.5.1, rebooting, adding them back and trying again? Sometimes will kick it.  Do you get an error when you try to run the corrective action through the prereq checker?



  • 6.  RE: IIS script maps must be properly configured for ASP.NET

    Posted 04-26-2011 08:37 AM

    No luck with removing IIS, .NET and reinstalling.

    The only message displayed is, that the script maps will be changed with "yes/no/abort" dialouge. Then it tries the "fixing" and goes back to the overview.



  • 7.  RE: IIS script maps must be properly configured for ASP.NET

    Posted 04-26-2011 09:06 AM

    Did you try clicking the button really hard?  :-)

    Your error looks different from the other error reported. Object reference errors, when I have gotten them, have been resolved by restarting the installer. Do you have any proxy settings? They seem to cause issues.



  • 8.  RE: IIS script maps must be properly configured for ASP.NET

    Posted 04-26-2011 09:22 AM

    The button is nearly broken ... out of frustration ...

    And the Object reference error appears only, if i "skip" the readiness check with the "EnableNextButton" registry hack/fix whatever.

    The question: is the IIS script map related to the Object reference error? If that's the case, fixing will hopefully solve the another error.



  • 9.  RE: IIS script maps must be properly configured for ASP.NET

    Posted 04-26-2011 10:30 AM

    Don't hurt your mouse.  It is an innocent.

    You need the prereq check to work. I think it registers .NET 2.0 asp extensions. You could try registering the extensions manually and see if the prereq checks feels better about things.



  • 10.  RE: IIS script maps must be properly configured for ASP.NET

    Posted 04-26-2011 11:48 AM

    Hey All,

     

    I have seen this issue a few times and it is caused by a few different things, but lets start with this first:

     

    Have you checked to make sure that the user you are trying to install under is a part of the IIS worker processer group?

         - The group is IIS_WPG in windows server 2003 (I know you are running 2008 but just wanted to get the data out there for others that might not be running 2008)

         - The group is IIS_IUSRS in windows server 2008

      * This is one of the two things that happens when you do an aspnet_regiis -ga during the install. It adds the user the the group above as well as adding the user as the application pools Process Model's Identity, as seen below ~

    IIS_IUSRS group:

     

     

     

    Application Identity:

     

     

     

     

    Let me know if this works out for you or not! If not I will send a few other things that can cause the issue.

     

    Cheers



  • 11.  RE: IIS script maps must be properly configured for ASP.NET

    Posted 04-27-2011 02:27 AM

    @rpoag
    But someone is to blame ...

    I have tried to register the asp extensions via aspnet_regiis.exe and via text-to-keyboard -> result: nothing changed.

     

    @Justin
    The user was not member of IIS_IUSRS, but the checks still fails.

    What is up next?

     

    If everything fails, i will setup a new server and try it again ... long live the test site!



  • 12.  RE: IIS script maps must be properly configured for ASP.NET
    Best Answer

    Posted 04-27-2011 04:11 AM

    So,

    after a clean install of IIS (after removing everything related to IIS, kinda annoying) I got past the readiness check ... YEAH !!!



  • 13.  RE: IIS script maps must be properly configured for ASP.NET

    Posted 04-27-2011 08:52 AM

    Glad to hear something worked for you. I thought you already removed IIS previously and it did not help?



  • 14.  RE: IIS script maps must be properly configured for ASP.NET

    Posted 04-27-2011 09:27 AM

    I removed and reinstalled the IIS several times now, but some traces were left behind.
    This time I manually removed everything (folder, file, regkey) that were still present on the machine.



  • 15.  RE: IIS script maps must be properly configured for ASP.NET

    Posted 04-27-2011 09:32 AM

    Excellent!  At least you got it working. Hopefully the rest of the install will go smoothly.