Critical System Protection

Expand all | Collapse all

Error installing agent 8.0MP1 on windows 7 (1603 error)

  • 1.  Error installing agent 8.0MP1 on windows 7 (1603 error)

    Posted 05-25-2020 04:23 AM
    Hello,

    I'm getting error when installing agent on windows 7.

    EFAINST_TRACE [10:11:50:406]: --> Starting ValidateCurrentProcess...
    EFAINST_TRACE [10:11:50:406]: ValidateCurrentProcess (86) - Initializing verify trust...
    EFAINST_TRACE [10:11:50:406]: ValidateCurrentProcess (103) - Get current process info...
    EFAINST_TRACE [10:11:50:428]: ValidateCurrentProcess (107) - Check process path...
    EFAINST_TRACE [10:11:50:428]: ValidateCurrentProcess (127) - Validate process path...
    EFAINST_TRACE [10:11:50:470]: ValidateCurrentProcess (132) - Verify couldn't successfully validate process id: 3980 for 4 signature. ccVTErrorType = 3
    EFAINST_TRACE [10:11:50:470]: <-- ValidateCurrentProcess ended
    CustomAction efainst_install.C1599C28_9DB3_446E_AC61_80DD180FF696 returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)


    I found this: https://knowledge.broadcom.com/external/article/169702/when-installing-windows-data-center-secu.html
    It says that "VeriSign Class 3 Public Primary Certification Authority - G5" is needed, but its installed.

    Is there any windows update that is causing this problem? I managed to install the agent on an other version of windows 7.


  • 2.  RE: Error installing agent 8.0MP1 on windows 7 (1603 error)

    Posted 05-28-2020 05:04 AM
    I have done some testing, and it looks like its some problem with windows updates, i uninstalled kb4512506. And i was able to install the agent after that.
    But that isn't a good fix, anyone knows why this problem occur? I have tried removing and installing certficates but that didn't work.