Messaging Gateway

Expand all | Collapse all

Message Gateway Relay to Exchange 2016

Jump to Best Answer
  • 1.  Message Gateway Relay to Exchange 2016

    Posted 08-14-2020 02:03 AM
    Hello All,

    I am trying to relay email for one specific email sender incoming to relay directly to our exchange server. I have setup the content rule, but the relay portion is failing. Exchange is set to accept anonymous users. Once i get it working for my test account i want to expand it to our whole domain.

    I keep getting this message in the audit log for SMG.

    451 4.4.2 [internal]no mail from response


  • 2.  RE: Message Gateway Relay to Exchange 2016

    Posted 08-14-2020 06:46 AM
    Go to protocol, domains, in smg. Make a new entry for the email domain, local, add the routing path to exchange ip. Save




  • 3.  RE: Message Gateway Relay to Exchange 2016

    Posted 08-14-2020 07:47 AM
    Yep that is all set for our normal routing paths, but will that route all messages to that path? i only want one email sender to be delivered to a different routing path for testing purposes.


  • 4.  RE: Message Gateway Relay to Exchange 2016

    Posted 08-14-2020 07:48 AM
    You can use domains section to route mail addresses as well.




  • 5.  RE: Message Gateway Relay to Exchange 2016

    Posted 08-14-2020 08:05 AM
      |   view attached
    I uploaded my content filtering rule to route this specific email to a different host if you wanted to see the screenshot. Do I still need to add that host to the domains section?

    FYI I already have our "normal" host setup in the domains section, this is a different one that I want to test to see if it accepts email.


  • 6.  RE: Message Gateway Relay to Exchange 2016

    Posted 08-14-2020 08:08 AM
    The content filter does override the domains section. But is the rule getting triggered?




  • 7.  RE: Message Gateway Relay to Exchange 2016

    Posted 08-14-2020 08:12 AM
    yes the rule is getting triggered, but I'm getting this message in the audit log. My exchange server is set to accept anonymous emails so I'm not sure why its getting that message.

    451 4.4.2 [internal]no mail from response


  • 8.  RE: Message Gateway Relay to Exchange 2016

    Posted 08-14-2020 08:14 AM
    What does the exchange log say?




  • 9.  RE: Message Gateway Relay to Exchange 2016

    Posted 08-14-2020 08:20 AM
    I don't think it reaches exchange, I cant find anything in the log about it.


  • 10.  RE: Message Gateway Relay to Exchange 2016

    Posted 08-14-2020 08:22 AM
    Show a pic of the audit log pls.




  • 11.  RE: Message Gateway Relay to Exchange 2016

    Posted 08-14-2020 09:26 AM
      |   view attached
    Here is the audit log from SMG.


  • 12.  RE: Message Gateway Relay to Exchange 2016

    Posted 08-14-2020 09:45 AM
    Are these going to the same server




  • 13.  RE: Message Gateway Relay to Exchange 2016
    Best Answer

     
    Posted 08-14-2020 11:14 AM
    If the SMG is getting as far as sending the mail from verb in the conversation, it means the issue is somewhere in your Exchange configuration (i.e. not a network issue or an SMG mail routing issue).

    It sounds like your Exchange server is dropping the connection (or maybe prompting?) at some point after it displays the banner.  You should do some manual runs where you telnet into the Exchange server and manually walk through the process so you can observe the results.