Ghost Solution Suite

Expand all | Collapse all

Error trying to restore from .gho image file - says file is not a valid image file

  • 1.  Error trying to restore from .gho image file - says file is not a valid image file

    Posted 09-14-2020 11:42 AM
    I am using GhostCast 3.3 to create image over multicast. This process has worked with no issue in the past, however we are trying to create a new image and I keep encountering this error after trying to choose the .gho file for 'Restore Image'. The image creation seems to be working as there are no errors, however I notice in the folder of our successful image file there are several .ghs files that are not being created in this new one. 

    My next attempt is to try to turn off spanning, however I'm wondering if anyone else has run into this issue or if there is a clear resolution since it's worked without turning off spanning in the past, hence the .ghs files?


  • 2.  RE: Error trying to restore from .gho image file - says file is not a valid image file

    Broadcom Employee
    Posted 09-14-2020 12:19 PM
    Yes, I have tested this and GhostCast does not like span files currently on the deployment side. When you capture your image with Ghost, you can include the -split=0 parameter to not create span files and it works great.

    After I figured that out, I did some research and saw this has been an ongoing issue for some time. I am inquiring with our development team about it.


  • 3.  RE: Error trying to restore from .gho image file - says file is not a valid image file

    Posted 09-14-2020 12:21 PM
    Hopeful this resolves the issue, about 80% through a new image creation with spanning turned off so will update if this works.


  • 4.  RE: Error trying to restore from .gho image file - says file is not a valid image file

    Posted 09-14-2020 02:01 PM
    So if I turn off spanning, I get an internal error 10022 - an internal inconsistency has been detected at 99% complete. Any ideas? I am using Symantec Ghost 12.0.0.1157 and GhostCast Server. As mentioned I have an active image that worked using this same process a just a few weeks ago. 

    I am trying again with span turned on, but I am already thinking the initial error is going to come up again as I still don't see the proper .ghs files being created...


  • 5.  RE: Error trying to restore from .gho image file - says file is not a valid image file

    Broadcom Employee
    Posted 09-14-2020 02:33 PM
    I've seen that a handful of times when there's a problem on the data on the disk or the disk itself, and a chkdsk /f  on that disk while in WinPE usually fixes it.


  • 6.  RE: Error trying to restore from .gho image file - says file is not a valid image file

    Posted 09-14-2020 03:38 PM
    Okay going to try this. Afterwards would you still advise trying it with -split=0?


  • 7.  RE: Error trying to restore from .gho image file - says file is not a valid image file

    Broadcom Employee
    Posted 09-14-2020 03:42 PM
    Yes because I know the span files is an issue. I did get word back that the span file issue with GhostCast has been reviewed and is slated to be fixed in the RU5 in a month or two.


  • 8.  RE: Error trying to restore from .gho image file - says file is not a valid image file

    Broadcom Employee
    Posted 09-14-2020 08:30 PM
    Edited by Junichiro Hayashi 09-14-2020 08:50 PM
    Hi Thomas,

    Please try a pointfix.

     The GhostCastServer won't create *.ghs files even if image file size is bigger than 2.0GB.
    https://knowledge.broadcom.com/external/article?articleId=195004

    1. Replace the following files.
    C:\Program Files (x86)\Symantec\Ghost\GhostSrv.exe
    C:\Program Files (x86)\Symantec\Ghost\GhostSrv64.exe
    C:\Program Files (x86)\Symantec\Ghost\bootwiz\OEM\GSS\winpe\x64\Base\ghost\ghost64.exe
    C:\Program Files (x86)\Symantec\Ghost\bootwiz\OEM\GSS\winpe\x86\Base\ghost\ghost32.exe

    2. Recreate the boot disk.


    Thanks,



  • 9.  RE: Error trying to restore from .gho image file - says file is not a valid image file

    Posted 09-17-2020 09:51 AM
    Okay so replacing the files fixed creating the image file. I have recreated the boot disk and have established a connection via multicast to restore the image.

    I will confirm the image is working after completion.

    Thanks for your help so far!


  • 10.  RE: Error trying to restore from .gho image file - says file is not a valid image file

    Posted 09-17-2020 10:13 AM
      |   view attached
    Okay so it gets 7% done in the restore and then I get a pop up that says it needs to find the next span file, Okay to continue or 'Browse'. When I browse I get an error with the attached log file.

    I am trying to move it do a new directory to see if that's the issue. Any other ideas?

    Attachment(s)

    txt
    logfile.txt   1K 1 version