Protection Suite Enterprise Edition

Expand all | Collapse all

SPC 2.0 install updates failing

  • 1.  SPC 2.0 install updates failing

    Posted 10-13-2011 11:54 AM

    I just installed the appliance on a physical system, which went fine.  When I tried to install the 4 upgrades manually, it came up showing 3 of the 4 updates available, and the documentation update failed.  I clicked to install all 4, and now they don't show up as installed or available.  I also tried running LiveUpdate, but it just sits at connecting... and never completes or errors out.  Is there some way to uninstall and reinstall these updates?  Or do I need to start completely over?  Thanks.

  • 2.  RE: SPC 2.0 install updates failing

    Posted 10-13-2011 12:35 PM

    Hello JWolf

    Let's see how your support session goes, and we'll report the steps needed to resolve this issue here.

    Thank you for thinking of the SPC Connect site to get community assistance.



  • 3.  RE: SPC 2.0 install updates failing

    Posted 10-17-2011 04:40 PM

    Hello JWolf;

    Most troubleshooting requires command line access to the Server Core OS, Review of the Logs, or submission of the Support Diagnostics file. You can review the System logs in the Web Console, but will need to call support and have them assist you to get "under the hood" and go deep into troubleshooting this issue..

    Without a support call, lets approach it from this angle:

    After your reboot, do you still only have the one item that was successful? (You have rebooted, correct?)

    What browser version are you using? (Please use IE 8 for testing purposes, if possible, otherwise, use FireFox 3.6)

    Do you have your backup setup, and have you successful run a backup? (If not, please setup your backup, and then run a backup job to verify it works.) Make sure to use the FQDN of the backup location, and please make sure that you have the AD Domain\Username set for the credentials.

    The first thing that happens when check for updates is the system looks to see if there are any. (Standard Port 80 traffic) If there are, it downloads them and updates the displayed information. If not, it simply returns to the web console.

    When you select items to install manually the system will attempt to install all of the items that are required for the item you selected to be installed, and it will then install them in order. When it attempts to do the install it will check to see if you have a valid backup. If not, it will prompt you with a message asking if you want to continue anyway. You need to read the message and allow the system to install without a backup if you haven't had a successful backup.

    If you have several items showing as available try to click them one at a time. If only that items is highlighted when you click it, then choose to install that item, wait 10-20 minutes, and then see if it has shown up in the installed section. If you do have your backup setup the system may initiate a backup, so it could take several minutes for this to complete before the system attempts to do the install. If you interrupt this process with a reboot, or repeated attempts to install this could have an impact on the installation.

    After getting one item to install attempt to install the remaining items.

    If this is a fresh install and you have nothing else integrated it may just be simpler to start over, as you suggested.

    Prior to attempting the updates with the fresh install you should make sure that your backup settings are present, and you are able to run a successful backup. If you do this and you have issues with the install of the updates again you will have a base backup that can be used to restore your system and you won't have to do a fresh install again. Try to install the updates one at a time, and only install the next one after the previous has completed successfully. Make sure to give each update plenty of time to complete, and verify it shows up in the installed updates section.

    I will mention that this is the only report of updates not installing that I am aware of, so there is something weird going on here. I have tried to reproduce the update installation process multiple ways and have net been able to do so.


  • 4.  RE: SPC 2.0 install updates failing

    Posted 11-29-2011 10:40 AM

    Greetings JWolf

    Please mark this issue as closed. The solution was to reinstall your SPC appliance and allow it to update normally.

    We were unable to determine exactly what caused the updates to never complete. It may have been a corruption of some particular file(s).

    Since this was a new installation and there were some questions about it the best course of action in this case was to do a reinstall and then proceed with integration after the updates succeeded.

    Thank you for using the forums.


  • 5.  RE: SPC 2.0 install updates failing

    Posted 01-04-2012 11:31 AM


    Please help us to keep the forum clean by marking this issue as resolved.