Messaging Gateway

Expand all | Collapse all

TLS support

  • 1.  TLS support

    Posted 11-07-2019 10:59 AM

    We have one client using secured email service, which requires TSL excrypted messaging, but after enabling TLS for this domain, the TLSSTART command is still unrecognized..  Of course the SMG server at this point don't even know about the destination domain, and it's settings. So does the Messaging Gateway support TLS handshaking or not, and what might be the problem here?   
     

     telnet qntsrv9.qnet.fi 25

     

    Trying 62.142.220.9...

    Connected to qntsrv9.qnet.fi.

    Escape character is '^]'.

    220 qntsrv9.qnet.fi ESMTP Q-Net Spamcontrol ehlo turvaposti.fi 250-qntsrv9.qnet.fi says EHLO to 212.68.18.130:35317 250-8BITMIME 250-PIPELINING 250-SIZE 110000000

    250 ENHANCEDSTATUSCODES

    STARTTLS

    500 5.5.2 unrecognized command

    Jukka



  • 2.  RE: TLS support

    Posted 11-07-2019 11:29 AM
    Can't do tls test from telnet. Send an email normally as you would thru the smg and then look at the audit logs. If you wanna test tls from command line. Google openssl tls smtp test. And yes the smg Definitely supports tls and tls start. Lates.


  • 3.  RE: TLS support

    Posted 11-07-2019 01:51 PM
      |   view attached

    Actually found the solution, https://support.symantec.com/us/en/article.howto58876.htmland now SMG responds with a proper STARTTLS response:

     



  • 4.  RE: TLS support

    Posted 11-08-2019 01:17 AM
    Like I said telnet only shows if tls is a available on the remote end. U can't test it specifically. The admin guide has more info on how to set up tls. Lates