Ghost Solution Suite

Expand all | Collapse all

iPXE Error PXE-E99 Unexpected Error 6

Jump to Best Answer
  • 1.  iPXE Error PXE-E99 Unexpected Error 6

    Posted 12-02-2019 11:25 AM
      |   view attached

    Hi All,

     

    Recently upgraded out ghost servers (server 2019)

    2 done no problems - ipxe works great 

    1 server works fine apart from iPXE - exactly the same config, settings and files used as 2 working Ghost Servers

    When ever I try to boot to iPXE i get an error PXE-E99: Unexpected Error (6)

    Failed to start the image fileFailed to read/process proxy responseFailed to PXE boot 

    Failed to start the application

    I reisntalled Server 2019 and all of the Ghost software but still get the same error, reinstalled the GSS ipxe addon and pxe server ipxe addon

    Regenerated the ipxe winpe boot image 

    I have double checked the iis settings on the 2 working servers and the configs/settings/user details are the same 

    Clucthing at straws now as to what could be the issue 

    Tested standard PXE and works fine

     

    Thanks

    Jon



  • 2.  RE: iPXE Error PXE-E99 Unexpected Error 6

    Posted 12-02-2019 02:38 PM

    You didn't mention the version of ghost but there is an issue introduced in 3.3 RU3 and I have made it my default to put it on every RU3 pxe server even if the server is working because some environments some systems do work and other models don't so I just default to using this.   

     

    TECH256162
    Unable to get PXE boot menu on specific client model after upgrading to GSS 3.3 RU3  
    Last Updated September 26, 2019
    https://www.symantec.com/docs/TECH256162

     

    I realise your error isn't directly related but I have seen a lot of different failures resolved with that update.   It is 2 files that get replaced and would be an easy test just to see if that is the issue or not.  

    Let us know if you are on RU3 and if so does this change the behavior you are seeing.

    Cheers. 



  • 3.  RE: iPXE Error PXE-E99 Unexpected Error 6

    Posted 12-03-2019 04:04 AM

    Hi

     

    Thanks for the reply

    Yes i forgot to mention - we are running 3.3 RU2 - we did some test with RU3 installed but had a few errors so settled with RU2

    Will give those files a test later this afternoon when im back on site - fingers crossed. 

    Main thing i dont understand is that the servers, software, configs etc are the same on each site and the PCs/Laptops that are in the console are the same 

     

    The online possible thing i can think of (but not sure if it would make a difference on not) I backed up the express DB from the old server and restored it on the new server. I kept the server name the same and the IP address and then shut down the old server. Could there be some sort of issue caused be moving the DB from the old server ? The old server didnt have iPXE installed but the other 2 did

    Thanks

    Jon



  • 4.  RE: iPXE Error PXE-E99 Unexpected Error 6

    Posted 12-03-2019 12:49 PM

    I tried the suggestion above and now i get a different error

     

    Now it says 

     

    PXE-E99 Unexpected Error (6)

    No configuration methods succeeded (http://ipxe.org/040ee1806)

     



  • 5.  RE: iPXE Error PXE-E99 Unexpected Error 6

    Posted 12-03-2019 01:18 PM

    I tried the update files

    I still get an error but a slightly different one this time

     

    PXE-E99 Unexpected Error (6)

    No configuration methods succedded (http://ipxe.org/040ee186)



  • 6.  RE: iPXE Error PXE-E99 Unexpected Error 6

    Posted 12-04-2019 06:59 PM

    Ok so a follow up question.   If I track the steps right.   You have a old server that didn't have ipxe.   Then you installed a new server with IPX using the same name and IP.   And then migraged the original DB over to the new server?


    I think it would take some effort to prove this theory true or faulse but here goes.     Upon instlling IPXE components in GSS the service account is required.   It isn't required because it needs rights to update files on the server or set up services.   But it is required and I think maybe even notes it in the GUI,  it needs access to the DB so that the DB can be updated.   

    So my theory if what I think you are saying and I have noted in the first paragraph is that your server has IPXE installed but your DB that you are running isn't upgraded to be aware of the IPXE feature and so it is being ignored?   

    If I am not making too many assumptions I think you need to run the ipxe installer a second time on this server and tell it to perform a repair.    I would go to the dssetup folder and run the GSSServeriPXEAddon.msi  And then the PXEServeriPXEAddon.msi .   Although likely only the GSSServeriPXEAddon needs to be "repaired"

    I hope this is useful as a suggestion I have made some recent suggestions that proved I really didn't understand the situation correctly and maybe should have asked more questins.   But on the forums some times it takes so long with the time to respond back and forth I just want to put out all the info I can think of and not hold back any thing.   I think on this one the suggestion and my understanding are sound but if not please let me know where I should better be tracing.

     

    Thanks

     



  • 7.  RE: iPXE Error PXE-E99 Unexpected Error 6
    Best Answer

    Posted 12-17-2019 03:59 AM

    thanks for the suggestions - i tried this but didnt seem to resolve the issue 

    i ended up wiping and installing GU 3.3 and ipxe - restored the DB and then upgraded to RU 2 and did the ipxe upgrades - so far it seems to working 

     

    Thanks for your suggestions