Client Management Suite

Expand all | Collapse all

Installation fails

  • 1.  Installation fails

    Posted 09-19-2019 09:11 AM

    Hey guys,

    for testing purposes I want to Install the Trial Version of the Client Management Suiteon a VM.

    The VM looks as follows:

    8 Processor Cores (host got an i7-8750H)
    12Gb RAM
    300Gb HDD (SSD on Host)
    Windows Server 2016

    I already have a virtual environment into which I want to integrate the Suite to evaluate some functions. Unfortunately, the Installation always runs into a "Critical Failure" during the confuguration at step 6 "Pre-Configuration"

    Here is a screenshot of the message (unfortunately in german, hope it helps you anyway)

    error message

     

    I was searching a bit and it may be related to IIS. The installation pre-requisites states everything is fine, just gives a warning because I am using SQL Server 2016 Express (which is enough for my purpose).

    If you guys have any ideas on how to fix it I'd appreciate it. If you need any further information I will try to provide it.

    Thanks in advance.



  • 2.  RE: Installation fails

    Posted 09-19-2019 02:32 PM

    Hi Savin,

    1. Could you please post a screenshot of the "LogViewer" error message?
    2. Is TLS 1.0 or 1.1 disabled on the Server? If yes try to enable TLS 1.0 and 1.1 and disable it after the Installation..
    3. Is TCP/IP enabled in SQL Server Express (take a look at the SQL Server Network Configuration)

    Network23



  • 3.  RE: Installation fails

    Posted 09-19-2019 06:02 PM

    Hey Network23,

    thanks for your answer.

    1. Here is the Screenshot of the error message

     

    2. TLS 1.0  and 1.1. both were activated according to IIS Crypto

    3. TCP/IP was deactivated. I activated it, rebooted the VM and tried again. Unfortunately the same result. The screenshot above is after the activation of TCP/IP



  • 4.  RE: Installation fails

    Posted 09-20-2019 01:38 AM

    Good morning Svain!

     

    1. For this clean installation of "CMS 8.5", you are using clean installed Windows Server OS with manually pre-configured IIS?

    For you Default Web Site where you are trying to install CMS, you have the same settings like on picture below?

     

    2. 

    • What credentials you've specified for Notification Server (local administrator or domain account which is also as local administrator on this Server?)
    • What you've specified for 'FQDN:' there? Short name or FQDN? (Make sure that this Server correctly resolves itself by own short name & by own FQDN

    If there are problems with DNS resolving for this Server, fix DNS problems or its just a test environment which will not be converted to production, you can try to use a localhost as FQDN of course if you are not using HTTPs enabled

    3. Make sure that this Windows Server where CMS configuration fails, doesn't have any such a group policies that do not allow Web Access for local accounts as well as domain accounts.

     

    In case if you will need to change NS configuration settings, you can open "Symantec Installation Manager" ⇒ 'Configure Settings' ⇒ 'Configure NS Settings' ⇒

     

    Best regards,

    IP.



  • 5.  RE: Installation fails

    Posted 09-20-2019 05:29 AM

    Hi Igor,

    thanks for your suggestions. I tried/checked the things you mentioned.

    1. I am using a fresh installed Windows Server 2016. I did not configure IIS manually, I used the automatic configuration from the installer in the installation readiness check.The IIS Settings look like on the Screenshot you posted

    2. I am using the credentials of a domain admin. I added him to the local administrator group. On the FQDN I added a new certificate with localhost as FQDN.

    3. I checked the GPOs, there is no such GPO which blocks web access.

     

    I made some screenshots of the configuration I did during installation. Maybe this helps.

    But unfortunately, I still get the same error.



  • 6.  RE: Installation fails

    Posted 09-20-2019 06:00 AM

    Hey,
    its me again.

    I checked again and noticed something.

    On the NS config page, where you can edit the config after the installation, I noticed that the certificate went back to the "old" certificate instead of using the localhost. Tried it a 2nd time but it happened again. How can I force it to use the certificate for localhost instead of the FQDN?



  • 7.  RE: Installation fails

    Posted 09-20-2019 07:06 AM

    (If you specify 'localhost' as FQDN: there and check 'Require HTTPS to access Notification Server", then SIM will generate this self-signed certificate. In IIS Manager you can check bindings settings for Default Web Site, click 'Edit' for :443 and there will be a drop-down menu with available certificates. This generated certificate will has name of your NS Server machine but if you will double click it, there will be shown that certificate issuer is localhost and issued to localhost) I will don't suggest to use https required and use localhost since if you will have managed clients and would like to communicate them via HTTPs then SSL Handshake won't work due localhost name in this cert)

    Let's do not use localhost now as NS name there since we see same failure and also in case of HTTPs required usage.

    Other things:

    • What settings you have for Default Web Site in IIS Manager for 'Authentication' options?

    • Try to use just shortname "ServerName" without dns suffixes if in 1st time you've used full name"ServerName.domain.com" and configuration attempt failed.
    • Try to use just fullname "ServerName.domain.com" if in 1st time you've used shortname 'ServerName" and configuration attempt failed.

    Or actually you can open cmd on your server and check command to see how your machine resolved by dns

    nslookup shortname

    nslookup fullname

     

    • Did you try to use .\Administrator local account instead of domain account? If you will have installed/configured CMS 8.5, then you will be able to change NS AppIdentity account to any other via Symantec Installation Manager.


  • 8.  RE: Installation fails

    Posted 09-20-2019 09:40 AM

    Hey,

    I checked the DNS with nslookup, both names get resovled correctly. The local admin does not have the needed rights, atleast thats what the installer says. The domain admin does get accepted and is the user I used before.

    The IIS Authentication settings look exactly like in your screenshot (Anonymous enable, all the others disabled).

     

    So with the FQDN. Is there any other field where I need to specify the FQDN than in the NS settings when I create a new certificate? (Which I understood I dont need as long as I dont use https)



  • 9.  RE: Installation fails

    Posted 09-20-2019 11:16 AM

    1. Seems like expected, because you installed SQL server using currently logged in Domain account and didn't add there any local accounts

    Actually you can add local administrator in SQL server security role, using SQL cmd (without reinstalling SQL Server) Assume that lot of posts are available in google search how to do this.

    2. Before CMS 8.5 install, you only need to specify hostname in 'FQDN:' field on "Notification Server Configuration" page of Symantec Installation Manager (like we see it above) but I see that you seems like checked 'required HTTPS' before and now "FQDN:" field isn't available.

    If you don't need HTTPS enabled, go to IIS Manager and delete HTTPs :443 binding for Default Web Site, so then "FQDN:" field should appear on "Notification Server Configuration" page of Symantec Installation Manager