Idea Details

<Device Name> or <Remote IP> option

Last activity 06-13-2019 10:13 AM
i.kuchin's profile image
07-27-2016 06:57 AM


Hello!

I suggest add to CA Privileged Access Manager besides options <user>, <password>, <Local IP> and <First Port> additional option - <Device Name> or <Remote IP>. This option needs when we use 3rd party applications like xShell or WinSCP with PAM and configure TCP/UDP Service for it.  When user runs this applications he can see in window title information about local connection settings (like root@127.0.0.202, see screenshot in attachment) and it is really confused when user works with a lot of target systems.

WinSCP for example supports option /sessionname that allows to add to windows title specific information. So if PAM could paste to this parameter Device Name or IP address of target system it will be best solution for this issue.


Comments

05-17-2018 03:13 PM

Use the below configuration in your TCP services to show the title bar with the server name

C:\Test\WinSCP.exe sftp://<user>:<password>@<Device Name>:<First Port>

07-18-2017 07:35 AM

Hi elmiro.neto,

 

You should create TCP/UDP Service with next Client Application String:

C:\PROGRA~1\NETSAR~1\XSHELL~1\XSHELL.EXE -url ssh://<username>:<password>@<Local IP>:<First Port>

 

 

If you want to open sessions in different XShell tabs, select option Always dailog based as shown below.

 

07-17-2017 04:47 PM

Could someone tell me the procedure to integrate CA PAM with XSHELL?

07-10-2017 10:49 AM

Then this idea should be marked as delivered and the option should be added in the documentation.

07-10-2017 10:13 AM

Yes, this is a question of the PAM version. The "<Device Name>” parameter was added in 2.8.2.

07-05-2017 03:16 PM

I have tried adding the /sessionname=<Device Name> at the end of my WinSCP service.  It reads as follows:

 

C:\Programs\WinSCP\WinSCP.exe sftp://<user>:<password>@<Local IP>:<First Port> /sessionname=<Device Name>

 

When I launch WinSCP from the device it comes up like this

Am I using /sessionname properly?  Is the <Device Name> variable dependent on a PAM or WinSCP version (currently running 2.7.1)?

As a test, I used /sessionname=<user> and that seemed to work?

06-28-2017 11:28 AM

Hello, sorry, we missed this earlier and only noticed it after today's updates. This variable exists. It's "<Device Name>”. For WinSCP you would use it like /sessionname=<Device Name> . This resolves to the device name (not address) in the device configuration.

06-28-2017 09:52 AM

You can actually make a change on the server side that will make the title of the server display in the window title instead of 127.0.0.x. Add the below code to /etc/profile (OS specific):

 

For Linux

printf "\033]0;%s@%s:%s\007" "${USER}" "${HOSTNAME%%.*}" "${PWD/#$HOME/~}"

 

For AIX this is what needs to be added to the /etc/profile

 

export SERVER=$(hostname)

case "$TERM" in

xterm*|rxvt*)

    PROMPT_COMMAND="\033]0;${USER}@${SERVER}\007"

    echo $PROMPT_COMMAND

    ;;

*)

    ;;

esac

 

For Solaris

Add these lines to /etc/profile

 

SERVER=$(hostname)

export SERVER

case "$TERM" in

xterm*|rxvt*)

    PROMPT_COMMAND="\033]0;${USER}@${SERVER}\007"

    echo $PROMPT_COMMAND

    ;;

*)

    ;;

esac

06-28-2017 08:34 AM

I also agree with this requirement, users find CA PAM unusable because of this problem: having 12.7.0.0.X displayed is especially annoying when users need to open multiple sessions: users see multiple windows (or tab) with the same title bar and cannot distinguished the remote computer.

08-22-2016 12:35 AM

I agree with this this requirement, I also have ran into similar situation where I am launching a web application with native browser and it displays "127.0.0.x"  ip address instead of the actual device IP/device name. At times the end users are confused and we get a lot of queries thereafter.