Idea Details

Plex EJB generation version: obsolete V2.0

Last activity 06-13-2019 10:08 AM
BRUNO AGOSTINHO's profile image
04-23-2015 06:56 AM

Regarding EJB generation version, Plex only support versions 1.1 and 2.0. These two versions have final release dates 1999-12-17 and 2001-08-22 respectively.

The version 2.1 (with final release date from 2003-11-24) is not supported by Plex generator. So, Plex is frozen in time regarding EJB related issues.

We are actually using EJBs V2.0 in IBM WebSphere,  but currently there are Application Servers that not support such an old EJB version. For example, we tried to deploy our application using IBM Liberty Profile but only EJB V3.0 or newer are supported.  Note that EJB V3.0 is not new: it was released in 2006!

So, it is time to update Plex’ s EJB versions.


Comments

01-18-2016 05:55 AM

Hello All,

  We have been discussing about this feature (EJB 3.X support in Plex) with product management team. As part of this process we would like to gather different use cases where Plex EJB connectors are being used. We are requesting customers whoever is using CA Plex EJB connectors to upload a sample model which closely depicts their production model.

You can uploaded the models here under this thread or directly send it across to my mail(kanbr05@ca.com).

Thanks,

Brahmaji.

04-23-2015 09:46 AM

good...

04-23-2015 09:33 AM

Understood, was just informing Jorge that the ActiveX library had been updated but unfortunately for you the EJB support needs some attention.

04-23-2015 09:28 AM

Hi,

I'm not referring the use of third party javaBeans but the JavaBeans generated by Plex to implement a CA Plex EJB connector

04-23-2015 09:19 AM

04-23-2015 08:40 AM

What to say about Protoview at 2015...CA MUST refurbish Active library and its dependencies...for EJB the same...at its time,EJB generator was not a free one, by far