Idea Details

IBM_SVC probe

Last activity 06-13-2019 09:35 AM
Anon Anon's profile image
09-04-2015 02:50 PM

The new version of the operating system for the IBM v7000 no longer supports SSH for connectivity.  As a result we have lost the ability to monitor these devices with ibm_svc version 1.4  This idea is to include TLS as an authentication  protocol.  This would seem to be a critical issue for us and probably other customers using the ibm_svc probe.

 

The second request is to add the ability for the ibm_svc probe to notify, via an alarm, if a bad drive has been taken off line.  This would enable us to request a change window so we can swap out the failed drive.  The current version of the probe does not have this functionality.


Comments

04-22-2016 08:54 AM

I noticed that the default port 5988, doesn't work. When opening up the secure port 5989 in the firewall and changing the profile, it now seems to work. At least the communication works, UIM can now speak to V7000.
BUT... it doesn't generate any alarm using the threshold setup. Even if try to setup an auto configuration med MDISK status, and using the threshold ">= 0" to generate an alarm. Nothing. Not in the log either. Same thing with auto config of %Used of Pool or Cluster. with threshold ">= 0". Nothing!

I've tried all different type of threshold values trying to generate an alarm, but no success.

 

I've created a case. Will upload log and cfg in couple of minutes.

Case number: 00366728

04-15-2016 12:12 PM

I'll check with support and get back to you on this soon.

In the meantime can you forward the support case numbers to me over mail.

04-15-2016 11:52 AM

Totally agree.  Version 1.06 is very buggy.  We actually stopped upgrading and have told our customers that we cannot monitor the storage devices.

04-15-2016 05:01 AM

Does anyone get this working?

Testing the probe with an admin account works, it says that the V7000/SVC is responding. But the profiles and all monitors doesn't seem to work, and the probe seems to have problem connecting and becomes red(error state). The probe is really buggy, and slow. Not possible to apply any new settings if I don't close and open up the probe again, sometimes I even need to deact/activate the probe again.

Is this the problem? Checking the firewall and can't get any response back when using port 5988. Even when I set no limits in the firewall. From the UIM-server to V7000 Gen 2 (not the other way around tho).

Does it matter if I use SVC or V7000 as storage type? I mean, V7000 uses SVC as well? I've tried both... same issues.

03-04-2016 04:27 AM

Released version 1.06

01-27-2016 04:30 AM

EelcoD is testing a beta version, but this idea is still flagged as new

01-26-2016 09:31 AM

Great news, thanks!!

01-26-2016 09:07 AM

we are testing a beta version, still some issues which need to be resolved

01-26-2016 08:28 AM

Any news here? Really need a good working SVC-probe.

12-09-2015 06:16 AM

As a temporary workaround I have created a custom probe that uses the lsmdisk, lsvdisk and iostats command to get at least the status and latencies of all disks and volumes. I do not want to publish it here because it is only a temporary probe and it lacks proper documentation, but feel free to contact me if you want it.

 

Regards,

Gijsbert

12-08-2015 09:30 AM

Opened a case for this got back that a new release with a fix for this will be released in Q1 2016. In the meantime IBM allready released V7.6.0.0.

Developement  is running slow for this probe to get this fixed. V7.4 is available for more then 1 year.

12-07-2015 05:02 AM

Yupp, we need this urgently.

12-01-2015 05:56 AM

One of our customers is facing the exact same problem. I hope we can push this bit

10-13-2015 05:53 PM

Done thank you.  I believe this has already been placed in to development status.  Hopefully a new version by year end.

10-13-2015 05:44 PM

dan1-h, just noticed this idea is not showing up in the list of ideas, probably because the category is missing. Would you mind editing this idea and selecting the "CA Unified Infrastructure Management (f/k/a Nimsoft Monitor)" category?

10-07-2015 11:10 AM

Based on IBM documentation, IBM has increased the security level to connect to the V7000 SMI-S server, starting on firmware 7.4. This IBM documentation shows that there are 3 possible security levels and none of them allow SSL 3.0. Only TLS 1.0 and 1.2 are allowed.

 

My customer is testing the probe against two V7000 boxes:

  • The one running firmware 6.4 works fine!
  • The one running firmware 7.4 can not connect to the SMI-S server, reporting a "Connection reset" error in the log file.

 

I agree with dan1-h, it would seem to be a critical issue for every customer who decides to upgrade the V7000 firmware.

 

If anyone knows if there is a way to allow V7000 v7.4+ to use SSL 3.0, please let me know.