CA Workload Automation ESP Edition

Expand all | Collapse all

Cant complete application

Jump to Best Answer
  • 1.  Cant complete application

    Posted 02-24-2020 11:47 AM
    Edited by Isaac Toro Vera 02-24-2020 11:48 AM
      |   view attached
    Hi everyone,
    I have many application in Processing state but all jobs are completed. I tried to complete the applications manually but i got an error which said "is not an active application managed by the Manager."

    How could I complete them?. I have a CAWA DE 12.1 in Linux Red Hat 7 and Oracle DB.

    Thanks,
    Isaac


  • 2.  RE: Cant complete application
    Best Answer

    Posted 02-24-2020 12:09 PM

    You should not need to manually complete jobs/applications.

    Can you check the agentparm.txt file on the server and note the setting of oscompoment.noexitcode.

    oscomponent.noexitcode
    Specifies the exit code that tells the agent not to send a completion code to the scheduling manager host.
    Limits: 1-255
    Default: 255 for UNIX, 127 for Windows

    If the oscomponent.noexitcode is not present in the agentparm.txt then the default value of 255 is used.

    If a script exits with 255 or -1 the job will not be marked complete.

    Also check the transmitter.log to see what is sent/not sent from agent.



    ------------------------------
    Senior Systems Analyst
    UPS
    ------------------------------



  • 3.  RE: Cant complete application

    Posted 02-24-2020 01:38 PM
      |   view attached
    Hi Rick,
    Thanks a lot for your response. In the agentparm.txt file that property has the 255 value. Should i change it? which value?

    Thanks again


  • 4.  RE: Cant complete application

    Posted 02-24-2020 01:59 PM

    Prior to making any changes I would recommend what the script/program exited with.

    If it exits with a 255 or a -1 the job will remain in the Processing/Executing state.

    Are you able to determine how the script/program exited?

    Does the program log it's exit status?



    ------------------------------
    Senior Systems Analyst
    UPS
    ------------------------------



  • 5.  RE: Cant complete application

    Posted 02-24-2020 02:30 PM
    Yes, it exits with 255


  • 6.  RE: Cant complete application

    Posted 02-25-2020 09:10 AM

    ​I have also set oscomponent.noexitcode=256.

    If you create a simple test job you can test before making the change and after to confirm things work as expected.

    This is an example for CA Workload Automation ESP Edition:

    LINUX_JOB NIXCMD            

       AGENT %USER1            

       CMDNAME <valid shell>        

       USER <valid user>          

       ARGS -c 'exit %USER1'    

       RUN     ANYDAY          

    ENDJOB  


    You will need to provide a <valid shell> and a <valid user>.

    Trigger event USER1 is agent, USER2 is exit code.



    ------------------------------
    Senior Systems Analyst
    UPS
    ------------------------------



  • 7.  RE: Cant complete application

    Posted 03-06-2020 02:29 AM
    did your issue has been solved?


  • 8.  RE: Cant complete application

    Posted 02-24-2020 12:10 PM
    Hi Isaac,
    I would suggest opening a case.  This may take some investigation....

    Don


  • 9.  RE: Cant complete application

    Posted 02-25-2020 06:24 AM
    Please change noexitcode to 256. As 255 is max exit code in linux, your job will fail when your script fails with 255 RC.

    ------------------------------
    MTS IV Consultant
    Verizon India
    ------------------------------



  • 10.  RE: Cant complete application

    Posted 02-25-2020 10:41 AM
    Thanks a lot to all of your responses. I would like to give more context to my problem.
    I was implementing the HA, i did it following all the steps described in the techdocs.broadcom.com (i have implemented this many times), everything was going well until that i run the standby manager service up, it caused the primary manager service was down. This problem happened a couple of times, and after I executed changerole option in ADMIN perspective, and finally the configuration HA was going to work OK.

    Later, reviewing the plataform i realize close to 90 appications was in "Processing" state but all their jobs was in "complete" state. Was in this moment when i asked for help here.

    Yesterday, i found the table esp_wss_appl, which feeds the monitor perspective, i executed some queries against it and all the applications i have in "Processing" state were in status "1" and with field complete_date_time empty. I dont know if here the problem, or maybe this fact could help to find out a solution.

    Thanks all of you again.


  • 11.  RE: Cant complete application

    Posted 02-25-2020 11:24 AM
    Hi Isacc,

    It seems you posted in the wrong community.

    Please post it in the DE community below:
    https://community.broadcom.com/enterprisesoftware/communities/communityhomeblogs?CommunityKey=01f9af04-bcec-4c48-8697-829ab833175a

    Thank you,

    Lucy