Gen

GEN 8.6 runtimes are COBOL 5

  • 1.  GEN 8.6 runtimes are COBOL 5

    Broadcom Employee
    Posted 09-15-2016 02:29 PM

    But this does not mean customers must upgrade to COBOL 5 to use Gen 8.6. It means the Language Environment must include support for COBOL 5.X.

     

    Gen 8.6 for z/OS runtimes are compiled using COBOL 5.1, so the Language Environment must include support for COBOL 5.X or else the SMP/E APPLY job for the Gen 8.6 COBOL runtime experiences link-edit failures.  IBM provides this support in a number of PTFs and the appropriate PTFs must be installed before Gen 8.6 is installed.

     

    After the Gen 8.6 product has been installed, Gen 8.6 applications can still be generated using COBOL 4.2 or any supported version of COBOL. The COBOL 4.2 Gen generated applications will be able to call and use Gen 8.6 COBOL 5.1 runtimes.  COBOL 4.2 Gen generated applications from releases prior to Gen 8.6 will also be able to use Gen 8.6 COBOL 5.1 runtimes.