CA Spool

Expand all | Collapse all

CA-Spool Java transform. Version dependencies

Jump to Best Answer
  • 1.  CA-Spool Java transform. Version dependencies

    Posted 09-30-2019 07:52 AM
    Hi

    As support of C AFP transformers is ended with CA-Spool V12, we plan to change to JAVA Transformers.
    Question: Can Java Transform R14 run with CA-Spool V12 and even CA Spool r11.7 ?

    ------------------------------
    Regards
    Ib Marthin
    ------------------------------


  • 2.  RE: CA-Spool Java transform. Version dependencies

    Posted 09-30-2019 08:48 AM
    Hi Ib,

    The CA Spool release and Java release have to match. So if you are using CA Spool 12.0 you have to use the Java Transformers 12.0. The same for CA Spool 14.0 that requires Java Transformers 14.0.
    CA Spool. 11.7 is no longer supported.

    Regards,
    Mario


  • 3.  RE: CA-Spool Java transform. Version dependencies

    Posted 09-30-2019 10:50 AM
    Hi Ib,
    Yes, the CA Spool 14.0 Java Transformers works with Spool 12.0, but not with CA Spool 11.7, which is no longer supported. 
    /Regards, Niels
    --

    Niels Worsoe Andersen
    CA Technologies. A Broadcom Company
    Sr Consulting Architect

    Tel: +44 1223 381305

    Telnet: +1381305

    Office: +81305 

    nielsworsoe.andersen@broadcom.com  






  • 4.  RE: CA-Spool Java transform. Version dependencies
    Best Answer

    Posted 10-01-2019 05:00 PM
    Hello LB,

    I'm the product manager for Spool. I'm in the process of getting ready to send out End of Life announcement for the C transformers as well as End of Service announcement for Spool r12. I'm targeting 18 months from now so around April 2021 it will take effect.

    If you need to see doc on how to migrate from C to Java transformers, take a look here: https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-mainframe-software/traditional-management/ca-spool/14-0/release-notes/migrating-from-afp-transformers-to-java-transformers.html

    Regards,
    Ed

    ------------------------------
    Product Manager Output Management
    Broadcom
    ------------------------------



  • 5.  RE: CA-Spool Java transform. Version dependencies

    Posted 10-02-2019 04:13 AM
    Thanks Ed - very usefull.
    Some more work to do than I expected though :-)

    One more: In /xenos/apps/ the nnn.d2eproj files are in ASCII. What is the recommended tool to edit these files with?
    I would very much avoid using my EBCDIC editor.in ISPF ISHELL.

    ------------------------------
    Regards
    Ib Marthin
    ------------------------------



  • 6.  RE: CA-Spool Java transform. Version dependencies

    Posted 10-03-2019 03:33 AM
    Never mind-
    Found : Specify the EA (Edit - ASCII) 

    ------------------------------
    Regards
    Ib Marthin
    ------------------------------



  • 7.  RE: CA-Spool Java transform. Version dependencies

    Posted 10-17-2019 05:29 AM
    I can't seem to find which JAVA version to use.
    If I set
    JAVA_HOME=products/java/J7.1_64
    Transformer task says:
    CEE3588S A call was made to a function in the AMODE 64 DLL /products/java/J7.1_64/bin/classic/libjvm.so from an AMODE 31 caller

    with this
    JAVA_HOME=/products/java/J6.0.1.SR8FP26
    Transformer task says:
    ESF4211 JNI FindClass failed


    ------------------------------
    Regards
    Ib Marthin
    ------------------------------



  • 8.  RE: CA-Spool Java transform. Version dependencies

    Posted 10-18-2019 07:05 AM
    Hi Ib,

    Here is the doc for the Java release requirement.

    Java Transformers on z/OS
    The following software prerequisites apply to the Java transformers that run on z/OS:
    • 31-bit SDK for z/OS, Java Technology Edition, V8 (5655-DGG), available at ibm.com.
    You can find it on this page:

    http://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-mainframe-software/traditional-management/ca-spool/14-0/installing-the-transformers.html#concept.dita_20d55850b9dfd96e07d6318be7631ec8bb5e401b_SoftwareRequirements

    Regards,
    Len Middleton
    CA Spool SE