Italian

 View Only
Expand all | Collapse all

Problemi di ping tra VM

lombardialess

lombardialessMar 15, 2012 03:38 PM

  • 1.  Problemi di ping tra VM

    Posted Mar 14, 2012 02:56 PM

    Ragazzi oramai molti di voi conoscono ahimè la mia situazione che ripeto per dovere di cronaca :

    1 PC desktop fisico ,su cui sono installati : Workstation, sulla quale ho installato un Host ESXi e una VM FreeNAS.

    1 MACbook pro, su cui gira : 1VM sulla quale ho installato windows x far girare VSphere

                                                 Da Vsphere mi connetto sull'host ESXi sul quale ci ho installato (al momento) 3VM così distribuite :

                                                                       1 con OS WIndows server 2008 R2 facente funzione di AD/ DC, DNS e DHCP

                                                                       1 con medesimo OS su cui gira Vcenter server e Viewcomposer

                                                                       1 su cui ho installato il connection server e quindi che uso per controllare tutto da View manager

    Per completezza vi dico anche che i due PC (Desktop e macbookpro) sono connessi tra di loro con uno switch  in una LAN privata utilizzando indirizzi privati di classe c, però vengo al dunque...

    Come mai dalle VM che ci sono sull' HOST non riesco a raggiungere il NAS che invece viene tranquillamente visto da VSPhere come dispositivo di memoria in rete?

    Le VM che girano sull'host ESXI, tra loro si "pingano senza problemi", ma al di fuori di quella cerchia non si riesce a pingare nulla, se non l'host.

    Preciso comunque che ho usato solo IP statici, e che l'unico IP pubblico a mia disposizione lo assegnerò al Security server in modo da porter accedere alla mia infrastruttura dalla rete internet.

    Come posso risolvere questi problemi di ping ?

    GRAZIE DELL'ATTENZIONE A TUTTI!

    Saverio.



  • 2.  RE: Problemi di ping tra VM

    Posted Mar 14, 2012 03:04 PM

    Ciao Saverio,

    vedo che ci hai preso gusto a smanettare :smileywink:

    comunque....per aiutarti servono maggiori dettagli:

    1) schermata della parte networking di Esxi

    2) che ip hai messo sulle vm e sul freenas

    3) cosa hai condiviso sul nas (share cifs, smb, nfs, iscsi)

    4) riesci a pingare il freenas da dentro le vm?

    Ultimo appunto....non chiamare il macbook > PC (si offende) e il vsphere client chiamalo nel modo giusto e non solo vsphere! :smileycool:



  • 3.  RE: Problemi di ping tra VM

    Posted Mar 14, 2012 03:18 PM

    Ciao Ale, più che gusto ci sto facendo una tesi di laurea, e considerato che l'appello è il 23 Aprile, devo anche darmi una mossa (nella mia tesi ringraziero voi della community perchè mi avete dato una mano immensa...    :smileyhappy: )....comunque:

    1)IP ESXi :192.168.150.13 DNS:192.168.150.2 (che poi è una delle VM sull host stesso che funge da DC e DNS)

    2)IP del FreeNAS: 192.168.150.3

    3) VM con AD ,DNS e DHCP : 192.168.150.2

    4) VM con Vcenter e Vcomposer : 192.168.150.7

    5) VM con Connection server :192.168.150.8

    Tengo a precisare che le macchine in 3,4 ,5 appartengono ad un dominio labvdi.local (non so se aggiungere anche il FreeNAS).

    Sul NAS ho condiviso NFS (Praticamente per fare tutto utilizzero un solo HDD- quello del PC-Desktop,sperando mi basti)

    Comunque il FreeNAS non lo pingo dalle VM, ma solo l'host che le ospita 192.168.150.13

    Quando provo a pingare il FreeNAS (ovviamente vale anche il viceversa) dalle VM l'errore che mi dà puoi vederlo nella schermata che ti ho allegato....

    mi dice che non raggiunge l'host corrispondente a se stessa praticamente....

    Grazie Ale... :smileyhappy:



  • 4.  RE: Problemi di ping tra VM

    Posted Mar 14, 2012 03:24 PM

    La schermata di come è configurato il networking di Esxi?



  • 5.  RE: Problemi di ping tra VM

    Posted Mar 14, 2012 03:29 PM

    Faccio prima a dirtelo :

    IP:192.168.150.13

    Preferred DNS: 192.168.150.2

    Netmask :255.255.255.0

    Gateway :192.168.150.1 (Che per adesso ho impostato così ovunque ma poi si vedrà se con queste macchine voglio uscire dalla mia LAN...)



  • 6.  RE: Problemi di ping tra VM

    Posted Mar 14, 2012 03:33 PM

    Ok, ma cosa c'è un vswitch solo? Le nic fisiche sono connesse tutte li?

    Oltre alla management ci sono anche altre porte vmk?



  • 7.  RE: Problemi di ping tra VM

    Posted Mar 14, 2012 03:39 PM

    Si Ale gli unici collegamenti reali sono quelli tra il mac e lo switch via cavo ethernet, e tra il desktop pc e lo stesso switch....

    Di adattatori di rete c'è solo il vmnic0, ti posto una schermata dall'inetrno del VSphere, così forse mi capisci meglio.....



  • 8.  RE: Problemi di ping tra VM

    Posted Mar 14, 2012 03:51 PM

    A livello di Esxi è tutto corretto.

    Il problema secondo me è a livello di workstation (non comunicano la vm esxi e la vm freenas)

    dalla freenas hai la possibilità di avere una console per provare un ping verso l'esxi?



  • 9.  RE: Problemi di ping tra VM

    Posted Mar 14, 2012 04:00 PM

    Ale non è nemmeno lì il problema, perchè con la schermata che ti posto, puoi notare con i tuoi occhi che l'host ESXi lo pingo dalla console del FreeNAS...

    Basta guardi in basso...



  • 10.  RE: Problemi di ping tra VM

    Posted Mar 14, 2012 04:17 PM

    A questo punto deve esserci qualcos'altro che hai configurato.

    Come ti abbiamo già detto è difficile fare analisi senza avere il tuo lab davanti.

    Le vm hanno una solo nic?

    Se fai un tracert dell'ip del freenas dalle vm che succede?

    se dal freenas fai un ping verso le vm (con firewall disabilitato) ti rispondono?



  • 11.  RE: Problemi di ping tra VM

    Posted Mar 14, 2012 04:25 PM

    Per il tracert che mi hai chiesto vd schermata allegata, per il ping dal freeNAS verso le VM, nemmeno questo va a buon fine e le VM hanno un solo nic.....Bridgiato sulla LAN...



  • 12.  RE: Problemi di ping tra VM

    Posted Mar 15, 2012 09:07 AM

    Saverio stavo riguardando la schermata del networking, la vmk1 con ip x.x.x.6 per cosa l'hai configurata?

    il gateway delle vm, del esxi e del freenas è il medesimo? Esiste o l'hai messo tanto per metterlo?



  • 13.  RE: Problemi di ping tra VM

    Posted Mar 15, 2012 09:13 AM

    Ciao Ale, buondì.... :smileyhappy:

    Allora l'ip x.x.x.6 l'ho assegnata al Kernel dell' host che all'inizio mi serviva per il vmotion, ma non avendo più bisogno di questo e nemmeno dell'ip, l'ho lasciato lì....

    Poi comunque il gateway l'ho impostato così per tutti, e l'ho messo per convenzione pari a x.x.x.1 , pochè l'avrebbe preso un gateway, però lo scopo della mia tesi e pare tutta la base dell'infrastruttura View in LAN locale, e poi accedervi mediante la rete satellitare....Quindi il Gateway non so se lo userò di fatto, o dici che comunque è necessario che lo assegni a qualcosa di fisicamente esistente?

    Non so, dammi dei consigli....



  • 14.  RE: Problemi di ping tra VM

    Posted Mar 15, 2012 10:58 AM

    Ale ma ci sei ancora ? Ho ho detto qualche boiata d'altri tempi per aver causato la tua fuga improvvisa? :smileyhappy:



  • 15.  RE: Problemi di ping tra VM

    Posted Mar 15, 2012 11:01 AM

    Magari sta lavorando...

    Ricorda sempre che questi forum sono basati sul volontariato di chi ci partecipa, non è un supporto ufficiale di VMware :smileyhappy:



  • 16.  RE: Problemi di ping tra VM

    Posted Mar 15, 2012 11:05 AM

    Certamente Luca, infatti sono gentile con tutti e non credo di aver mai mancato di rispetto a nessuno, anzi la mia tesi sta venendo fuori anche grazie al vostro aiuto, e questo ovviamente non mancherò di dirlo nei ringraziamenti della mia tesi...La mia era solo una battuta per capire se ho detto una cosa che non esiste sulla faccia della terra o meno....so che comunque una persona non può stare tutto il giorno davanti al pc come me che lo faccio perchè sono impegnato con la tesi...

    Detto ciò, rinnovo il ringraziamento a tutti voi che spesso chiarite i miei dubbi, spesso banali lo so, ma che inevitabilmente approcciando un mondo nuovo vengono fuori ....  :smileywink:



  • 17.  RE: Problemi di ping tra VM

    Posted Mar 15, 2012 11:35 AM

    Saverio ti rispondo tra un lavoro e l'altro quindi non aspettarti risposte "reattive" :smileycool:

    Il gateway ti servirà se ti serve uscire dalla rete locale, cosa che in questo momento non stai facendo.

    A questo punto a livello logico è tutto ok. Può essere un problema di firewall di esxi....anche se mi sembra strano, soprattutto se non hai toccato nulla.

    Non ricordo se te l'ho chiesto ma dalle vm riesci a pingare l'esxi e l'ip di una risorse esterna all'esxi (ad esempio il macbook pro)?



  • 18.  RE: Problemi di ping tra VM

    Posted Mar 15, 2012 11:43 AM

    Ale, l'host lo pingo, il mio MacBook no.... Anche io ho pensato al firewall di Esxi ma da dove si può modificare questo x poterlo disabilitare e fare le prove a fw disabilitato? Grazie...:)



  • 19.  RE: Problemi di ping tra VM

    Posted Mar 15, 2012 12:48 PM

    Non penso sia qualche blocco di esxi però se vuoi puoi controllare da vsphere client nella sezione configuration - security profile.

    Il problema secondo me è a livello di workstation, la scheda vmnic0 a cosa corrisponde in workstation? Come è configurata la parte networking in vmware workstation per l'esxi e per il freenas?

    Altro non saprei dirti ma visto che non riesci a pingare nemmeno il macbook, il ping si perde oltre l'esxi in uscita e arriva solo fino all'esxi in entrata.

    Come ti abbiamo già indicato per il tuo "custom" lab è difficile darti altre indicazioni...



  • 20.  RE: Problemi di ping tra VM

    Posted Mar 15, 2012 01:06 PM

    Ale, come ha appena scritto Andrea, sbloccando tutti i fw di ESXi non risolvo nulla, e come hai ancora più giustamente detto te, il problema sarà nella configurazione del networking di workstation, infatti come vedi nella schermata in allegato, la vmnet0 io l'ho messa in auto bridging, ma forse ho sbagliato li? Ti aggiungo che oltre al bridging automatico potrei scegliere quello con la eth0 oppure la eth1.....Secondo me siamo molto vicini alla svolta....Cosa mi consigli di cambiare nelle impostazioni  del networking?

    Grazie ancora Ale...:)



  • 21.  RE: Problemi di ping tra VM

    Posted Mar 15, 2012 01:08 PM

    Beh, scusa, ma eth0 e eth1 sono entrambe connesse alla tua rete locale? Altrimenti forzi il bridging con una di queste due che sia effettivamente connessa alla lan fisica.



  • 22.  RE: Problemi di ping tra VM

    Posted Mar 15, 2012 01:20 PM

    Luca la eth0 è connessa allo switch, ho forzato il bridging su questa e nemmeno così risolvo.... :smileysad:



  • 23.  RE: Problemi di ping tra VM

    Posted Mar 15, 2012 02:12 PM

    Allora ragazzi, sperando di rendervi la comprensione più semplice, per ciò che riguarda la mia tesi, ho fatto uno schema, molto semplice senza tanti fronzoli, in cui ho indicato pure gli indirizzi ip delle varie macchine fisiche e non....lo allego in questo messaggio sperando che qualcuno di voi possa darmi una mano....Grazie a tutti...



  • 24.  RE: Problemi di ping tra VM

    Posted Mar 15, 2012 12:54 PM

    Il firewall di ESXi non è in grado di filtrare il traffico delle VM, ma solo quello sulla management network... Quindi è improbabile sia lui.

    Visto che cmq ti serve per la tesi, puoi fare un disegno della rete a beneficio di tutti e di una maggiore comprensione della tua situazione.

    Al momento non riesco a rileggermi tutti i post precedenti, ma in messo c'è pure una doppia virtualizzazione, quindi un bel disegno con indicate le reti potrebbe chiarire la situazione :smileyhappy:



  • 25.  RE: Problemi di ping tra VM

    Posted Mar 15, 2012 09:05 AM

    Nessuno mi sà aiutare? Possibile? :smileysad:



  • 26.  RE: Problemi di ping tra VM

    Posted Mar 15, 2012 02:54 PM

    Comunque il problema è circoscritto al "mondo " delle VM create sull'host ESXi, poichè queste oltre a pingarsi tra loro e pingare l'host su cui risiedono , non riescono ad andare oltre....

    Quale può essere l'impostazione che mi da noia?

    L'host e il FreeNAS si pingano tra loro tranquillamente, mentre le VM oltre il loro mondo non vedono altro....



  • 27.  RE: Problemi di ping tra VM

    Posted Mar 15, 2012 03:25 PM

    Saverio dacci maggiori indicazioni sulla parte workstation, mettici un pò di print screen della parte networking di workstation di ogni vm (esxi e freenas)



  • 28.  RE: Problemi di ping tra VM

    Posted Mar 15, 2012 03:33 PM

    Ale ti ripeto che il problema con la Workstation non dovrebbe sussistere, poiche le VM oltre l'host esxi non riescono ad andare, nemmeno dall esterno, qualunque altra macchina non riesce a pingare nulla oltre l'host esxi....

    Per quanto riguarda l'host esxi, questo ha un adattatore di rete bridgiato con la spunta su "replicate phisical network connection state", stessa cosa dicasi per la VM del NAS.....Non credo ti serva un print screen....non c'è altro.... hai visto lo schema della rete su carta che ho postato?



  • 29.  RE: Problemi di ping tra VM

    Posted Mar 15, 2012 03:35 PM

    Potrebbe mica essere un problema di "permissions" che hanno i vari users per accedere alle VM, che si impostano da ogni singola VM e io ho lasciato quelli di default, tranne qualche variazione ininfluente che sto facendo adesso per provare?

    Grazie....



  • 30.  RE: Problemi di ping tra VM

    Posted Mar 15, 2012 03:38 PM

    Hai giocato con le permission di esxi?