Spanish

 View Only
  • 1.  Problema con Vmware Vcenter Converter

    Posted Jul 13, 2012 07:22 AM

    Buenos días,

    Tengo una maquina virtual de un servidor ESXI 5.0 que tengo que migrar a ESX 4.00 siguiendo las recomendaciones de un usuario del foro me comento que utilizara VMWARE VCENTER CONVERTER y que no lo hiciera a mano.

    Tras realizar la conversión, cuando voy por 4% me devuelve un error del tipo " AN ERROR OCURRED DURING THE CONVERSION " THE OPERATION EXPERIENCED A NETWORK ERROR" Alguien sabe el porque de este error? He mirado en google pero no sale prácticamente nada...

    Adjunto Logs,

    Muchas Gracias



  • 2.  RE: Problema con Vmware Vcenter Converter

    Posted Jul 13, 2012 07:42 AM

    Buenas

    Yo empezaría a preocuparme aquí:

    2012-07-12T11:23:58.670+02:00 [03108 error 'HttpConnectionPool'] [ConnectComplete] Connect error Se produjo un error durante el intento de conexión ya que la parte conectada no respondió adecuadamente tras un periodo de tiempo, o bien se produjo un error en la conexión establecida ya que el host conectado no ha podido responder.

    Mira a ver si lo haces mejor en 2 pasos (vm a imagen workstation) y luego restauras (vm from image).

    Saludos



  • 3.  RE: Problema con Vmware Vcenter Converter

    Posted Jul 13, 2012 07:55 AM

    Ok, he hecho la conversion a workstation 8.0, luego la podré restaurar a un esx 4.00 o tendré algún problema con la version de hardware?

    Gracias!



  • 4.  RE: Problema con Vmware Vcenter Converter

    Posted Jul 13, 2012 09:05 AM

    No creo que tengas un exceso de problemas (nunca lo he hecho)

    Si te da algún tema por controladoras o similar, puedes intentar sacar una imagen acronis o ghost y restaurarla contra una vm vacía.



  • 5.  RE: Problema con Vmware Vcenter Converter

    Posted Jul 13, 2012 04:02 PM

    Si ya hiciste la conversión a Workstation, la conversión a ESX 4 utilizando Converter no debiera darte ningún problema.  Yo ya he tenido que realizar los mismos pasos en algunas ocasiones y funciona bien.

    Probablemente los problemas que tuviste para usar Converter para pasar del ESXi 5 al ESX 4 se deba solamente a un problema de conectividad.

    Saludos,



  • 6.  RE: Problema con Vmware Vcenter Converter

    Posted Jul 16, 2012 11:59 AM

    Buenos días,

    En primer lugar agradeceros las respuestas, muchas gracias.

    En segundo lugar, comentaros que después de usar el Vmware Converter ahora tengo la *.vmdk en el Storage1 del Server, pero no puedo añadirla al Iventory al no estar la vmx, me he dejado algún paso?

    Me falta hacer algún restore o algo? Si tenéis algo de documentación también me sirve, gracias por vuestro tiempo una vez más

    PD : Adjunto screenshot.



  • 7.  RE: Problema con Vmware Vcenter Converter
    Best Answer

    Posted Jul 16, 2012 12:30 PM

    Buenas

    Puedes crear una VM sin disco y atachar ese disco.

    Si no te ha creado el vmx es porque ha dado algún fallo. Revisa los logs del converter a ver que ha pasado.

    Saludos



  • 8.  RE: Problema con Vmware Vcenter Converter

    Posted Jul 16, 2012 01:01 PM

    Ok, entonces para concluir :

    Teng 1 server X con ip 192.168.1.1 y ESXI 5.00, con una maquina virtual que tengo que migrar al server con Ip 192.168.1.2 Y ESX4.00.

    Cual es estas opciones exactas son es? para no cagarla más xD

    Muchisimas Gracias



  • 9.  RE: Problema con Vmware Vcenter Converter

    Posted Jul 16, 2012 01:18 PM

    Adjunto Logs del último trabajo, yo no he visto nada raro :/



  • 10.  RE: Problema con Vmware Vcenter Converter

    Posted Jul 16, 2012 03:09 PM

    Hola

    Mira aquí

    2012-07-16T14:57:28.457+02:00 [03776 info 'wizardController'] parameter>>> ThirdPartyHostedFilter ( <obj xmlns="urn:ConverterLogic" versionId="1.0" xsi:type="ArrayOfConverterLogicKeyValuePair"><ConverterLogicKeyValuePair xsi:type="ConverterLogicKeyValuePair"><key>microsoftVirtualPCVM</key><val xsi:type="xsd:string">Microsoft Virtual PC (*.vmc)</val></ConverterLogicKeyValuePair><ConverterLogicKeyValuePair xsi:type="ConverterLogicKeyValuePair"><key>parallelsVM</key><val xsi:type="xsd:string">Parallels Virtualization Products Image (*.pvs)</val></ConverterLogicKeyValuePair><ConverterLogicKeyValuePair xsi:type="ConverterLogicKeyValuePair"><key>livestateBackup</key><val xsi:type="xsd:string">Symantec LiveState Recovery Image (*.sv2i)</val></ConverterLogicKeyValuePair><ConverterLogicKeyValuePair xsi:type="ConverterLogicKeyValuePair"><key>shadowProtectBackup</key><val xsi:type="xsd:string">StorageCraft ShadowStor Image (*.spf)</val></ConverterLogicKeyValuePair><ConverterLogicKeyValuePair xsi:type="ConverterLogicKeyValuePair"><key>acronisBackup</key><val xsi:type="xsd:string">Acronis True Image Backup (*.tib)</val></ConverterLogicKeyValuePair><ConverterLogicKeyValuePair xsi:type="ConverterLogicKeyValuePair"><key>vmwareVCBBackup</key><val xsi:type="xsd:string">VMware Consolidated Backup (*.vmx)</val></ConverterLogicKeyValuePair></obj> )
    2012-07-16T14:57:28.457+02:00 [03776 info 'wizardController'] parameter>>> VMwareHostedFilter ( <obj xmlns="urn:ConverterLogic" versionId="1.0" xsi:type="ArrayOfConverterLogicKeyValuePair"><ConverterLogicKeyValuePair xsi:type="ConverterLogicKeyValuePair"><key>vmwareVM</key><val xsi:type="xsd:string">VMware virtual machine (*.vmx)</val></ConverterLogicKeyValuePair></obj> )
    2012-07-16T14:57:28.504+02:00 [03776 info 'wizardController'] FillPage()
    2012-07-16T14:57:28.504+02:00 [03576 error 'Default'] SourceSelectPluginModel::BuildFilter 3rd party type microsoftVirtualPCVM not found
    2012-07-16T14:57:28.504+02:00 [03576 error 'Default'] SourceSelectPluginModel::BuildFilter 3rd party type parallelsVM not found
    2012-07-16T14:57:28.504+02:00 [03576 error 'Default'] SourceSelectPluginModel::BuildFilter 3rd party type vmwareVCBBackup not found
    2012-07-16T14:57:28.504+02:00 [03576 error 'Default'] SourceSelectPluginModel::BuildFilter 3rd party type livestateBackup not found
    2012-07-16T14:57:28.504+02:00 [03576 error 'Default'] SourceSelectPluginModel::BuildFilter 3rd party type shadowProtectBackup not found
    2012-07-16T14:57:28.504+02:00 [03576 error 'Default'] SourceSelectPluginModel::BuildFilter 3rd party type acronisBackup not found
    2012-07-16T14:57:28.504+02:00 [03576 error 'Default'] SourceSelectPluginModel::BuildFilter 3rd party type vmwareVM not found
    2012-07-16T14:57:28.504+02:00 [03576 error 'Default'] SourceSelectPluginModel::BuildThirdpartyHostedExtVector 3rd party type vmwareVM not found
    2012-07-16T14:58:17.426+02:00 [03440 verbose 'HttpConnectionPool'] [RemoveConnection] Connection removed; cnx: [class Vmacore::Http::HttpConnectionPoolImpl::Cnx:043C0EB0]; pooled: 0
    2012-07-16T14:59:24.613+02:00 [03576 info 'ConverterSession'] Converter::Client::Gui::Common::DiagnosticDataProvider::SetLastKnownSource - Setting last known source:
    --> (converter.ComputerSpec) {
    -->    dynamicType = <unset>,
    -->    location = (converter.ComputerSpec.LiveComputerLocation) {
    -->       dynamicType = <unset>,
    -->       hostname = "ttyrt",
    -->       port = <unset>,
    -->       username = "ytytry",
    -->       password = (not shown),
    -->       osType = "windowsOs",
    -->       verifyPeer = true,
    -->       sslThumbprint = <unset>,
    -->    },
    --> }
    2012-07-16T14:59:43.442+02:00 [03576 info 'ConverterSession'] Converter::Client::Gui::Common::DiagnosticDataProvider::SetLastKnownSource - Setting last known source:
    --> (converter.ComputerSpec) {
    -->    dynamicType = <unset>,
    -->    location = (converter.ComputerSpec.ManagedVmLocation) {
    -->       dynamicType = <unset>,
    -->       vimConnect = (converter.VimConnectionSpec) {
    -->          dynamicType = <unset>,
    -->          hostname = "192.168.1.208",
    -->          port = <unset>,
    -->          credentials = (converter.VimConnectionSpec.LoginVimCredentials) {
    -->             dynamicType = <unset>,
    -->             username = "root",
    -->             password = (not shown),
    -->          },
    -->          verifyPeer = true,
    -->          sslThumbprint = <unset>,
    -->       },
    -->       vm = <unset>,
    -->       uuid = <unset>,
    -->       vmName = <unset>,
    -->    },
    --> }
    2012-07-16T14:59:43.442+02:00 [03576 info 'ConverterSession'] Converter::Client::Gui::Common::DiagnosticDataProvider::SetLastKnownSource - Setting last known source:
    --> (converter.ComputerSpec) {
    -->    dynamicType = <unset>,
    -->    location = (converter.ComputerSpec.ManagedVmLocation) {
    -->       dynamicType = <unset>,
    -->       vimConnect = (converter.VimConnectionSpec) {
    -->          dynamicType = <unset>,
    -->          hostname = "192.168.1.208",
    -->          port = <unset>,
    -->          credentials = (converter.VimConnectionSpec.LoginVimCredentials) {
    -->             dynamicType = <unset>,
    -->             username = "root",
    -->             password = (not shown),
    -->          },
    -->          verifyPeer = true,
    -->          sslThumbprint = <unset>,
    -->       },
    -->       vm = <unset>,
    -->       uuid = <unset>,
    -->       vmName = <unset>,
    -->    },
    --> }
    2012-07-16T14:59:43.442+02:00 [02396 verbose 'wizardController'] Trying connection to VC server '192.168.1.208' with user 'root'
    2012-07-16T14:59:43.442+02:00 [02396 verbose 'wizardController'] Getting VIM connection to 192.168.1.208...
    2012-07-16T14:59:43.442+02:00 [02396 info 'wizardController'] Connecting to host 192.168.1.208 on port 443
    2012-07-16T14:59:43.442+02:00 [02396 info 'wizardController'] localVersion is: vim.version.version7
    2012-07-16T14:59:43.442+02:00 [00996 error 'Default'] SSLStreamImpl::DoClientHandshake (04533fd0) SSL_connect failed. Dumping SSL error queue:
    2012-07-16T14:59:43.442+02:00 [00996 error 'Default'] [0] error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
    2012-07-16T14:59:43.442+02:00 [00996 error 'HttpConnectionPool'] [ConnectComplete] Connect error SSL Exception: The remote host certificate has these problems:
    -->
    --> * unable to get local issuer certificate
    -->
    --> * Host name does not match the subject name(s) in certificate.
    2012-07-16T14:59:43.442+02:00 [02396 warning 'wizardController'] CreateVimConnection has SSL certificate error while trying to connect, Error: SSL Exception: The remote host certificate has these problems:
    -->
    --> * unable to get local issuer certificate
    -->
    --> * Host name does not match the subject name(s) in certificate.
    -->
    2012-07-16T14:59:43.442+02:00 [02396 error 'wizardController'] GetVimConnection has error while trying to connect (3), Error: converter.fault.SSLVerificationFault
    -->
    2012-07-16T14:59:43.473+02:00 [03576 verbose 'SSLVerificationFailureHandler'] SSL thumbprint for 192.168.1.208:443 [30:18:52:04:6C:D5:2E:2A:D2:51:B0:58:A8:93:30:92:B3:45:7C:7E]
    2012-07-16T14:59:43.473+02:00 [03576 verbose 'SSLVerificationFailureHandler'] SSL error message is The remote host certificate has these problems:
    -->
    --> * unable to get local issuer certificate
    -->
    --> * Host name does not match the subject name(s) in certificate.
    2012-07-16T14:59:43.473+02:00 [03576 error 'SSLCertificateIgnorer'] Failed reading SSL thumbprint from registry.
    2012-07-16T14:59:46.301+02:00 [03576 info 'ConverterSession'] Converter::Client::Gui::Common::DiagnosticDataProvider::SetLastKnownSource - Setting last known source:
    --> (converter.ComputerSpec) {
    -->    dynamicType = <unset>,
    -->    location = (converter.ComputerSpec.ManagedVmLocation) {
    -->       dynamicType = <unset>,
    -->       vimConnect = (converter.VimConnectionSpec) {
    -->          dynamicType = <unset>,
    -->          hostname = "192.168.1.208",
    -->          port = <unset>,
    -->          credentials = (converter.VimConnectionSpec.LoginVimCredentials) {
    -->             dynamicType = <unset>,
    -->             username = "root",
    -->             password = (not shown),
    -->          },
    -->          verifyPeer = true,
    -->          sslThumbprint = "30:18:52:04:6C:D5:2E:2A:D2:51:B0:58:A8:93:30:92:B3:45:7C:7E",
    -->       },
    -->       vm = <unset>,
    -->       uuid = <unset>,
    -->       vmName = <unset>,
    -->    },
    --> }
    2012-07-16T14:59:46.301+02:00 [03576 info 'ConverterSession'] Converter::Client::Gui::Common::DiagnosticDataProvider::SetLastKnownSource - Setting last known source:
    --> (converter.ComputerSpec) {
    -->    dynamicType = <unset>,
    -->    location = (converter.ComputerSpec.ManagedVmLocation) {
    -->       dynamicType = <unset>,
    -->       vimConnect = (converter.VimConnectionSpec) {
    -->          dynamicType = <unset>,
    -->          hostname = "192.168.1.208",
    -->          port = <unset>,
    -->          credentials = (converter.VimConnectionSpec.LoginVimCredentials) {
    -->             dynamicType = <unset>,
    -->             username = "root",
    -->             password = (not shown),
    -->          },
    -->          verifyPeer = true,
    -->          sslThumbprint = "30:18:52:04:6C:D5:2E:2A:D2:51:B0:58:A8:93:30:92:B3:45:7C:7E",
    -->       },
    -->       vm = <unset>,
    -->       uuid = <unset>,
    -->       vmName = <unset>,
    -->    },
    --> }
    2012-07-16T14:59:46.301+02:00 [00888 verbose 'wizardController'] Trying connection to VC server '192.168.1.208' with user 'root'
    2012-07-16T14:59:46.301+02:00 [00888 verbose 'wizardController'] Getting VIM connection to 192.168.1.208...
    2012-07-16T14:59:46.301+02:00 [00888 info 'wizardController'] Connecting to host 192.168.1.208 on port 443
    2012-07-16T14:59:46.301+02:00 [00888 info 'wizardController'] localVersion is: vim.version.version7
    2012-07-16T14:59:46.348+02:00 [00888 info 'wizardController'] Remote version is: vim.version.version5

    Creo que sigues con problemas. ¿es a 100 o a giga? ¿Tienes los drivers de red correctos?

    Saludos