Endpoint Management Solutions Beta Community

Expand all | Collapse all

Service Desk installation error

  • 1.  Service Desk installation error

    Posted 02-14-2011 04:37 PM

    Hi Guys,

    I know most of the support over the beta has ended, but really hoping someone can throw some ideas here?

    The first part of the install finishes successfully, but when i click on next it comes up with Application Error.

    Please see screen shots.

    I'm installaing SD7.1 on the NS Server, but i have SQL off box running on Win2008

    IIS has been changed to Classic and is running under the newly create Service Account.

    really appreciate the help on this.



  • 2.  RE: Service Desk installation error

    Posted 02-14-2011 05:46 PM

    With 7.0 you had to be sure that your SD/WF server had local admin rights on the SQL server... Might still be the case.



  • 3.  RE: Service Desk installation error

    Posted 02-14-2011 07:32 PM

    administrator login from admin@logicbase.com to something else during the install steps?  From what I can tell, I see Native authentication succeeded (so no AD authentication enabled).  You must first login as admin@logicbase.com pw:  admin.  What I've been told and what works for me is to always leave the default admin account, install with Navtive authentication, log in with the default admin account (logicbase) and then enable the AD authentication.  Also, Nurb's comment above was also a requirement.  On SQL2005, the local administrators group was a SQL admin by default.  On SQL 2008 it has to be specifically set up during install or done post install.



  • 4.  RE: Service Desk installation error

    Posted 02-14-2011 07:38 PM

    Leaving the admin account at the default password is a SEVERE security risk since its widly publisied what it is.  I changed mine at install time ( back then there was no tool to change it afterward ) and didn't have a problem with doing that.

     I have got bit a couple of times during test installs by forgetting to give the SD machine admin rights..  and feel stupid every time :)



  • 5.  RE: Service Desk installation error

    Posted 02-14-2011 07:52 PM

    I'm glad they gave us the ability to do this since the inital SD 7 release.  The restrictions of NS/SD 7.0 were too much to even consider upgrading, mostly the OS limitations, but also the SD setup steps and requirements were not acceptable by my organization's standards.  With SD 7.1 I've been fairly happy, even with the performance using only 3GB of RAM in a VM and on the same server as the ITMS.



  • 6.  RE: Service Desk installation error

    Posted 02-14-2011 08:05 PM

    Thanks guys, both make sense and ill give this a try in the morning.

    I would maybe like to add that i'm trying to upgrade my previous SD 7.0 install to 7.1 beta, so in essence i've built  2 new win2008 boxes and with the one server being the SQL 2008 server, i've attached the old Ensemble Database.

    Now in the SD setup, i chose to upgrade the old Ensemble database, but one thing i did note was that my admin account was set to something other than admin@logicbase.com.

    When doing an upgrade there isnt a way to change it back so this might be the case. The only way around that would be for me to create a new database with admin@logicbase.com, which would be my last resort. (kinda good practice this for the upgrade process from 7.0 to 7.1 though)

    Brentmtincher, any chance you could elaborate on the local admininstrators group with SQL 2008? I already did have both computer names as part of the local administrators group in windows on both servers, but do i need to add that group again to the Security login section within SQL 2008?

    Also, hwere is this tool located to change the admin@logicbase.com account password?

    Thanks guys, appreciate it!



  • 7.  RE: Service Desk installation error

    Posted 02-15-2011 04:11 PM

    I'm still on version 6.x in production and am going to migrate over.  For changing the administrator password, the instructions and tool is located at http://www.symantec.com/docs/TECH146586.

    For SQL, the database security is handled in the SQL Server Management Studio.  I am not sure how many different domain accounts you are using, but may want to temporarily make the install and service domain accounts a sysadmin in the server roles, so it has full access to any databases on the server.
     



  • 8.  RE: Service Desk installation error

    Posted 02-17-2011 07:44 PM

    You are happy with performance? wow. How many concurrent users do you have? New tickets per day and number of edits? Just curious as our performance was dismal due to our load, with some huge hardware thrown at it. ( and i have seen similar stories to mine around here )



  • 9.  RE: Service Desk installation error

    Posted 02-17-2011 07:45 PM

    There is no "upgrade" from HD6. ( or at least there isnt as of 7.0MR2 )



  • 10.  RE: Service Desk installation error

    Posted 02-17-2011 08:51 PM

    I only have a minor load on the Beta 7.1, and I have noticed a 3x improvement over 7.0 and on less hardware.  When I go prod, I am going to double the RAM and double processor speed on the MP and SD and carve out a new SQL box.



  • 11.  RE: Service Desk installation error

    Posted 02-17-2011 08:57 PM

    An upgrade from 6 would be impossible due to OS incompatibilities and product architecture differences.  If there were an upgrade option I would still choose to migrate to a clean server anyways.  We do this for all our OS and enterprise systems where applicable as upgrades tend to leave behind unwanted remnants of the previous installation.



  • 12.  RE: Service Desk installation error

    Posted 02-18-2011 12:36 AM

    Couldt get this sorted, so i ended up installing a new Win2003 64bit server and attached the old 7.0 MR2 SD database and did the upgrade. Went through first time.

    First issue i noticed though was that i had used a new Service Desk server name, so just after you submit your first Incident, it berings up an error, everything is still referencing the old server name.

    So then reloaded another new server under a new name and started from scratch (new database)....not ideal, but couldnt waist anymore time on this.

    So when 7.1 is released next month, by all means do an upgrade, but dont change server name....(Would be good if maybe a Migration document was released too...)



  • 13.  RE: Service Desk installation error

    Posted 02-18-2011 03:38 AM

    The server name issue sounds like a bit of a bug if the server name has to be the same.  You wouldn't be able to have both servers up part of the same domain at the same time.  At least for us, we are bypassing the 7.0 products and migrating from 6.x to 7.1 just like we skipped Vista and went XP to Win 7, but for people who have vested time into 7.0 I would hope they come out with decent upgrade documentation.  Did you have any issues with upgrading the rest of the ITMS?



  • 14.  RE: Service Desk installation error

    Posted 02-18-2011 09:10 AM

    its worse then you realize, you cant rename your SQL server either.  So you have no option for consolidation or side by side upgrades.

    This was a huge issue for me in the 7.0 beta days as you cant even have a valid QA/Dev/Training environments of  your portal. in my case even the WF cant be properly 'copied' as i have made a lot of changes in the portal that tie back to wf ( like groups, AD imports, custom variables, rights on various web parts )

    I found this out the hard way after spending literally days setting up our portal properly in dev and not being able to transfer a single thing over to our future production box.  Symantec's response was 'document your changes and reproduce them'. Personally this is NOT an answer, and made a long weekend for me redoing it at the last minute for a training class.

    Oh, and i bet you didn't notice but when you had the renamed server running you were also getting all sorts of errors from your AD imports and other SQL problems. i actually had the 2nd copy writing to 2 seperate databases, which is how i found out things are hardcoded both in SQL and on the WF sevrer. :(

    If it was all documented what to change i suppose it would possible, but there isnt any, even for the developers apparently.



  • 15.  RE: Service Desk installation error

    Posted 02-18-2011 10:00 AM

    ...i'm starting to get very nervous come March 2011!

    I personally look after 12 companies who have been waiting well over 6 months for 7.1 to be released.

    They're not doing the upgrades....i am!  Think i'll need to ask them wait a few months until we have some decent KB's on this stuff



  • 16.  RE: Service Desk installation error

    Posted 02-18-2011 11:25 AM

    We waited until MR2, thinking it would be a stable product by that point.  We wont be "upgrading" to 7.1



  • 17.  RE: Service Desk installation error

    Posted 02-18-2011 01:47 PM

    Because Helpdesk 6 loses all support come 9/4/2011, upper management wants it done prior to that.  We use the entire ITMS except for patching and remote control(still use WSUS for patching and probably sticking with RA instead of PCA), but SD is going to be the most difficult, especially from an end-user training perspective.  I am excited about it as I want to get off of the 2003 servers and on Windows 2008 R2 and SQL 2008 R2, and I will have several months to test and pilot before going live.  Hopefully they will have a MR for MP and SD by then to fix some of the bugs.