Intel,Altiris Group

Expand all | Collapse all

Query result do not match Target

  • 1.  Query result do not match Target

    Posted 03-01-2011 11:28 PM

    I enabled a new policy under " Remote Management\Remote Control\windows\pcAnywhere Setting\windows\pcAnywhere Settings_lab"

    Target: "Manage\Computers\Active Directory Domain\Labs\Computers" 

    When I run the query it display 300 computers, but the actual Container display 340 computers

    For the records, we are using Notification server 7 (sql server in different box)

    I am wondering if there is an option in NS to run or a query in SQL to fix the problem

    Any help would be appreciated

    Thanks

    Mark



  • 2.  RE: Query result do not match Target

    Posted 03-02-2011 01:01 AM

    are you only displaying the machines in lab that have pcA?  It doesn't sound like that is the case based on your question but the first thing that comes to mind is if you are pointing to all machines in the lab and you are excludeing machines not in the computers with pca.  If that is the case then are there 40 machines that don't have pcA yet but are in the lab?

    Also computer container is potentialy computers that are known about because of an AD import, but when you filter them you are only listing machines that have the altiris agent that can have a policy applied and so 40 machines don't have the altiris agent yet but do have a database record because of the AD import. 

    Just my off the top of my head Idea may not be of use.

    cheers.



  • 3.  RE: Query result do not match Target

    Posted 03-03-2011 08:28 PM

    Thanks for your comment ICHCB,

    I went through the computer resources, filter option and altiris agent report...there some discrepancies in the numbers of computer that should be displayed in the notification server and what is in the labs...

    we are working through the discovery option and membership update to make sure we get the correct numbers to make sure that will bring up what we should see at this time and then review the pcanywhere setting again

    Thanks for you



  • 4.  RE: Query result do not match Target

    Posted 03-07-2011 04:06 AM

    I Was viewing the filter options  "windows computers with NS 7 altiris agent" for one of the computer labs.

    It did not display all the computers that supposed to be talking to the server. Then I manually update the configuration and basic inventory options of one the computer that was not in the list. I refreshed the  filter for "windows computers with NS 7 altiris agent" and the machine show up in the list.. My understanding is that it should be an automatic process, but why some are updating and others not despite that they all can comunicate to the server?

    May be I could run a query or script to clean up the database, tables...etc...and see if that help....by the way I ran the purge option and duplicated computer name too, but still no much difference

    Any help would be appreciated

    Thanks



  • 5.  RE: Query result do not match Target

    Posted 03-08-2011 01:45 PM

    Sorry I don't know the core Symantec Managment Platform so much.   I think this should be posted in the main Symanted Managment Platform forum and those users will probably have good suggestions for us.

    cheers.



  • 6.  RE: Query result do not match Target

    Posted 03-08-2011 02:43 PM

    I'm not sure I understand what changed when you updated a configuration and sent a basic inventory.  What did you reconfigure?

    Obviously to be seen by the target it must be 1) managed/have the agent installed and 3) be part of the organizational group that is synchronzed with Active Directory.  Are you saying that the missing computers are in the organizational group, but don't have the agent, or they have the agent but aren't in the group, or neither, or somehow both?



  • 7.  RE: Query result do not match Target

    Posted 03-08-2011 11:28 PM

    What have changed?  the main changes in the Labs were machines updated from xp to windows 7  two months ago approx.

    Current Scenario:  Labs computers with windows 7 and altiris NS 7 installed (lab-01 to lab-40)

    Now, In Notificaiton Server 7, if I look in the Organization group for the "Lab-xx" I get following computer list

    Lab-04,Lab-06,Lab-07,Lab-12,Lab-13,Lab-16,Lab-21,Lab-25,Lab-30

    If I check the filters "Windows comptuers with NS 7 Altiris agent" for "Lab-xx" I get the following list

    Lab-02,Lab-07,Lab-08,Lab-10,Lab-12,Lab-14,Lab-17,Lab-23,Lab-29

    Things done so far in the server side: Purge Maintenance; Discover AD computers; Resource membership update; inventory report ran. I also created new test computer with windows 7 and altiris NS 7 installed and authenticated to server ok

     Thanks for your help

     

     



  • 8.  RE: Query result do not match Target

    Posted 03-09-2011 08:10 AM

    In NS7, if you go to Manage > Computers > Active Directory View and drill down until you get to Lab-xx, you see one set of computers, but if you check the NS7 Filter for 'Windows Computers with NS 7 Altiris Agent' installed, you see a different set of computers for Lab-xx?

    What is your synchronization schedule for Active Directory?  In your example, Lab-04 is in the OG but not the Filter.  Should it actually exist in the filter?  In your example, Lab-14 is in the filter but not the OG -- should it exist in the OG?  I'm trying to find out whether one is correct, or the other, or neither.

    Did you use Active Directory to initially discover these computers?



  • 9.  RE: Query result do not match Target

    Posted 03-09-2011 10:32 PM

    My apologies if things are a little confuse......

    The lab have 40 computers, Lab-01 to lab-40, all computers with windows 7 and NS 7 agent installed,

    When I run AD discover, I expect to see all the computers in the OG

    If I run membership update and inventory (anything else?), I expect to see all the computers in the Filters, but it is not happening, just some computers show up.......

    The synchronization schedule for AD is once a week (manually run twice this week)

     

     

     

     

     

     



  • 10.  RE: Query result do not match Target

    Posted 03-24-2011 12:25 AM

    Hi,

    I am posting this to NS forum, but thanks for you suggestions

    Regards