ITMS Administrator Group

Expand all | Collapse all

Inventory of ESXi servers

Jump to Best Answer
  • 1.  Inventory of ESXi servers

    Posted 04-06-2017 07:05 AM

    Hello,

    I am trying to collect the inventory on VMware ESXi servers in my enviroment.

    The network discovery task run fine. In the Virtual Machine Management page, I can see the host and corresponding guest servers.

    However when I try to run the VMM Inventory task nothing happens. In the main view the status is running, in detailed view it says queued for 2 days now.

    The VVM plugin is installed on NS.

    Any ideas ?

    Tomasz



  • 2.  RE: Inventory of ESXi servers

    Broadcom Employee
    Posted 04-06-2017 08:12 AM

    Hi Tomasz,

    1. You have correct credentials specified for "VMWare Protocol" in "Default Connection Profile"? What timeout is set for "VMWare protocol" credentials?

    2. please check this discussion https://www.symantec.com/connect/forums/tangled-tasks-policy-being-reconstructed-patch-management-distribution-task

    Probably your 'Server Side Tasks' such as VMM Inventory are stuck in queue.

    Thanks,

    IP.



  • 3.  RE: Inventory of ESXi servers

    Posted 04-06-2017 08:55 AM

    Hi Igor,

    Ad.1 I was successfuly able to scan and inventory the same VMware host from my test console that is placed in completely different country. For sure the credentials are correct. The timeout is default 30 seconds.

    The discovery task output looks ok.

    Total devices processed: 13
    New devices added: 0
    Devices updated: 13
    Device add failures: 0
    Device update failures: 0

     

    Ad.2 I have run the following query

    select * from TaskInstances ts
    Where taskserverguid = '6af1645a-97c4-45e5-832b-47409a776172' --NS guid
    order by StartTime desc

    There are number of tasks, I would say the number of tasks looks normal. For most tasks the InstanceStatus is 2 that stands to running.

    I also restarted the services on NS.

    What else I can check or how to find out the tasks name ?

    thanks

    Tomasz



  • 4.  RE: Inventory of ESXi servers

    Broadcom Employee
    Posted 04-07-2017 04:52 AM

    Tomasz, I've sent registry keys to enable more traces in NS log while task is running. Add registry keys and run a VMM Inventory task for ESX - check Altiris Log Viewer, to see what can be a root cause of such behavior.



  • 5.  RE: Inventory of ESXi servers

    Posted 04-07-2017 08:24 AM

    hi Igor,

    I enabled more traces in the log, unfortunetly there is nothing at verbose and trace level, and nothing useful in the Info stream. Now the task fails immediately:

    -----------------------------------------------------------------------------------------------------

    Starting task instance: 'Run VMM Inventory' (05aad509-6eb8-4243-8b79-b354e7db2fd3) from 'VMM Inventory' (926ba814-4151-421f-9be7-fbf60eb36580, 0ba3af3c-e4ea-4441-a15c-1ddb9f1bdedc)

    License for the VMM Solution is working properly 

    Agent XML at Sever side:-<vman><ConnectionParam /><command>vManInventoryTask</command><inputparams><vm><commands /></vm></inputparams><LicenseEnabled>true</LicenseEnabled></vman>

    Resuming task instance 'Run VMM Inventory' (05aad509-6eb8-4243-8b79-b354e7db2fd3), 07/04/2017 14:10:53

    Task 'VMM Inventory' (926ba814-4151-421f-9be7-fbf60eb36580, 0ba3af3c-e4ea-4441-a15c-1ddb9f1bdedc) (07/04/2017 14:10:53) - has met the minimum number of child instances complete.

    Task instance is completed: 'Run VMM Inventory' (05aad509-6eb8-4243-8b79-b354e7db2fd3, 0ba3af3c-e4ea-4441-a15c-1ddb9f1bdedc), started at 07/04/2017 14:10:53, status=Failed, total time=00:00:23.1042807
    -----------------------------------------------------------------------------------------------------

    Meanwhile I installed additionally the VMM plugin on the remote Task server. It did not make any difference.

    Since I ran out of ideas I am going to open a support case

    Tomasz



  • 6.  RE: Inventory of ESXi servers

    Broadcom Employee
    Posted 04-07-2017 10:11 AM

    Hi Tomasz!

    1. I've sent another correct registry keys with steps to show verbose/trace level logging.
    2. Try to open your vcenter address (IPv4, Hostname, FQDN) from I.E browser using same VMware credentials on machine where you have a problem with VMM Inventory task. No certificate problems, etc and it successfully opens vcenter page?

    Thanks,

    IP.



  • 7.  RE: Inventory of ESXi servers
    Best Answer

    Posted 04-18-2017 05:07 AM

    Eventually I opened a support case. Here is the case summary.

    ISSUE: VMM Inventory task does not run on ESXi host 
    DIAGNOSTIC STEPS: Task execution instance trace. 
    CAUSE: Overlapping subnets, causing VMM task to run on task site server, which is not fully configured for VMM & PPA. It's recommended to rum VMM tasks via NS as long as the target is reachable. 
    SOLUTION/WORKAROUND: Manually assign "All discovered hypervisors" filter to SMP Task Service. 

    So forcing the inventory task to run from NS, where VMM component is installed, finally worked for me.

    I hope it helps others.