United Kingdom Endpoint Management User Group

 View Only
  • 1.  Software Quick Deliveries - Not launching on some machines

    Posted Apr 18, 2018 01:02 PM

    We are currently pushing out some new endpoint protection software, and in our student facing areas I am using Quick Delivery tasks to achieve this as I can control power on/off etc. and know their availability.  However, on a number of these machines, the software package is downloaded but the commandline is seemingly never launched - the task just sits with the status of "Running" until the task eventually times out.  There are no logs to suggest that the installer ever ran.  It hasn't happened on all PCs - just some of them, and no matter how many times I repeat the quick delivery task on those machines, the outcome is still the same.  I'm fairly certian it's not a problem with the actual installer, as when I run the installer manually on those machines - it works fine.

    I have no idea how to diagnose the problem since it is pretty intermittent in terms of it working on some machines.  However, it consistently doesn't work on others.  The machines (working and non-working) are all running identical images and are all identical hardware.  We are using CMS 8.1 RU3 and the agents are all up to date and healthy.

    Any ideas where to start looking?


  • 2.  RE: Software Quick Deliveries - Not launching on some machines
    Best Answer

    Posted Apr 18, 2018 01:16 PM

    On a client where you are having the problem, try this:
    1) Stop the Altiris Agent
    2) delete the AexSWDAgentPolicy.xml from C:\Program Files\Altiris\Altiris Agent\Agents\SoftwareManagement\Software Delivery
    3) Restart the agent.
    Try the task again.


  • 3.  RE: Software Quick Deliveries - Not launching on some machines

    Posted Apr 18, 2018 04:28 PM

    I've seen this type of symptom if the installer is unexpectedly prompting the user for some type of input but the advanced setttings in the policy / task is set to not allow user interaction or to run in a hidden window.  One possible reason for this on otherwise identical machines could be a prompt warning users of a pending reboot that is needed before the software can be installed.  Such a prompt could install before the installer starts logging.  If this is the case, I would expect you to see the installer running in task manager.  I'm not sure if you checked for that. 

    If the installer is not running, the next place I'd check is the SMA logs to see if any errors show there during launch and the Windows event logs around the time of launch.  

  • 4.  RE: Software Quick Deliveries - Not launching on some machines

    Posted May 09, 2018 12:25 PM

    Thanks!  This seemed to solve the issue for us.  No idea what causes it tho.  Any ideas?

    We have managed to script something to do this remotely too, based on a script we found here.  Here it is:

    REM Get the Altiris Agent install path
    FOR /F "tokens=2*" %%A IN ('REG.EXE QUERY "HKLM\Software\Altiris\Altiris Agent" /V "installdir"') DO SET AgentDir=%%B
    set tempbat="c:\temp\AgentClean.bat"
    REM Create temporary batch file to execute while the agent restarts
    echo "%AgentDir%\aexagentutil" /stop > %tempbat%
    echo rmdir "%AgentDir%\Agents\SoftwareManagement\Software Delivery" /s /q >> %tempbat%
    echo ping localhost -n 300 >> %tempbat%
    echo "%AgentDir%\aexagentutil" /start >> %tempbat%
    echo "%AgentDir%\aexagentutil" /updateconfiguration >> %tempbat%
    echo exit >> %tempbat%
    REM Executes temporary batch file
    start "" /MIN %tempbat%

    Caveats to the above:

    • Set the task to timeout after 5 mins.
    • The task will timeout and fail after 5 mins with exit code -1.  This is a success.
    • It can run while a user is logged on but they can close it down in the task bar if they wish.  Better to run whilst users are not logged on.