Brocade Management Software Community

Expand all | Collapse all

SANnav install error message

  • 1.  SANnav install error message

    Posted 07-01-2019 08:49 AM
      |   view attached
    Hi team.
    I´m trying to install SANnav 1.1.1 Single mgmt portal server, but I´m running into problems at the installation checkup.
    All checkpoints are green, but it states "System requirements check failed.....".
    See attached picture.
    We had to use RHEL 7.6 instead of 7.4/7.5, but the checkpoint is green in that case.
    The CPU is 2 x 14 Cores (Spec says 16 Core), but the total is 56. Can that be the issue?

    Screenshot (in normal black/white):
    ------------------------------------------------------------------------------------------------
    [xxxxxxxxx bin]$ sudo ./install-single-node-server.sh
    Disk space available in /opt/install/Portal_1.1.1_rc_bld51: 494 GB
    Disk space available in /var/lib/: 129 GB
    Disk space available in /: 29 GB
    Current memory: 94 GB
    UMASK set to: 0022
    Number of CPU: 56
    Host name to IP resolution: xxxxxxxxxx
    Port 80 is free.
    Number of CPU sockets available: 2
    Operating System: Red Hat Enterprise Linux Server release 7.6 (Maipo)
    NSLOOKUP of 172.24.48.36 resolved successfully
    CPU Speed: 2673 MHz
    System requirements check failed. Please fix the issues reported and re-run the script. Press Enter to Exit
    ------------------------------------------------------------------------------------------------
    [uelkster@bf-sto-sanmgmt1 logs]$ cat install_server_2019_07_01_1129.log
    Current umask is 0022
    Disk space available in /opt/install/Portal_1.1.1_rc_bld51: 494 GB
    Disk space available in /var/lib/: 129 GB
    Disk space available in /: 29 GB
    Current memory: 94 GB
    UMASK set to: 0022
    Number of CPU: 56
    Port 80 is free.
    OS is not **** CENTOS ****
    OS is **** REDHAT ****
    OsVendor is redhat Major version of centos is 7 and minor version of centos is 6
    Operating System: Red Hat Enterprise Linux Server release 7.6 (Maipo)
    NSLOOKUP:
    Server: xxxxxxxxxx
    Address: xxxxxxxxxx#53

    Non-authoritative answer:
    xxxxxxxxx.in-addr.arpa name = xxxxxxxxxxxxxxxxxxxxxxxxxx

    Authoritative answers can be found from:
    xxxx.in-addr.arpa nameserver = xxxxxxxxxxxxxxxxxxxxxxxxxx.
    xxxx.in-addr.arpa nameserver = xxxxxxxxxxxxxxxxxxxxxxxxxx
    xxxxxxxxx. internet address = xxxxxxxxx.
    xxxxxxxxx. internet address = xxxxxxxxx.
    xxxxxxxxx. has AAAA addressxxxxxxxxx.
    xxxxxxxxx.t has AAAA address xxxxxxxxx.
    NSLOOKUP of xxxxxxxxx. resolved successfully
    CPU Speed: 2673 MHz
    System requirements check failed. Please fix the issues reported and re-run the script. Press Enter to Exit



    Anyone with good ideas of how to solve it?
    Regards
    Ulf


  • 2.  RE: SANnav install error message

    Posted 08-29-2019 08:54 AM
    Hi Ulf,
    I am interested in how you fixed this issue?
    We also, will need to install SANnav on RHEL 7.6.
    Do you know if this is possible or is 7.6 not working?

    best regards
    Sean


  • 3.  RE: SANnav install error message

    Posted 08-30-2019 11:57 AM
    Hi,

    try to change 7.6 -> 7.5 in /etc/redhat-release.
    According to prereq script it's checking for minor version 5 or 4:

    if [ -f /etc/redhat-release ]; then
    echo "OS is **** REDHAT ****" &>> $LOG_LOCATION/$FILE_NAME
    osVendor=$(cat /etc/system-release-cpe | cut -d ':' -f3)
    major_version=$(cat /etc/redhat-release | tr -dc '0-9.'|cut -d \. -f1)
    minor_version=$(cat /etc/redhat-release | tr -dc '0-9.'|cut -d \. -f2)
    echo "OsVendor is $osVendor Major version of centos is $major_version and minor version of centos is $minor_version" &>> $LOG_LOCATION/$FILE_NAME
    if [ "$osVendor" == "redhat" ] && [ "$major_version" -eq "7" ] && [ "$minor_version" -eq "5" -o "$minor_version" -eq "4" ]; then
    echo "Passed redhat Version Check" &>> $LOG_LOCATION/$FILE_NAME
    isOSVersionOk="true"
    fi


  • 4.  RE: SANnav install error message

    Posted 12-04-2019 03:00 PM
    SANnav v1.1.1 supports 7.4 and 7.5. However SANnav v2.0.0 supports v7.6