Brocade Fibre Channel Networking Community

Expand all | Collapse all

SMI-Agent and Fabric Discovery Problem

  • 1.  SMI-Agent and Fabric Discovery Problem

    Posted 10-25-2019 06:38 PM
    Hi,

    I'm having problems to access Fabric Discovery (SMIA Configuration Tool) using Network Advisor 14.4.3.

    I'm trying to add my san switches to it so I can use the smi-agent to work with IBM Spectrum Control.

    I've tried all flavors of Windows (2008 R2, 2012 and 2016) and the same problem occured: the Fabric Discovery link in SMIA Configuration Tool (and all other links) doesn't work... I clique and nothing happens.



    It's supposed to open another window that will allow me add the fabric (add the switches) but unfortunently nothing happens.

    Does anyone knows what I can do it to make it works?

    Regards.


  • 2.  RE: SMI-Agent and Fabric Discovery Problem

    Posted 10-26-2019 02:52 AM
    @Heleno Felix

    is the SMI Agent correct installed and the Service Started ?

    see follow procedure.

    https://community.broadcom.com/communities/community-home/digestviewer/viewthread?MID=697137#bm822a7581-0fb4-4a9e-bfa9-4b15eb7cf603

    I tested in the past several Installation on Win2K8 R2 and Win2012 Server, and is working.



    ------------------------------
    TechHelp24
    ------------------------------



  • 3.  RE: SMI-Agent and Fabric Discovery Problem

    Posted 10-26-2019 11:00 PM
    Hi Antonio,

    I double check all the configuration but the Fabric Discovery Link and all others doesn't work. I cliq on the link and nothing happens.

    I did a fresh Windows 2012 R2 installation but it's not working and I have no logs with errors.

    Regards,


  • 4.  RE: SMI-Agent and Fabric Discovery Problem

    Posted 10-27-2019 02:34 AM
    by default installation Windows Server, Firewall is enable. Disable and try again.

    is the Server a BareBone Maschine or Virtual Maschine ?

    ------------------------------
    TechHelp24
    ------------------------------



  • 5.  RE: SMI-Agent and Fabric Discovery Problem

    Posted 10-27-2019 09:16 PM
    Antonio,

    Thanks, but unfortunently the Windows firewall is disabled in both my windows 2012 R2 and windows 2016 virtual machines. Both are installed from scratch.

    I found some documents telling that was mismatch version of java. But I'm using the java installed from Network Advisor, I didn't install any other version.

    Regards,


  • 6.  RE: SMI-Agent and Fabric Discovery Problem

    Posted 10-28-2019 01:52 AM
    supported OS

    Windows Server 2008 R2 SP1 Datacenter, Standard and Enterprise
    Windows Server 2012 R2 Standard, Datacenter
    Windows Server 2016 Datacenter, Standard

    About JAVA.

    can you point from the same Windows Server machine to the Switch WebTools , Internet Explorer or Mozilla ?

    Additional try follow:

    Install the JAVA runtime JRE 1.8u181

    post Switch Type and installed FOS Release

    ------------------------------
    TechHelp24
    ------------------------------



  • 7.  RE: SMI-Agent and Fabric Discovery Problem

    Posted 10-28-2019 10:47 PM
    Antonio,

    Thanks for trying to help me with this problem.

    Because the Fabric Discovery link doesn't open I can't add the switches yet.

    I'll try to install the Java's version that you mentioned but I don't know if the SMIA Configuration Tool will used it. I'm saying that because the Network Advisor install a java it self in their own directory and all batch files that I openned it points to their's java.

    Regards,



  • 8.  RE: SMI-Agent and Fabric Discovery Problem

    Posted 11-04-2019 09:41 AM

    Hi @Heleno Felix

    I just tested the SMIA configration tool indeed doesn't open the links on the HOME tab, but try to use configure fabrics ( ​Discover--> Fabrics ) menu from Network Advisor itself.

    Discover Fabrics

    Our environment is Windows Server 2016 Standard, Network Advisor version 14.4.2. Based on the User Manual, it should work:

    "Accessing Management application features
    To access Management application features such as, fabric and host discovery, role-based access
    control, application configuration and display options, server properties, as well as the application
    name, build, and copyright, complete the following steps.
    1. Click the Home tab, if necessary.
    2. Select from the following to access the feature or dialog box.
    • Fabric Discovery
    • Host Discovery
    • Users
    • Options
    • Server
    • About
    • Upgrade (Trial version only)
    3. Click Close to close the SMIA Configuration Tool dialog box."

    Right after you added the fabrics, you'll be able to add the IP of Network Advisor to IBM Spectrum Control.

    Goodl luck.



    ------------------------------
    Regards, Tamas.
    ------------------------------



  • 9.  RE: SMI-Agent and Fabric Discovery Problem

    Posted 11-04-2019 06:54 PM
    Hi Tamas,

    I appreciate so much for your help. But we don't have Network Advisor License because we only use SMI-Agent Only (free feature) to provide information from our SAN to IBM Spectrum Control. So I can't access Network Advisor menu that you send to me unforunently.

    I'm working with IBM team trying to solve this problem too.

    Thanks again for share your steps and if you have another way to call this menu action please let me know.


  • 10.  RE: SMI-Agent and Fabric Discovery Problem

    Posted 11-05-2019 04:35 AM

    Hi @Heleno Felix

    I'm not sure if this will work for you but let's give it a try. I used the below method to be able to launch the 'Discover Fabrics' menu.
    For sure, it has something to do with java, and I'm not sure if the license is a must to be able to reach this configuration menu.

    So enter the IP address of your INA to your web browser based on the Network Advisor SAN Installation and Migration Guide, section
    Launching the SMIA Configuration Tool remote client:



    After that, I ran "JRE and MIB Files" option, and opened the jnlp file with java:


    On the next window you can launch Web Start the Configuration Tool under IBM Network Advisor SMI Agent:


    In the meantime, I got these kind of alerts, that is why assume, that this is some java version or cache related "issue":



    Right after the above point, I was able to reach the same window, that I can reach from the INA menu: Fabrics--> Discovery.
    Again, I'm not sure if this function needs a license ( we do have ) but worth a try.

    Good luck, and let me know the outcome.

    Cheers.



    ------------------------------
    Regards, Tamas.
    ------------------------------



  • 11.  RE: SMI-Agent and Fabric Discovery Problem

    Posted 11-06-2019 08:20 PM
    Hi Thomas,

    You solved my problem!

    Accessing the interface using the method you mentioned permits me to access the Fabric Discovery tool and everything works fine after that.

    I really appreciate your attention and thanks a lot!

    Best regards,


  • 12.  RE: SMI-Agent and Fabric Discovery Problem

    Posted 11-07-2019 03:08 AM

    Hi @Heleno Felix!

    I'm glad to hear that this workaround solved this issue. I don't think this is how it should work, but it's working this way anyway. 

    Cheers.



    ------------------------------
    Regards, Tamas.
    ------------------------------



  • 13.  RE: SMI-Agent and Fabric Discovery Problem

    Posted 11-07-2019 11:25 AM
    Hi Thomas,

    I don't know either. The other way always worked fine, but know it's solved and I'm vary glad because our SAN monitoring came back!

    Thanks again!

    Regards,