Brocade Fibre Channel Networking Community

Expand all | Collapse all

Port wrongly recognized as Long Distance

  • 1.  Port wrongly recognized as Long Distance

    Posted 02-17-2020 12:40 PM
    Hello

    I have a problem with an interconnection between an HP Blade equipped with an HP VC 8Gb 24-Port FC Module and a Brocade 5300 switch.

    On the Brocade side I see that the port is in E-Port instead of F-Port with the following error : Segmented, Long distance fabric mismatch.

    Except that it is not a long distance, I already have several HP Blades in this same configuration they are in F-Port and everything works correctly.

    Also note that I have two fabric FC, the second one is in F-Port.

    Do you have any ideas?

    Regards,
    -JG


  • 2.  RE: Port wrongly recognized as Long Distance

    Posted 02-18-2020 07:27 AM
    Hello,


    try to disable E-port on switch port.

    portcfgeport slot/port 0

    ------------------------------
    If my answer fulfilled your question please mark the reply as "Make Best Answer"

    Kind Regards

    Marian
    ------------------------------



  • 3.  RE: Port wrongly recognized as Long Distance

    Posted 02-18-2020 10:31 AM
    Hi Marian,

    Thank you for your answer. I've already tried, but it doesn't change anything:

    22  22   c84a00   id    N8   Online      FC  E-Port  segmented,(Long distance fabric or mode incompat) 
    23  23   c84800   id    N8   Online      FC  E-Port  segmented,(Long distance fabric or mode incompat)

     



  • 4.  RE: Port wrongly recognized as Long Distance

    Posted 02-19-2020 02:23 AM
    Edited by Marian Bezeg 02-19-2020 02:25 AM
    Hello,

    Could you please share output of portcfgshow for affected ports?
    One VC is cabled to same fabric ?
    Which FOS are you running ?

    Anyway there is KB for simmilar issue:

    https://support.hpe.com/hpesc/public/docDisplay?docId=emr_na-c04991138


    ------------------------------
    If my answer fulfilled your question please mark the reply as "Make Best Answer"

    Kind Regards

    Marian
    ------------------------------



  • 5.  RE: Port wrongly recognized as Long Distance

    Posted 02-20-2020 06:05 AM
    Hello

    Here is the portcfgshow configuration:

    XXX:admin> portcfgshow 22

    Area Number:   74

    Speed Level:   AUTO(HW)

    Fill Word(On Active)   0(Idle-Idle)

    Fill Word(Current)   0(Idle-Idle)

    AL_PA Offset 13:   OFF

    Trunk Port   ON

    Long Distance   OFF

    VC Link Init   OFF

    Locked L_Port   OFF

    Locked G_Port   ON

    Disabled E_Port   ON

    Locked E_Port   OFF

    ISL R_RDY Mode   OFF

    RSCN Suppressed   OFF

    Persistent Disable   OFF

    LOS TOV mode   0(OFF)

    NPIV capability   ON

    QOS Port   AE

    Port Auto Disable:   OFF

    Rate Limit   OFF

    EX Port   OFF

    Mirror Port   OFF

    SIM Port   OFF

    Credit Recovery   ON

    F_Port Buffers   OFF

    E_Port Credits   OFF

    Fault Delay:   0(R_A_TOV)

    NPIV PP Limit:   126

    NPIV FLOGI Logout:   OFF

    CSCTL mode:   OFF

    TDZ mode:   OFF

    XXX:admin> portcfgshow 23

    Area Number:   72

    Speed Level:   AUTO(HW)

    Fill Word(On Active)   0(Idle-Idle)

    Fill Word(Current)   0(Idle-Idle)

    AL_PA Offset 13:   OFF

    Trunk Port   ON

    Long Distance   OFF

    VC Link Init   OFF

    Locked L_Port   OFF

    Locked G_Port   ON

    Disabled E_Port   ON

    Locked E_Port   OFF

    ISL R_RDY Mode   OFF

    RSCN Suppressed   OFF

    Persistent Disable   OFF

    LOS TOV mode   0(OFF)

    NPIV capability   ON

    QOS Port   AE

    Port Auto Disable:   OFF

    Rate Limit   OFF

    EX Port   OFF

    Mirror Port   OFF

    SIM Port   OFF

    Credit Recovery   ON

    F_Port Buffers   OFF

    E_Port Credits   OFF

    Fault Delay:   0(R_A_TOV)

    NPIV PP Limit:   126

    NPIV FLOGI Logout:   OFF

    CSCTL mode:   OFF

    TDZ mode:   OFF


    The VC concerned has well two ports to the same fabric, I am in version v7.4.1d

    At the moment I have looked at the KB and I have the longDistance activated because I have a temporary auxiliary site interconnected in SAN :

    XXX:admin> configshow | grep "long"
    fabric.ops.mode.longDistance:1
    XXX:admin>




  • 6.  RE: Port wrongly recognized as Long Distance

    Posted 02-21-2020 02:16 AM
    @Jordan G

    You better go and disable the ​fabric.ops.mode.longDistance:1 !

    This mode is obsolete since quiet some years.  The only purpose is for backward or 3rd party compatibility. All the long distance configurations can be done on a port level using the portcfglongdistance command.

    As Marian mentioned before, also check HPs KB article about this.   https://support.hpe.com/hpesc/public/docDisplay?docId=emr_na-c04991138


    ------------------------------
    Senior Systems Engineer
    Broadcom - Brocade Storage Networking
    ------------------------------



  • 7.  RE: Port wrongly recognized as Long Distance

    Posted 02-19-2020 12:13 PM
    you should switch your VC to pass-thru mode to see as an F port