Brocade Fibre Channel Networking Community

Expand all | Collapse all

Problems with disabling virtual fabrics

  • 1.  Problems with disabling virtual fabrics

    Posted 11-26-2019 11:29 AM
    Hi all

    I have a brand new director where I want to disable virtual fabrics.
    But when trying to do it I get the following message

    switchname:FID128:admin> fosconfig --disable vf
    WARNING: This is a disruptive operation that requires a reboot to take effect.
    Would you like to continue [Y/N]: y
    System is not ready to disable the Virtual Fabric. Please try again shortly.

    I only have the default switch configured and the VF is enabled (by default)

    switchname:FID128:admin> fosconfig --show
    FC Routing service: disabled
    Virtual Fabric: enabled

    switchname:FID128:admin> lscfg --show

    Created switches FIDs(Domain IDs): 128(ds)(23)
    Slot 1 2 3 4 5 6 7 8
    -------------------------------------------------------
    Port
    0 | | | 128 | 128 | 128 | 128 | | |
    1 | | | 128 | 128 | 128 | 128 | | |
    2 | | | 128 | 128 | 128 | 128 | | |
    3 | | | 128 | 128 | 128 | 128 | | |
    4 | | | 128 | 128 | 128 | 128 | | |
    5 | | | 128 | 128 | 128 | 128 | | |
    6 | | | 128 | 128 | 128 | 128 | | |
    7 | | | 128 | 128 | 128 | 128 | | |
    8 | | | 128 | 128 | 128 | 128 | | |
    9 | | | 128 | 128 | 128 | 128 | | |
    10 | | | 128 | 128 | 128 | 128 | | |
    11 | | | 128 | 128 | 128 | 128 | | |
    12 | | | 128 | 128 | 128 | 128 | | |
    13 | | | 128 | 128 | 128 | 128 | | |
    14 | | | 128 | 128 | 128 | 128 | | |
    15 | | | 128 | 128 | 128 | 128 | | |
    16 | | | 128 | 128 | 128 | 128 | | |
    17 | | | 128 | 128 | 128 | 128 | | |
    18 | | | 128 | 128 | 128 | 128 | | |
    19 | | | 128 | 128 | 128 | 128 | | |
    20 | | | 128 | 128 | 128 | 128 | | |
    21 | | | 128 | 128 | 128 | 128 | | |
    22 | | | 128 | 128 | 128 | 128 | | |
    23 | | | 128 | 128 | 128 | 128 | | |
    24 | | | 128 | 128 | 128 | 128 | | |
    25 | | | 128 | 128 | 128 | 128 | | |
    26 | | | 128 | 128 | 128 | 128 | | |
    27 | | | 128 | 128 | 128 | 128 | | |
    28 | | | 128 | 128 | 128 | 128 | | |
    29 | | | 128 | 128 | 128 | 128 | | |
    30 | | | 128 | 128 | 128 | 128 | | |
    31 | | | 128 | 128 | 128 | 128 | | |
    32 | | | 128 | 128 | | | | |
    33 | | | 128 | 128 | | | | |
    34 | | | 128 | 128 | | | | |
    35 | | | 128 | 128 | | | | |
    36 | | | 128 | 128 | | | | |
    37 | | | 128 | 128 | | | | |
    38 | | | 128 | 128 | | | | |
    39 | | | 128 | 128 | | | | |
    40 | | | 128 | 128 | | | | |
    41 | | | 128 | 128 | | | | |
    42 | | | 128 | 128 | | | | |
    43 | | | 128 | 128 | | | | |
    44 | | | 128 | 128 | | | | |
    45 | | | 128 | 128 | | | | |
    46 | | | 128 | 128 | | | | |
    47 | | | 128 | 128 | | | | |
    48 | | | | | | | | |
    49 | | | | | | | | |
    50 | | | | | | | | |
    51 | | | | | | | | |
    52 | | | | | | | | |
    53 | | | | | | | | |
    54 | | | | | | | | |
    55 | | | | | | | | |
    56 | | | | | | | | |
    57 | | | | | | | | |
    58 | | | | | | | | |
    59 | | | | | | | | |
    60 | | | | | | | | |
    61 | | | | | | | | |
    62 | | | | | | | | |
    63 | | | | | | | | |

    Anyone got any ideas what it could be?




  • 2.  RE: Problems with disabling virtual fabrics

    Posted 11-27-2019 08:16 AM
    My advice is to leave VF enabled but if you must, try disabling the logical switch first.

    There is no operational difference between a switch with a single default logical switch and VF disabled.

    ------------------------------
    Field Applications Engineer
    Broadcom
    ------------------------------



  • 3.  RE: Problems with disabling virtual fabrics

    Posted 11-27-2019 09:01 AM
    Hi all, just wanted to say that a reboot of the new director did the trick :-)