Symantec Access Management

 View Only

Tech Tip : CA Single Sign-On : Time based Auditlog Rollover does not work 

Oct 14, 2016 07:09 AM

Issue: 

 

The smaccess log is not being rolled over at the scheduled time (Everyday @ 00:00 hours) on Siteminder 12.52 SP1 Cr5 Policy Sever. 

This happens for time based Audit log rollover even though the LastRolloverTime registry is set to 0 as below: 

HKEY_LOCAL_MACHINE\SOFTWARE\Netegrity\SiteMinder\CurrentVersion\Reports=923788632 

LastRolloverTime= 0; REG_DWORD 

 

Environment:  

 

Policy Server 12.52SP1CR05 build 2112 on RedHat 6.8 64bit 

 

Cause: 

 

The algorithm is failing when the roll time is set to 00:00. The algorithm will work if the roll time is set to 23:59.

 

Resolution/Workaround:

 

The work around to resolve the issue is to set the Audit Logfile Rollover time to 23:59

 

 

 

KD : TEC1625128

Statistics
0 Favorited
0 Views
0 Files
0 Shares
0 Downloads

Tags and Keywords

Comments

Jan 04, 2017 05:14 PM

Seems like a permission issue to create new file in the directory by the user under which you are running policy server.

Did you verify that ?

 

If the permission are all good, I would capture strace log during the policy server startup and see why it wasn't able to create a new file( rollover)

 

 

strace -Ff -t -i -v -o strace.log -s 16384 <command>

 

e.g strace -Ff -t -i -v -o strace.log -s 16384 ./start-all

Jan 04, 2017 03:03 PM

I am running Policy Server version 12.51 SP1  on a Linx RedHat 6 Environment.

 

I have set the logfile rollover as:

 

(check)  When the server is restarted

(check) with the logfile reached 25 MB

(check) Time Based, Every 1 Days at 23:59

Retain up to 10 old LogFile(s)

 

But the log rollover is NOT working at all.  I originally had time of 00:00; then tried 00:01 (which is what I used in SiteMinder Rel 12.0.SP3), and then 23:59

 

Here is my environment:

Policy Server Version: 12.52 sp01

 

ProductName=CA SiteMinder Policy Server

 

FullVersion=12.52.100.499

 

Location=/opt/ca/siteminder

 

 

Policy Server O/S: Red Hat Enterprise Linux Server release 6.7 (Santiago)

 

Policy Store Database: IBM TDS V6.3

 

 

Is there some other setting needed to get the rollover 'reset'?

Related Entries and Links

No Related Resource entered.