Article Contents:
Problem:
Alarm received from the cabi probe: “Failed to upload uim_core_dashboards.zip to cabi Server at http://<CABI_Server_IP or hostname>:<port>/cabijs”
In the UMP under Unified Dashboards -> CA Business Intelligence Dashboards, the Summary Dashboard displays: “No dashboard found with path: Click Edit Dashboard button to create dashboard or click Options -> Preferences to update path”
Cabi log:
Mar 10 17:53:48:349 [UserSynchronizationThread, cabi] Finished synchronizing users between UIM and CABI
Mar 10 17:54:46:460 [ContentUploaderPool-1-thread-1, cabi] could not upload file=C:\Program Files (x86)\Nimsoft\probes\service\cabi\content\upload\uim_core_dashboards.zip
Mar 10 17:54:46:461 [ContentUploaderPool-1-thread-1, cabi] java.util.concurrent.TimeoutException: Export is taking more time than max allocated time of 600 milliseconds
Environment:
UIM 8.51 Cabi probe v2.00
Cause:
Before the cabi probe uploads new dashboards and reports, in this case the uim_core_dashboards.zip, it first does an automatic backup of the existing content in jasperserver. This is a safeguard in case customization has been made to the content. The auto backup logic has a default timeout of 600 seconds, and normally this is more than enough time. For some reason, that backup of the the existing Jasperserver content is running very slowly.
Workaround:
DIRECT LINK TO ARTICLE
Additional Information:
Install or Upgrade CA Business Intelligence with CA UIM - https://docops.ca.com/ca-unified-infrastructure-management/8-5-1/en/installing-ca-uim/install-or-upgrade-ca-business-intelligence-with-ca-uim
CABI is temporarily unavailable - https://www.ca.com/us/services-support/ca-support/ca-support-online/knowledge-base-articles.TEC1294397.html