Symantec Access Management

Configure SiteMinder Administrative UI for HTTP (non SSL) connection 

09-12-2014 12:26 AM

Note that this document is applicable to all versions until 12.8 included as the mentioned feature "/iam/sitemindermanage" won't be available in the next versions.

 

By default SiteMinder Administrative UI is configured for HTTPS connection. If for any reason you want to enable non SSL connection, then you can follow below steps :

 

  • Stop SiteMinder Administrative UI service.
  • Edit <adminui_install_path>\server\default\deploy\iam_siteminder.ear\management_console.war\WEB-INF\web.xml  and update "AccessFilter" param value as true (set as false by default).

      0.jpg

  • Restart SiteMinder Administrative UI service.
  • Access SiteMinder Manager application as  http://<servername>:8080/iam/sitemindermanage,

      1.jpg

  • Select the Environments -> SiteMinder

2.jpg

  • Under Environment Properties, modify "Base URL" to contain "http" and http port as  :

         http://<servername>:8080/iam/siteminder

      3.jpg

  • Restart SiteMinder Administrative UI service.
  • Access Admin UI over http port

        http://<servername>:8080/iam/siteminder/adminui

 

Note : In case of R12.52SP2 Administrative UI install, the web.xml is located at following directory:

<Adminui_install_dir>\standalone\deployments\iam_siteminder.ear\management_console.war\WEB-INF

Statistics
0 Favorited
4 Views
0 Files
0 Shares
0 Downloads

Tags and Keywords

Comments

04-13-2016 03:05 AM

Have you registered Admin UI with the policy server ?

04-08-2016 02:06 PM

Hello Ujwol,

When I try 8080/iam/sitemindermanage/ and click on Environments I don't see anything.

 

Any ideas?

Thanks

Milind

02-02-2016 11:19 PM

Hi Adam,

That is correct.

02-02-2016 10:04 PM

Ujwol,

 

Thank you for posting this! It is a very helpful guide.

 

Am I correct in saying that whatever the Base URL property is set to on this management console will be where the server redirects to? Mine was originally set as the http://FQDN:8080/iam/siteminder/adminui and was sending all of my SSL traffic to the HTTP url with a 301 redirect. I changed the base URL to now have https://FQDN:8443/iam/siteminder/adminui and SSL traffic now properly goes to 8443, but now the http traffic routes to 8443.

 

Is this the expected behavior? You can only access either HTTPS or HTTP but not use both?

 

Thanks,


Adam

03-20-2015 12:33 AM

I have followed the above steps, it worked for me. Great Share.

12-30-2014 04:21 AM

Hi Patrick,

I have tried accessing the management console using both FQDN and the ip address of the machine. Still it is displaying the same error.

 

Subhash

12-30-2014 02:25 AM

Try to access the server using its FQDN instead of localhost, and be sure that the FQDN is resolved correctly on the server and on the Browser machine.

 

Hope this helps,

 

Patrick

12-30-2014 12:51 AM

Hi,

When I am trying to access the URL http://localhost:8080/iam/sitemindermanage , the following error has been displayed.

"This functionality is currently disabled. Please contact customer support."

Can you help me regarding this.


Thank You

Related Entries and Links

No Related Resource entered.