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Tech Tip: The SOI Spectrum Connector does not failover to Secondary Spectrum Server 

Sep 15, 2017 01:33 AM

Document ID:  TEC1510304
Last Modified Date:  09/14/2017
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Problem:

In the following scenario the spectrum connector is not failing over to the secondary spectrum server when shutdown and startup is very slow.

1. stop primary spectrum server to reload a SSdb backup

2. the secondary becomes active

3. start primary spectrum server and create an online backup

4. synchronize the database with the secondary

Spectrum Connector Logfile shows following messages and never tries to failover to the secondary Spectrum Server:

Timer-0],08-31-17 09:00:36,INFO successfullyPolled :4516 Communication with Spectrum timed out. Server may be busy or Online Backup process is running. Retry count(1/10)


4 minutes later connector got offline, because off the SS restart: Notifying ErrorListeners of exception com.ca.ucf.api.MDRUnavailableException: MDR host <primary SS> is unavailable (reason: automatic restart after restore)

 

 

 

Environment:
Spectrum 10.1.1 Spectrum Connector 2.0.0.244 SOI 4.0 SP2
Cause:

The shutdown and startup of the Spectrum Server is very slow and it shows a "CORBA" client "jitter" situation - reported by the 10F14 event. This indicates a "communication problem".
By default - once a "CORBA client" will do a regular "disconnect" this is not causing a 0x10F14 event .. but in case the CORBA client is "irregularry dropped" - or unavailable for completing a communication cycel (Request & Response). So in case a CORBA client becomes unexpected "unresponsive" the SpectroSERVER will raise an event 0x10F14.
So - having massive 0x10F14 is indicating a "problem".

 

 

Workaround:

At this point the workaround advise here is to reconfigure the SpectroSERVERs - by adding parameter in the ./SS/.vnmrc config file - please add parms:
wait_active=yes
spm_wait_activate=yes
Allow_UpdAllSearches_Mode=true
real_time_search_debug=true
bypass_corba_shutdown=true
Those may already exist - but with different value - or are missing so you have to add.
This has to be configured in the primary and secondary Spectrum Server and both needs to be restarted.

 

In addition reseraches should have been done to find the root cause of the slow shutdown/startup

 

https://support.ca.com/us/knowledge-base-articles.TEC1510304.html

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