Layer 7 Privileged Access Management

CA Privileged Indentity Manager: Linux. JBoss will not start...? 

05-03-2015 09:33 PM

I came across this problem when someone was using my jboss installation script.

 

This could be because the scripts in, assuming jboss is installed to the default location, /opt/jboss-4.2.3.GA/bin do not have execute permissions.

 

To fix:

 

chmod +x /opt/jboss-4.2.3.GA/bin/*.sh

 

The reason why the scripts do not have permissions is that jboss is distributed as a zip file and the zip format does not support unix permissions.

 

It may also be that the path to the jdk has not been set. After making the scripts executable as above, and assuming that the jdk was installed to the default location, you can test this running:

 

export PATH=/usr/java/jdk1.7.0_71/bin:$PATH

 

And then starting jboss, if using my script:

 

/etc/rc.d/init.d/jboss start

 

It might be worth changing PATH permanently. To do the equivalent of setting the "system path" on Red Hat or Centos, create and edit a file /etc/profile.d/jdk1.7.0_71.sh with the following content:

 

if ! echo ${PATH} | /bin/grep -q /usr/java/jdk1.7.0_71/bin ; then      PATH=/usr/java/jdk1.7.0_71/bin:${PATH} fi

 

Next time you login in to the server the correct java executable should be in your path with a higher precedence than any other java on the system. Use the following to confirm:

java -version

 

Which should return:

java version "1.7.0_71"

Statistics
0 Favorited
0 Views
0 Files
0 Shares
0 Downloads

Tags and Keywords

Comments

05-04-2015 04:33 PM

Thanks for sharing this, Simon!

Related Entries and Links

No Related Resource entered.