Automic Workload Automation

Expand all | Collapse all

U01001312 error

Jump to Best Answer
  • 1.  U01001312 error

    Posted 08-21-2018 06:09 AM

    I just saw the following error when running my AE tracing workflow in a v12.2 system.

    U00021719 Syntax error in object 'UC4.AE_TRACE.LOOP_TEST.JOBI', line '00056'.

    U01001312 Variable name 'ProcessName#' is not allowed. A variable with the name '$ACTIVATOR#' already exists.

    The problem does not happen in a v12.0.5 HF2 system with the exact same objects. Any ideas?



  • 2.  Re: U01001312 error

    Posted 08-21-2018 03:14 PM

    What is on line 56? Can you respond with the script you are running?



  • 3.  Re: U01001312 error

    Posted 08-21-2018 05:29 PM

    The line sets the value of the &ProcessName# variable. The JOBI is in the XML attached to the linked discussion if you want to take a look.



  • 4.  Re: U01001312 error

    Posted 08-21-2018 05:36 PM

    FWIW, the CA Support specialist working on the incident thinks the problem might be related to GENERATE_UNDEFINED_SCRIPT_VARS.



  • 5.  Re: U01001312 error
    Best Answer

    Posted 08-24-2018 06:12 AM

    The problem does not happen if the GENERATE_UNDEFINED_SCRIPT_VARS setting in UC_SYSTEM_SETTINGS is set to N. The problem happens only if this setting is set to Y.

     

    When the new GENERATE_SCRIPT_VARS script function was added in v12.1, changes had to be made to the AE script syntax checker. The bug appears to be caused by one of these changes.



  • 6.  Re: U01001312 error

    Posted 08-31-2018 12:54 PM

    I found a work-around: enclose the whole part of the :SET statement after the equals sign in quotation marks (").