Layer7 API Management

Expand all | Collapse all

Configure the Gateway Application (Software) API GATEWAY 9.2

  • 1.  Configure the Gateway Application (Software) API GATEWAY 9.2

    Posted 19 days ago
    Hi! I'm trying to configure the Gateway Application (Software, Gateway Currently Unconfigured). When I do step 2 (Configure the CA API Gateway) and I enter all the required data, it tells me this at the end: 'An error occurred during configuration.  Error creating database when saving configuration 'Unable to create database'. The gateway user has all the grants. Why is this happening? Thank you.


  • 2.  RE: Configure the Gateway Application (Software) API GATEWAY 9.2

    Broadcom Employee
    Posted 19 days ago
    The gateway user should not be able to create a database. Use a MySQL administrative user, typically root (which is different from the OS root).

    ------------------------------
    Jay MacDonald - Adoption Architect - Broadcom API Management (Layer 7)
    ------------------------------



  • 3.  RE: Configure the Gateway Application (Software) API GATEWAY 9.2

    Posted 16 days ago
    Edited by Ruben deLuz 16 days ago
      |   view attached
    Good Morning Jay! First of all, thanks for replying. The one who creates the database is the root user of mysql. Below I attach an image of the configuration data entered. I don't know what I can be doing wrong... Thank you so much!! (My computer ip is: 192.168.117.138)



  • 4.  RE: Configure the Gateway Application (Software) API GATEWAY 9.2

    Posted 15 days ago
    Ruben,
    I had this issue also a few weeks ago, it appeared we had added the mysql config into the wrong .cnf file. Please make sure to add the character-set into the correct file. We saw this as there was actually a ssg database created. Please make sure to delete that ssg database first before doing another attempt.

    Also for the java path it is better to use a symbolic link instead of the absolute path, as when there is a java update then the path needs to be corrected in the node.properties/host.properties usually.

    ------------------------------
    Integration Consultant
    Enable-U
    Netherlands
    ------------------------------



  • 5.  RE: Configure the Gateway Application (Software) API GATEWAY 9.2

    Posted 15 days ago
    Good morning Marco! First of all, thanks for replying. I have already added the character-set-server=utf8 in 'my.cnf' file. It doesn't create any database 'ssg' for me... I have already used a symbolic link for the java path as you told me, but keep giving error. I don't know what mistake can be... I attach images so you can see it. 


  • 6.  RE: Configure the Gateway Application (Software) API GATEWAY 9.2

    Broadcom Employee
    Posted 15 days ago
    Are the Gateway and MySQL running on the same system? If not you need to grant permission for a root user from elsewhere to create the database. With the appliance, the only place where root can access the databaseis from localhost:

    [root@ssg100 ~]# mysql mysql -e 'SELECT user,host FROM user WHERE user="root"\G'
    *************************** 1. row ***************************
    user: root
    host: localhost
    [root@ssg100 ~]# mysql mysql -e 'SHOW GRANTS FOR root@localhost\G'
    *************************** 1. row ***************************
    Grants for root@localhost: GRANT SELECT, INSERT, UPDATE, DELETE, CREATE, DROP, RELOAD, SHUTDOWN, PROCESS, FILE, REFERENCES, INDEX, ALTER, SHOW DATABASES, SUPER, CREATE TEMPORARY TABLES, LOCK TABLES, EXECUTE, REPLICATION SLAVE, REPLICATION CLIENT, CREATE VIEW, SHOW VIEW, CREATE ROUTINE, ALTER ROUTINE, CREATE USER, EVENT, TRIGGER, CREATE TABLESPACE, CREATE ROLE, DROP ROLE ON *.* TO `root`@`localhost` WITH GRANT OPTION
    *************************** 2. row ***************************
    Grants for root@localhost: GRANT APPLICATION_PASSWORD_ADMIN,AUDIT_ADMIN,BACKUP_ADMIN,BINLOG_ADMIN,BINLOG_ENCRYPTION_ADMIN,CLONE_ADMIN,CONNECTION_ADMIN,ENCRYPTION_KEY_ADMIN,GROUP_REPLICATION_ADMIN,INNODB_REDO_LOG_ARCHIVE,PERSIST_RO_VARIABLES_ADMIN,REPLICATION_APPLIER,REPLICATION_SLAVE_ADMIN,RESOURCE_GROUP_ADMIN,RESOURCE_GROUP_USER,ROLE_ADMIN,SERVICE_CONNECTION_ADMIN,SESSION_VARIABLES_ADMIN,SET_USER_ID,SYSTEM_USER,SYSTEM_VARIABLES_ADMIN,TABLE_ENCRYPTION_ADMIN,XA_RECOVER_ADMIN ON *.* TO `root`@`localhost` WITH GRANT OPTION
    *************************** 3. row ***************************
    Grants for root@localhost: GRANT PROXY ON ''@'' TO 'root'@'localhost' WITH GRANT OPTION
    [root@ssg100 ~]#

    For a software gateway, where you are responsible for the MySQL configuration, make sure that you can access the database as root from your system.

    Also, are you certain you have the correct root password for mysql?

    ------------------------------
    Jay MacDonald - Adoption Architect - Broadcom API Management (Layer 7)
    ------------------------------



  • 7.  RE: Configure the Gateway Application (Software) API GATEWAY 9.2

    Posted 14 days ago
      |   view attached
    I have root user and gateway user with all the grants in mysql. I am entering the password correctly. I've been trying to configure for many days but I can't find the error.


  • 8.  RE: Configure the Gateway Application (Software) API GATEWAY 9.2

    Broadcom Employee
    Posted 14 days ago
    Again, are the Gateway and MySQL running on the same system?

    ------------------------------
    Jay MacDonald - Adoption Architect - Broadcom API Management (Layer 7)
    ------------------------------



  • 9.  RE: Configure the Gateway Application (Software) API GATEWAY 9.2

    Posted 13 days ago
    Yes, both are running on the same system... I don't know what could be happening.


  • 10.  RE: Configure the Gateway Application (Software) API GATEWAY 9.2

    Broadcom Employee
    Posted 13 days ago
    When you are at the command line and run `mysql -h localhost -u root -p mysql' are you able to gain access to the mysql command line tool? This should test the same access rules that the Gateway will be using.

    ------------------------------
    Jay MacDonald - Adoption Architect - Broadcom API Management (Layer 7)
    ------------------------------



  • 11.  RE: Configure the Gateway Application (Software) API GATEWAY 9.2

    Posted 12 days ago
    When i run: mysql -h localhost -u root -p mysql , I can access to the MySQL command line, the same with: mysql -h 192.168.1.136-u gateway -p mysql. It's very strange...


  • 12.  RE: Configure the Gateway Application (Software) API GATEWAY 9.2

    Broadcom Employee
    Posted 9 days ago
    When you are logged in as root, can you create a database?

    [root@ssg100 ~]# mysql -h localhost -u root -p mysql
    Enter password:
    Reading table information for completion of table and column names
    You can turn off this feature to get a quicker startup with -A

    Welcome to the MySQL monitor. Commands end with ; or \g.
    Your MySQL connection id is 141
    Server version: 8.0.18-commercial MySQL Enterprise Server - Commercial

    Copyright (c) 2000, 2019, Oracle and/or its affiliates. All rights reserved.

    Oracle is a registered trademark of Oracle Corporation and/or its
    affiliates. Other names may be trademarks of their respective
    owners.

    Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

    mysql> CREATE DATABASE foo;
    Query OK, 1 row affected (0.00 sec)

    mysql> SHOW DATABASES;
    +--------------------+
    | Database           |
    +--------------------+
    | foo                |
    | information_schema |
    | mysql              |
    | performance_schema |
    | ssg                |
    | sys                |
    +--------------------+
    6 rows in set (0.00 sec)

    mysql> DROP DATABASE foo;
    Query OK, 0 rows affected (0.00 sec)

    mysql> exit
    Bye
    [root@ssg100 ~]#

    ------------------------------
    Jay MacDonald - Adoption Architect - Broadcom API Management (Layer 7)
    ------------------------------



  • 13.  RE: Configure the Gateway Application (Software) API GATEWAY 9.2

    Posted 8 days ago
    Yes! When i logged as root i can create a database. You can see it in the attached image. Instead, now when I do step 2 of the configuration and enter all the data, it tells me 'Unable to create database' but it creates the database 'ssg' as you can see in the images.
    I also attach the images of '/etc/hosts' , the MySQL users and the GRANTS for 'gateway@nodo1'.
    Thank you very much for trying to help me.


  • 14.  RE: Configure the Gateway Application (Software) API GATEWAY 9.2

    Broadcom Employee
    Posted 8 days ago

    This looks like it was successful. Is this resolved? Let me know if you have any more questions.



    ------------------------------
    Jay MacDonald - Adoption Architect - Broadcom API Management (Layer 7)
    ------------------------------



  • 15.  RE: Configure the Gateway Application (Software) API GATEWAY 9.2

    Posted 7 days ago
    It's not solved. As I told you before, it says: 'Unable to create database'. When I try to start the api it won't let me as you can see in the images. The same when I try to 'Display the current CA API Gateway configuration', step 3) of the 'setup.sh'. It doesn't work...



  • 16.  RE: Configure the Gateway Application (Software) API GATEWAY 9.2

    Broadcom Employee
    Posted 7 days ago
    I'm confused. The ssg database was created, according to the SHOW DATABASES query you posted yesterday. If the ssg database is already created, then it will fail when you try to create it again.

    If the database is already there, I assume someone ran the creation steps earlier and you have a configured gateway. If this should not be the case, you can drop the existing ssg database and create a new one.

    What is in /opt/SecureSpan/Gateway/node/default/etc/conf? Is there a node.properties file there?

    ------------------------------
    Jay MacDonald - Adoption Architect - Broadcom API Management (Layer 7)
    ------------------------------



  • 17.  RE: Configure the Gateway Application (Software) API GATEWAY 9.2

    Posted 5 days ago
      |   view attached
    I get an error when creating the database (Error creating database when saving configuration 'unable to create database') but it creates it anyway. it should not be created in the right way. In /opt/SecureSpan/Gateway/node/default/etc/conf don't create the node.properties. I had already checked this too.
    I attach an image so you can see it. Thanks for trying to help me again.