Clarity

Expand all | Collapse all

Issue adding filter columns to portlets

  • 1.  Issue adding filter columns to portlets

    Posted 10-15-2013 05:38 PM
    Hi fellows,

    i am working on configuring a custom protlet related to displaying projects with custom fileds. I want to filter the data between some start and finish date. i am able to configure the start date filter for the portlet but when i try to configure the finish date , i am unable to see that field in the filter layout section but i can see the filed under list column layout.

    Am i missing something? do i need to do any setting for that field to visible under filter layout section. ( i didnt do anything for the start date though, to appear under filter section)

    Please advise.


  • 2.  RE: Issue adding filter columns to portlets

    Posted 10-20-2013 06:03 AM
    Have you added the filter under the filter section of the portlet ?

    NJ


  • 3.  RE: Issue adding filter columns to portlets

    Posted 10-21-2013 06:44 PM
    I have seen this bug several times when a column is added later to a custom portlet, sometimes it won't allow to add that column to the filter. There is a simple fix to this. Follow the steps -
    In admin >> portlets, find the portlet, check the box, then click on "Export" button which will create xml file of the portlet settings (attributes). Open the zip file which contains the XML file in notepad. Paste the entire xml text back in xog client and xog it in. This is fixes the issue every time for me.

    Give this a try...


  • 4.  RE: Issue adding filter columns to portlets

    Posted 10-16-2013 03:49 AM
    Screenshots please. Which Clarity version?

    Martti K.


  • 5.  Re: Issue adding filter columns to portlets

    Posted 01-22-2016 06:13 PM

    Thanks Atul.Kunkulol

    I gave it a try and it certainly helped me with two portlets which I could not XOG in the normal way.