Automic Workload Automation

Expand all | Collapse all

Oracle SQL jobs no longer prints DBMS_OUTPUT to Job's Report

  • 1.  Oracle SQL jobs no longer prints DBMS_OUTPUT to Job's Report

    Posted 11-07-2019 03:31 PM
    I'm kind of new to the Automic tool.

    Over the last couple of months I noticed that Automic by default printed out dbms_output.put_line from my procedures to the report logs. I'm not sure what cause this but dbms_output.put_line doesn't print out anymore.

    The only thing I can think of is that we changed the DB connection from the Oracle to the generic JDBC connection type causing us to lose this functionality by defualt.

    Can someone confirm this and if so knows a way to push output from Oracle procedures to Automic?



  • 2.  RE: Oracle SQL jobs no longer prints DBMS_OUTPUT to Job's Report

    Posted 11-07-2019 05:35 PM
    As an experiment, try adding this statement right before you execute your procedure, just to make sure dbms_output services are enabled at the time your request starts running;

    dbms_output.enable(NULL);

    ------------------------------
    Pete
    ------------------------------



  • 3.  RE: Oracle SQL jobs no longer prints DBMS_OUTPUT to Job's Report

    Posted 28 days ago
    Hi Pete,

    Thanks for your input on this.

    I finally been able to try to enable dbms_output right before the procedure. Unfortunately doesn't seem to make a difference (see screenshot).


  • 4.  RE: Oracle SQL jobs no longer prints DBMS_OUTPUT to Job's Report

    Posted 27 days ago
    Your screenshot looks different than ours.  We are on V12.3.0, and our SQL code goes into a "Process" tab, not a "JCL" tab.

    After execution, we get a PLOG report that echos the SQL statements.  Do you get this PLOG report?

    Either you constructed the wrong type of UC4 object, or I am unfamiliar with your setup.

    ------------------------------
    Pete
    ------------------------------



  • 5.  RE: Oracle SQL jobs no longer prints DBMS_OUTPUT to Job's Report

    Posted 27 days ago
      |   view attached
    Yea my team just upgraded to 12.3 and if you check out the next attached output of the PLOG you can see the successful execution of the pl/sql. But the dbms_output commands inside of the procedure isn't printing out. Prior that output used to print out on REP.