DX Application Performance Management

Expand all | Collapse all

Re: APM TIM 10.5 - Setup error

Jump to Best Answer
  • 1.  Re: APM TIM 10.5 - Setup error

    Posted 01-20-2017 08:18 AM

    Lynn_Williams Hallett_German

    Hello Guys!,

    I´m back with a new vm with apm, protected and working  with the same error, when try to configure tim after install at http://ip-address/cgi-bin/ca/apm/tim/index.

    Here the screenshot of httpd log at /etc/httpd/logs

     

    I´m using the tipical user/password combination: admin/quality, admin/blank, admin/admin.

    All services are running and checked by log ans by service httpd start, service apmpacked start and service tim start.

    I don´t touch the httpd.password file after install.

    I will appreciate your help.

    Regards,

    Guillermo



  • 2.  Re: APM TIM 10.5 - Setup error
    Best Answer

    Posted 01-20-2017 08:32 AM

    Hi Guillermo:

     

    Looks like selinux is blocking you,.htaccess needs changing, or permissions are incorrect. Did you harden your TIM environment? These articles had some good info

     

    http://serverfault.com/questions/744078/permission-denied-could-not-open-password-file

     

    https://lists.gt.net/apache/users/176344

     

    http://stackoverflow.com/questions/13394558/centos-subversion-basic-auth-password-file-not-working

     

    Verification of user id is also a permissions/config issue

     

    https://www.howtoforge.com/community/threads/apache-configuration.21158/ 

     

    Also check that Apache is set to run on boot. It is off by default 

     

    http://www.cyberciti.biz/faq/troubleshooting-apache-webserver-will-not-restart-start/


    https://www.futurehosting.com/blog/troubleshooting-the-most-common-apache-problems-youll-encounter/

     


    apache always run
    chkconfig httpd on

     

    Failing that, please consult with your local UNIX Admin or open a case

     

    Thanks

    Hal German



  • 3.  Re: APM TIM 10.5 - Setup error

    Posted 01-20-2017 08:59 AM

    Hello Hallett,

    The httpd it´s running at boot, but I ran the command chkconfig httpd on again to check it.

    I´ll read all links, but this machine has a default setup to meet the apm install without any customization.

    regards.

    Guillermo



  • 4.  Re: APM TIM 10.5 - Setup error

    Posted 01-20-2017 09:03 AM

    Hi Guillermo::

    Thanks for an update. Please open a case as previously indicated to help you resolve this

     

    Thanks

    Hal 



  • 5.  Re: APM TIM 10.5 - Setup error

    Posted 01-20-2017 09:20 AM

    Sure!...

    Issue : 00654039



  • 6.  Re: APM TIM 10.5 - Setup error

    Posted 01-20-2017 08:49 AM

    Marking as answered.  At this point, Hal's suggestions should help, lead to checking with your local UNIX Admin or opening a case with us.



  • 7.  Re: APM TIM 10.5 - Setup error

    Posted 12-20-2017 05:38 AM

    Hi Guillermo,

     

    Could you pls update us with solution you have been provided, so that it will be helpful for others with similar issue?

     

    Regards,

    Chandrasekhar.

     

     



  • 8.  Re: APM TIM 10.5 - Setup error

    Posted 12-20-2017 10:52 AM

    Hi Chandrasekhar,

     

    I checked the issue and it was resolved by disabling SELinux.  

     

    Regards,

    Matt



  • 9.  Re: APM TIM 10.5 - Setup error

    Posted 12-20-2017 12:16 PM

    That's correct guys.

    I usually disable Selinux at Linux Setup to avoid any interference with the APM Setup.

    Also, at production servers, the customer adopt this recommendation and at this moment, all installations are running ok.

    Regards,

    Guillermo