DX NetOps

Expand all | Collapse all

Performance value of memory is negative

Jump to Best Answer
  • 1.  Performance value of memory is negative

    Posted 05-29-2020 09:52 AM
    Hi world,

    did anybody of you encounter this behavior.
    Trying to see the performance of the memory of one server, NetOps Spectrum is showing a negative value:

    Nagative Value in Spectrum
    Why updated recently the operating system on that device.
    Does somebody know what could cause this behavior and how to correct it?

    Thank you.
    Rudi


  • 2.  RE: Performance value of memory is negative

    Posted 05-29-2020 10:28 AM
    Rudi,

    Spectrum uses external attributes to compute memory utilization. Most are from vendor private mibs.

    What type of device is this?

    Joe


  • 3.  RE: Performance value of memory is negative

    Posted 06-02-2020 11:31 AM

    Hi Joe,

    this is an Linux Server and the model is represented as Net-SNMP Linux.
    When I'm looking on the attributes, I see the negative value, too.

    Is that meaning, that the SNMP Agent on the Linux Server is causing the negative value?

    Memory - Attribute value with a negative value
    Thank you very much,
    Rudi



  • 4.  RE: Performance value of memory is negative

    Posted 06-02-2020 11:59 AM
    Rudi,

    It looks like it to me.

    Joe


  • 5.  RE: Performance value of memory is negative

    Posted 06-03-2020 03:42 AM
    Hello Rudi, Hello Joe,

    that's an interesting problem. We also found this problem, but on the Performance Manager. The problem with virtual servers with Linux 7.x occurred after the upgrade to PM 3.7.11. The net-snmp server is implemented on the server. It is interesting that we have no problem with hardware servers with Linux 7.x and net-snmp.

    Andreas


  • 6.  RE: Performance value of memory is negative

    Posted 06-03-2020 09:16 AM

    Description

    After upgrading the Linux UC Davis Net-SNMP agent to the latest version no longer seeing valid Memory metric data.

    • net-snmp-5.7.2-37.el7.x86_64 old working version or any version before this.
    • net-snmp-5.7.2-43.el7.x86_64 is the new version that does not look at Buffer and Cache values

    Do check the version enter the following command:

    rpm -q net-snmp

     

    So any device that upgrades the net-snmp to the new version you will need to look at the

    "Memory Without Buffer Cache" data in CA Performance Center.

    It is not guaranteed to  be negative values for the old but if it does then you need to look at the new

    "Memory Without Buffer Cache" values.




  • 7.  RE: Performance value of memory is negative

    Posted 06-03-2020 09:39 AM
    Sounds like maybe an updated vendor cert may to be requested from certification team.

    Should open support case to ask for cert update.

    You can use http://DA:8581/dcdebug to turn on detailed poll logging.  You can check the polling config to find the poll group id for the NormalizedMemoryInfo section.  Use that value in the detailed poll logging to limit the debug to just that group of items.   We can see what it's polling and calculating for memory value in DA/DC.


  • 8.  RE: Performance value of memory is negative

    Posted 06-03-2020 07:09 PM

    I would with support and was able to get one created a few months back. I ended up creating a new Metric Family:

    Memory Without Buffer Cache

    Please let me know if you need a copy of it.

     






  • 9.  RE: Performance value of memory is negative

    Posted 06-04-2020 02:10 AM
    Hi Jeffrey,

    a case is already open for the problem with the PM

    Andreas



  • 10.  RE: Performance value of memory is negative
    Best Answer

    Posted 21 days ago
    Hello,

    The cause of this, as already described above, is the net-snmp-5.7.2-37.el7.x86_64 package. We have now installed a newer version (net-snmp-5.7.2-48.el7_8.x86_64) and the problem is gone again.

    Andreas