Service Virtualization

Expand all | Collapse all

property to suppress "ERROR System.err - [Fatal Error] :1:1: Content is not allowed in prolog" in the VSE log?

Jump to Best Answer
  • 1.  property to suppress "ERROR System.err - [Fatal Error] :1:1: Content is not allowed in prolog" in the VSE log?

    Posted 09-20-2016 06:46 PM

    Hello,

     

    Which property can we use in the logging.properties to stop showing the error "content is not allowed in prolog" in the VSE log files?

     

    Error from vse.log
    ------------------------
    ERROR System.err - [Fatal Error] :1:1: Content is not allowed in prolog.
    ERROR com.itko.lisa.vse.stateful.common.datahandler.XMLPayloadParserDataProtocolHandler - An error occurred processing the set of actions for the XML payload parser.
    org.xml.sax.SAXParseException: Content is not allowed in prolog.



  • 2.  Re: property to suppress "ERROR System.err - [Fatal Error] :1:1: Content is not allowed in prolog" in the VSE log?
    Best Answer

    Posted 09-20-2016 07:08 PM

    > ERROR com.itko.lisa.vse.stateful.common.datahandler.XMLPayloadParserDataProtocolHandler - An error occurred processing the set of actions for the XML payload parser. 

     

    You can hide this by adding the following line to logging.properties:
    log4j.logger.com.itko.lisa.vse.stateful.common.datahandler.XMLPayloadParserDataProtocolHandler=FATAL

     

    > ERROR System.err - [Fatal Error] :1:1: Content is not allowed in prolog. 

     

    This one is more problematic, as the XML library we're using is writing this directly to Standard Error.  There are some ways to disable this in code, but I'm not aware of any system properties you can set.

     

    However, if it's happening often enough that it needs to be suppressed then maybe there's a bigger problem.  Why is the XML Data Parser DPH being run against requests bodies that are probably not XML?