Symantec IGA

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Campaign data inconsistency on large data sets

  • 1.  Campaign data inconsistency on large data sets

    Posted Mar 14, 2018 12:57 PM

    CA Support would like to alert you to the following issue in IP/IG 14.1.

     

     

    Issue:
    End user working on a campaign in Identity Portal r14.1 on large data sets that span across multiple pages may encounter inconsistency in the data. They may select a bulk approval but it will mark only some of the items, then if the user switches between pages some of the tasks will appear again or disappear.
     
    Environment:
    Occurs in Identity Portal 14.1.
    Will also occur in 14.2 when released and will be noted as a known issue in the 14.2 release notes.
    A permanent fix will be included in a subsequent release.
    Cause:
    This problem occurs due to a conflict between server side (IG admin default display) default sorting/grouping vs. client side (IP end user personalization) sorting/grouping.

    The issue will happen if one of the following is performed:
    1. In Identity Governance certification template default sorting/grouping is set
    2. In Identity Portal end user sets their own sorting/grouping
    Resolution:
    Workaround:
    Temporary workaround is comprised of two steps:
    1. Your Admin must remove default sorting/grouping from the campaign template
    2. Contact CA Support for a temporary code fix (HF-DE339097-20180301-0001) which removes the sorting/grouping functionality from Identity Portal.  (This fix needs to be removed once the permanent fix is provided.)
     
    Full Solution:
    A permanent fix will be delivered in a future release (to be determined).
     

    The above information is also published in the Knowledge Base:

    Campaign data inconsistency on large data sets - CA Knowledge