Clarity PPM1

Expand all | Collapse all

Issue executing a Jaspersoft report

  • 1.  Issue executing a Jaspersoft report

    Posted 06-30-2016 08:15 AM

    HI

    Can someone help me please?  I have tried and tried to understand the Rights Access for a User to see a Jaspersoft report I that created as Ad Hoc first then turned it into a report (didn't develop it using Jaspersoft Studio). I have extensively looked at the supporting  documentation, the communities etc and I am trying all the suggestions but still I am getting the following error when the user is trying to execute the report.

    What am I doing wrong? I am sure other PPM administrators are experiencing the same issue We are using PPM 14.2 currently. The only way the user can execute the report and see the data is if I give them Advanced Reporting - Administrator which I don't want. The user is a basic user and have the ability to view OOB reports no problem

     

    Thanks

    Stephen



  • 2.  Re: Issue executing a Jaspersoft report

    Posted 07-08-2016 04:12 PM

    Assuming the user has the "standard" roles of Rolead hoc designer , dashboard designer, role report designer, role user or even maybe csk role all reports domains (depends if user is doing ad hoc access or not for these roles and the first few are added when you assign rights and run the job). So it sounds like the user has access to the OOTB reports and not your own report?

     

    Then,  it will depend on where you stored your report. If you stored it under your id, then that is 'secure"- you will have to right click on the report >permissions and manually grant permissions (by user or role).  If you saved it under a public folder, then again, check the permissions to the report against the user's role.

     

    Also note that there are changes if you go to 14.4 : the full sync option is modified to empty user-specific folders under the users folders which stinks, but it is what it is.

     

    Chances are it is just sitting under a folder to which the user has no access. Granting that access can be done manually, or just ensuring the user has the proper roles (public vs. private folder).

     

    In our testing, we did have an odd issue about access, but aside from the folder access, I think ours was due to not running the DWH user security job after adjusting PPM rights.

     

    Anyway, hope that helps some.

     

    Lynn



  • 3.  Re: Issue executing a Jaspersoft report

    Posted 07-12-2016 08:55 AM

    Thanks Lynn

    At first I thought it was location where I had stored the report but when I moved it to the public folder they were still  having the same message. I will look at your others suggestions. 

     

    Thanks



  • 4.  Re: Issue executing a Jaspersoft report

    Posted 07-08-2016 04:45 PM

    Hi Stephen,

     

     

    It looks like you will have to configure your report's permissions and user's permissions. Please consider the following two options:

    1. Connect to Jaspersoft and grant the following rights to the test user that has the error:
    ROLE_ADHOC_DESIGNER
    CSK_ROLE_PROJECT_MANAGEMENT (If this is a project report, otherwise pick the needed CSK role(s)).
    2. Retry executing the report : this should normally be enough. Here is more information on how to grant the CSK roles:

    CA PPM Advanced Reporting and Database Schema Index - CA Technologies

     

    Scroll down until you see:
    CA PPM 14.3 ------ Advanced Reporting Product Guide
    Chapter 10: The 'Advanced Reporting Roles'

     

     

    Now if you don't use the CSK roles and you use your own security, then check the following:

     

    1. Access to the report
    Connect to Jaspersoft console and right click on your report, go to roles:

    Ensure that the role you use is assigned to the test user. For example, if you have a custom role, ensure it has Read Only access to the report.

    2. Access to the Domains
    Please note that you will have to assign to the domains as well. So this is why we recommended above to add Ad Hoc Designer permission as it allows to use Domains. The CA PPM OOTB Reports do not use the domains, so this might be the difference why the OOTB reports run with no issue for those users.

     

    I hope this helps.

     

    Kind Regards -Nika



  • 5.  Re: Issue executing a Jaspersoft report

    Posted 07-12-2016 08:59 AM

    Thanks Nika

    I will look at your suggestions. I am having trouble with the link you have provided. When I click on it and click on any of the links within the PPM version we are using I get:

    It would be great to see the content of these links

     

    Thanks again