Symantec Access Management

 View Only

Tech Tip : CA Single Sign-On : AdminUI :: OutOfMemoryError

  • 1.  Tech Tip : CA Single Sign-On : AdminUI :: OutOfMemoryError

    Broadcom Employee
    Posted Jan 11, 2017 10:35 AM

    Issue :

     

    I installed the AdminUI (using embedded JBOss as the Application Server). After login into the Admin UI I get the following error:

     

    ============================
    Exception during page display:
    java.lang.OutOfMemoryError: PermGen space
    ============================

     

    How can I fix it?

     

    Environment :

     

    AdminUI 12.52SP1

     

    Cause :

     

    The JBoss Server doesn't have enough memory to proceed.

     

    Resolution :

     

    Open the run.sh file under siteminder>/adminui/bin directory.
    Locate the following line:

     

      # Java Runtime
      JAVA_OPTS="$JAVA_OPTS -server"   
      JAVA_OPTS="$JAVA_OPTS -disableassertions"   
      JAVA_OPTS="$JAVA_OPTS -Xms128m -Xmx512m"

     

    Modify the fourth line like this:

     

      JAVA_OPTS="$JAVA_OPTS -Xms1024m -Xmx1024m"

     

    Then add the following line:

     

      JAVA_OPTS="$JAVA_OPTS -XX:PermSize=256m -XX:MaxPermSize=256m"

     

    Save the file and restart Admin UI. This will fix the issue.

     

    KB : TEC548400