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Tech Tip : CA Single Sign-On : Starting Web Agent with OHS, this one shuts down some seconds after having started successfully

  • 1.  Tech Tip : CA Single Sign-On : Starting Web Agent with OHS, this one shuts down some seconds after having started successfully

    Broadcom Employee
    Posted Nov 28, 2017 04:39 AM

    Issue:


    We're running a Web Agent on OHS12, and some seconds after it started, OHS reports an error and cannot starts completly, even if the Web Agent starts fine :

    [Thu Nov 09 14:07:20.475211 2017] [mpm_event:notice] [pid 18349:tid 1400794=88005952] AH00491: caught SIGTERM, shutting down

    and it ask the Web Agent to shutdown :

    [09/Nov/2017:14:07:20] [Info] [CA WebAgent LLAWP] [18620] [Shutdown message=sent to the LLAWP. It should stop within 5 seconds ...]

     

    Why is this happening? How can I solve this issue?

     

    Environment:

     

    Web Agent 12.52 SP1 CR05 64bit on OHS 12c on RedHat 6 64bit;

     

    Cause:

     

    Out of the box, the OHS Node Manager will try to access the /dms/ resource to monitor its availability. If this resource cannot be reached or have delays in the answer, it might request the OHS Server to shutdown. If you protect this resource, then the monitor will ask the OHS to shutdown.

     

    Resolution:

     

    Open the AdminUI, and edit the Domain protecting the Web Agent running on OHS. In the Policies configuration, unprotect the /dms/ resource on your Oracle HTTP Server to solve the issue.

     

    KB : TEC1545192



  • 2.  Re: Tech Tip : CA Single Sign-On : Starting Web Agent with OHS, this one shuts down some seconds after having started successfully