CA Service Management

Expand all | Collapse all

Virtual analyst installation

  • 1.  Virtual analyst installation

    Posted 09-11-2020 08:44 AM
    Edited by Thaer Slaibi 09-11-2020 09:52 AM
    I'm trying to deploy the virtual analyst using the steps in this page:
    Install Virtual Analyst
    However, when I come to the step to install RASA, I get this error:

    so as a result, I can't install RASA. Can you please help? 


  • 2.  RE: Virtual analyst installation

    Posted 09-11-2020 09:59 AM
    After doing some research, I couldn't find jaxlib for windows. Only for Linux and MacOS:
    https://pypi.org/project/jaxlib/0.1.51/#files


  • 3.  RE: Virtual analyst installation

    Broadcom Employee
    Posted 09-14-2020 12:55 PM
    Try following the steps in the following KB article:

    https://ca-broadcomcsm.wolkenservicedesk.com/wolken/esd/knowledgebase_search?articleId=187819

    These steps have been followed by several clients to successfully install VA/RASA

    ------------------------------
    Paul Coccimiglio
    Principal Support Engineer
    Broadcom Inc.
    ------------------------------



  • 4.  RE: Virtual analyst installation

    Posted 09-14-2020 02:56 PM
    The URL doesn't work. I get this error:



  • 5.  RE: Virtual analyst installation

    Broadcom Employee
    Posted 09-14-2020 03:08 PM
    Try the following URL

    https://knowledge.broadcom.com/external/article?articleId=187819

    ------------------------------
    Paul Coccimiglio
    Principal Support Engineer
    Broadcom Inc.
    ------------------------------



  • 6.  RE: Virtual analyst installation

    Posted 09-16-2020 06:26 AM
    Edited by Thaer Slaibi 09-16-2020 06:26 AM
    Hello Paul,
    Thanks for your help! 
    However, I've followed the instructions again step by step but I still get this error a few minutes after I run the pip install rasa==1.7.4 command :


    The strange thing is that after searching for this package name jaxlib, I found it's not available for windows OS!


  • 7.  RE: Virtual analyst installation

    Broadcom Employee
    Posted 09-16-2020 10:55 AM
    Please open a Broadcom Support Case so we can investigate further.

    ------------------------------
    Paul Coccimiglio
    Principal Support Engineer
    Broadcom Inc.
    ------------------------------



  • 8.  RE: Virtual analyst installation

    Posted 30 days ago
    Hello,

    i think i had the same problem under windows and could only solve it by installing version 1.8.0.
    I know that is not the supported way from the documentation but in my case i was not able to solve it with version 1.7.4.

    Maybe you can have a try in a test environment.


  • 9.  RE: Virtual analyst installation

    Posted 29 days ago
    Thanks Kern. Yes I managed to install 1.8.3. This seems to resolve the issue. I've also noticed they support have updated the documentation with that version.
    However, I face another issue a few steps after that. Once I run the rasa_train script, I get the following error:


     Any idea what might be the cause of this? 

    Regards
    Thaer




  • 10.  RE: Virtual analyst installation

    Posted 29 days ago
    Hi,

    can you please post the output of the command "pip freeze".
    You have to execute it inside of your virtual environment.

    The pip freeze command lists all installed packages in your enviroment.
    In my case (with rasa 1.8.0) the following tensorflow packages are installed:

    tensorboard==2.1.1
    tensorflow==2.1.1
    tensorflow-addons==0.8.3
    tensorflow-estimator==2.1.0
    tensorflow-hub==0.7.0
    tensorflow-probability==0.7.0

    Do you have also installed the MS library like described in the documentation?


  • 11.  RE: Virtual analyst installation

    Posted 28 days ago
    All the mentioned packages appear installed:

    (botenv) (base) C:\Program Files\CA\Aria\casm-bot>pip freeze
    absl-py==0.9.0
    aiofiles==0.5.0
    aiohttp==3.6.2
    alabaster==0.7.12
    anaconda-client==1.7.2
    anaconda-navigator==1.9.7
    anaconda-project==0.8.3
    APScheduler==3.6.3
    asn1crypto==0.24.0
    astor==0.8.1
    astroid==2.2.5
    astropy==3.2.1
    async-generator==1.10
    async-timeout==3.0.1
    atomicwrites==1.3.0
    attrs==19.3.0
    Babel==2.7.0
    backcall==0.1.0
    backports.functools-lru-cache==1.5
    backports.os==0.1.1
    backports.shutil-get-terminal-size==1.0.0
    backports.tempfile==1.0
    backports.weakref==1.0.post1
    beautifulsoup4==4.7.1
    bitarray==0.9.3
    bkcharts==0.2
    bleach==3.1.0
    blis==0.2.4
    bokeh==1.2.0
    boto==2.49.0
    boto3==1.15.0
    botocore==1.18.0
    Bottleneck==1.2.1
    cachetools==4.1.1
    certifi==2019.6.16
    cffi==1.12.3
    chardet==3.0.4
    Click==7.0
    cloudpickle==1.2.1
    clyent==1.2.2
    colorama==0.4.1
    colorclass==2.2.0
    coloredlogs==10.0
    colorhash==1.0.2
    comtypes==1.1.7
    conda==4.7.10
    conda-build==3.18.8
    conda-package-handling==1.3.11
    conda-verify==3.4.2
    contextlib2==0.5.5
    cryptography==2.7
    cycler==0.10.0
    cymem==2.0.3
    Cython==0.29.12
    cytoolz==0.10.0
    dask==2.1.0
    de-core-news-md @ https://github.com/explosion/spacy-models/releases/download/de_core_news_md-2.1.0/de_core_news_md-2.1.0.tar.gz
    decorator==4.4.0
    defusedxml==0.6.0
    distributed==2.1.0
    dnspython==1.16.0
    docopt==0.6.2
    docutils==0.14
    entrypoints==0.3
    et-xmlfile==1.0.1
    fastcache==1.1.0
    fbmessenger==6.0.0
    filelock==3.0.12
    Flask==1.1.1
    future==0.17.1
    gast==0.2.2
    gevent==1.4.0
    glob2==0.7
    google-auth==1.21.2
    google-auth-oauthlib==0.4.1
    google-pasta==0.2.0
    greenlet==0.4.15
    grpcio==1.32.0
    h11==0.8.1
    h2==3.2.0
    h5py==2.9.0
    heapdict==1.0.0
    hpack==3.0.0
    hstspreload==2020.9.15
    html5lib==1.0.1
    httptools==0.1.1
    httpx==0.9.3
    humanfriendly==8.2
    hyperframe==5.2.0
    idna==2.8
    imageio==2.5.0
    imagesize==1.1.0
    importlib-metadata==0.17
    ipykernel==5.1.1
    ipython==7.6.1
    ipython-genutils==0.2.0
    ipywidgets==7.5.0
    isort==4.3.21
    itsdangerous==1.1.0
    jax==0.1.77
    jdcal==1.4.1
    jedi==0.13.3
    Jinja2==2.10.1
    jmespath==0.10.0
    joblib==0.13.2
    json5==0.8.4
    jsonpickle==1.3
    jsonschema==3.2.0
    jupyter==1.0.0
    jupyter-client==5.3.1
    jupyter-console==6.0.0
    jupyter-core==4.5.0
    jupyterlab==1.0.2
    jupyterlab-server==1.0.0
    kafka-python==1.4.7
    Keras-Applications==1.0.8
    Keras-Preprocessing==1.1.0
    keyring==18.0.0
    kiwisolver==1.1.0
    lazy-object-proxy==1.4.1
    libarchive-c==2.8
    llvmlite==0.29.0
    locket==0.2.0
    lxml==4.3.4
    Markdown==3.2.2
    MarkupSafe==1.1.1
    matplotlib==3.1.0
    mattermostwrapper==2.2
    mccabe==0.6.1
    menuinst==1.4.16
    mistune==0.8.4
    mkl-fft==1.0.12
    mkl-random==1.0.2
    mkl-service==2.0.2
    mock==3.0.5
    more-itertools==7.0.0
    mpmath==1.1.0
    msgpack==0.6.1
    multidict==4.7.6
    multipledispatch==0.6.0
    murmurhash==1.0.2
    navigator-updater==0.2.1
    nbconvert==5.5.0
    nbformat==4.4.0
    networkx==2.4
    nltk==3.4.4
    nose==1.3.7
    notebook==6.0.0
    numba==0.44.1
    numexpr==2.6.9
    numpy==1.16.4
    numpydoc==0.9.1
    oauthlib==3.1.0
    olefile==0.46
    openpyxl==2.6.2
    opt-einsum==3.3.0
    packaging==19.0
    pandas==0.24.2
    pandocfilters==1.4.2
    parso==0.5.0
    partd==1.0.0
    path.py==12.0.1
    pathlib2==2.3.4
    patsy==0.5.1
    pep8==1.7.1
    pickleshare==0.7.5
    pika==1.1.0
    Pillow==6.1.0
    pkginfo==1.5.0.1
    plac==0.9.6
    pluggy==0.12.0
    ply==3.11
    preshed==2.0.1
    prometheus-client==0.7.1
    prompt-toolkit==2.0.9
    protobuf==3.13.0
    psutil==5.6.3
    psycopg2-binary==2.8.6
    py==1.8.0
    pyasn1==0.4.8
    pyasn1-modules==0.2.8
    pycodestyle==2.5.0
    pycosat==0.6.3
    pycparser==2.19
    pycrypto==2.6.1
    pycurl==7.43.0.3
    pydot==1.4.1
    pyflakes==2.1.1
    Pygments==2.4.2
    PyJWT==1.7.1
    pykwalify==1.7.0
    pylint==2.3.1
    pymongo==3.8.0
    pyodbc==4.0.26
    pyOpenSSL==19.0.0
    pyparsing==2.4.0
    pyreadline==2.1
    pyrsistent==0.14.11
    PySocks==1.7.0
    pytest==5.0.1
    pytest-arraydiff==0.3
    pytest-astropy==0.5.0
    pytest-doctestplus==0.3.0
    pytest-openfiles==0.3.2
    pytest-remotedata==0.3.1
    python-crfsuite==0.9.7
    python-dateutil==2.8.0
    python-engineio==3.11.2
    python-socketio==4.4.0
    python-telegram-bot==11.1.0
    pytz==2019.1
    PyWavelets==1.0.3
    pywin32==223
    pywinpty==0.5.5
    PyYAML==5.1.1
    pyzmq==18.0.0
    QtAwesome==0.5.7
    qtconsole==4.5.1
    QtPy==1.8.0
    questionary==1.5.2
    rasa==1.8.3
    rasa-sdk==1.10.2
    redis==3.5.3
    regex==2020.6.8
    requests==2.24.0
    requests-oauthlib==1.3.0
    requests-toolbelt==0.9.1
    rfc3986==1.4.0
    rocketchat-API==0.6.36
    rope==0.14.0
    rsa==4.6
    ruamel-yaml==0.15.46
    s3transfer==0.3.3
    sanic==19.12.2
    Sanic-Cors==0.10.0.post3
    sanic-jwt==1.3.2
    Sanic-Plugins-Framework==0.9.4
    scikit-image==0.15.0
    scikit-learn==0.22.2.post1
    scipy==1.5.2
    seaborn==0.9.0
    Send2Trash==1.5.0
    simplegeneric==0.8.1
    singledispatch==3.4.0.3
    six==1.12.0
    sklearn-crfsuite==0.3.6
    slackclient==2.9.0
    sniffio==1.1.0
    snowballstemmer==1.9.0
    sortedcollections==1.1.2
    sortedcontainers==2.1.0
    soupsieve==1.8
    spacy==2.1.9
    Sphinx==2.1.2
    sphinxcontrib-applehelp==1.0.1
    sphinxcontrib-devhelp==1.0.1
    sphinxcontrib-htmlhelp==1.0.2
    sphinxcontrib-jsmath==1.0.1
    sphinxcontrib-qthelp==1.0.2
    sphinxcontrib-serializinghtml==1.1.3
    sphinxcontrib-websupport==1.1.2
    spyder==3.3.6
    spyder-kernels==0.5.1
    SQLAlchemy==1.3.5
    srsly==1.0.2
    statsmodels==0.10.0
    sympy==1.4
    tables==3.5.2
    tabulate==0.8.7
    tblib==1.4.0
    tensorboard==2.1.1
    tensorflow==2.1.1
    tensorflow-addons==0.8.3
    tensorflow-estimator==2.1.0
    tensorflow-hub==0.7.0
    tensorflow-probability==0.7.0
    termcolor==1.1.0
    terminado==0.8.2
    terminaltables==3.1.0
    testpath==0.4.2
    thinc==7.0.8
    toolz==0.10.0
    tornado==6.0.3
    tqdm==4.31.1
    traitlets==4.3.2
    twilio==6.26.3
    typeguard==2.9.1
    typing-extensions==3.7.4.3
    tzlocal==2.1
    ujson==1.35
    unicodecsv==0.14.1
    urllib3==1.24.2
    wasabi==0.8.0
    wcwidth==0.1.7
    webencodings==0.5.1
    webexteamssdk==1.1.1
    websockets==8.1
    Werkzeug==0.15.4
    widgetsnbextension==3.5.0
    win-inet-pton==1.1.0
    win-unicode-console==0.5
    wincertstore==0.2
    wrapt==1.11.2
    xlrd==1.2.0
    XlsxWriter==1.1.8
    xlwings==0.15.8
    xlwt==1.3.0
    yarl==1.5.1
    zict==1.0.0
    zipp==0.5.1

    Thanks
    Thaer


  • 12.  RE: Virtual analyst installation

    Posted 25 days ago
    I still need help on this issue please.


  • 13.  RE: Virtual analyst installation

    Posted 24 days ago
    Do you have also installed the MS library like described in the documentation?


  • 14.  RE: Virtual analyst installation

    Posted 24 days ago
    Yes.


  • 15.  RE: Virtual analyst installation

    Posted 24 days ago
    Can you also try to load the tensorflow module in your virtual env to see what happens?

    On my machine (with working aria) it looks like this:



  • 16.  RE: Virtual analyst installation

    Posted 24 days ago
    Edited by Thaer Slaibi 24 days ago
    Please note it shows the same behavior. 




  • 17.  RE: Virtual analyst installation

    Posted 24 days ago
    Hi,

    please have a look here: https://github.com/tensorflow/tensorflow/issues/35749

    >>>

    I solved it today downloading and installing visual studio 2015-2019 x86 and x64 from here:
    https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads

    Other solution is downgrading tensorflow to 2.0:
    pip install tensorflow==2.0
    <<<

    Another post from this github issue

    >>>1.https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads
    2. download x64: vc_redist.x64.exe
    3.install it.

    It works.
    <<<




  • 18.  RE: Virtual analyst installation

    Posted 23 days ago
    Edited by Thaer Slaibi 22 days ago
    Thanks Sebastian. I can now run the rasa_train and rasa_run commands after installing visual studio 2015-2019 x86 and x64 from here:
    https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads
    I can also see the welcome message from RASA:



    Regards
    Thaer 



  • 19.  RE: Virtual analyst installation

    Posted 19 days ago
    Hello Thaer,

    the next step would be to activate the activate the option va.bot.nlu.server.url in the xFlow settings.
    Please make sure that the actions are loaded correctly on startup.
    When the actions are not loaded the chatbot cannot execute command against the USD:

    (botenv) (base) D:\aria\casm-bot>2020-10-05 10:54:26 INFO __main__ - Starting action endpoint server...
    2020-10-05 10:54:26 INFO rasa_core_sdk.executor - Registered function for 'fallback_action'.
    2020-10-05 10:54:26 INFO rasa_core_sdk.executor - Registered function for 'action_submit'.
    2020-10-05 10:54:26 INFO rasa_core_sdk.executor - Registered function for 'action_search_with_term'.
    2020-10-05 10:54:26 INFO rasa_core_sdk.executor - Registered function for 'set_tkt_id_slot'.
    2020-10-05 10:54:26 INFO rasa_core_sdk.executor - Registered function for 'SetTicketSlotActionFalse'.
    2020-10-05 10:54:26 INFO rasa_core_sdk.executor - Registered function for 'SetTicketSlotActionTrue'.
    name of the form
    2020-10-05 10:54:26 INFO rasa_core_sdk.executor - Registered function for 'tkt_create_form'.
    2020-10-05 10:54:26 INFO rasa_core_sdk.executor - Registered function for 'feedback_form'.
    name of the form
    2020-10-05 10:54:26 INFO rasa_core_sdk.executor - Registered function for 'search_kd_form'.
    name of the form
    2020-10-05 10:54:26 INFO rasa_core_sdk.executor - Registered function for 'tkt_close_desc_form'.
    name of the form
    2020-10-05 10:54:26 INFO rasa_core_sdk.executor - Registered function for 'tkt_comment_form'.
    name of the form
    2020-10-05 10:54:26 INFO rasa_core_sdk.executor - Registered function for 'tkt_desc_form'.
    2020-10-05 10:54:26 INFO rasa_core_sdk.executor - Registered function for 'transfer_ticket_form'.
    2020-10-05 10:54:26 INFO rasa_core_sdk.executor - Registered function for 'update_urgency_form'.
    2020-10-05 10:54:26 INFO __main__ - Action endpoint is up and running. on ('0.0.0.0', 5055)

    If not you have to do the following:

    Install rasa-core-sdk in your virtual env.

    pip install rasa-core-sdk

    Modify startup script rasa_run.cmd
    @echo off
    echo Running Rasa Core (Default) ...
    start /B rasa run -m models -p 5005 --endpoints endpoints.yml --log-file out.log --enable-api --debug

    REM echo Running Endpoint Actions (Default) ...
    REM start /B rasa run actions --actions actions -p 5055   --> commented out an replaced with the next line
    start /B python -m rasa_core_sdk.endpoint --cors --actions actions

    The rasa_halt.cmd must be modified too, but in my environment it is not done at the moment.

    Regards
    Sebastian