Automic Workload Automation

Expand all | Collapse all

Setting up Dialog work process for UC4 AWI

Jump to Best Answer
  • 1.  Setting up Dialog work process for UC4 AWI

    Posted 02-13-2020 11:43 AM
    Hi Guys,

    We were trying to setup Dialog work process so that we can see the monitor the past executions of the objects. Can anybody help us with or point us in right direction?


    ------------------------------
    Regards,
    Geetak Sharma
    ------------------------------


  • 2.  RE: Setting up Dialog work process for UC4 AWI

    Posted 02-14-2020 03:26 AM
    Hello,
    some more information would be helpful, e.g. (not final)
    • Which version do you use?
    • What exactly do you want to achieve? What is not working?
    • Have you already checked the documentation for installing Automic?

    Regards,Tim



    ------------------------------
    Automation Evangelist
    Fiducia & GAD IT AG
    ---
    Mitglied des deutschsprachigen Automic-Anwendervereins FOKUS e.V.
    Member of the German speaking Automic user association FOKUS e.V.
    ------------------------------



  • 3.  RE: Setting up Dialog work process for UC4 AWI

    Posted 02-17-2020 04:11 AM
    Please find my inline response below.

    • Which version do you use?
      • Automic Web Interface 12.2.2.hf1-dev-feature-12.2.2-hf.1-86456
    • What exactly do you want to achieve? What is not working?
      • We are unable to monitor any workflow from last execution and not even able to open the report from statistics and it keeps loading.
    • Have you already checked the documentation for installing Automic?
      • yes, but couldn't find any relevant information. 


    ------------------------------
    Thanks,
    Geetak
    ------------------------------



  • 4.  RE: Setting up Dialog work process for UC4 AWI
    Best Answer

    Posted 02-17-2020 08:41 AM
    Hi,

    Here's a copy of what I answered to a similar question some time ago : https://community.broadcom.com/enterprisesoftware/communities/community-home/digestviewer/viewthread?MessageKey=287ba934-8962-46dd-b801-25c5d9357864&CommunityKey=2e1b01c9-f310-4635-829f-aead2f6587c4&tab=digestviewer#bm287ba934-8962-46dd-b801-25c5d9357864



    The way WPs are distributed between 'W' and 'D' types is dependent upon the settings defined in UC_SYSTEM_SETTINGS > WP_MIN_NUMBER  key.

    Here's an example :

    bq9bkn9g5qg1.pnghttps://us.v-cdn.net/5019921/uploads/editor/dr/bq9bkn9g5qg1.png" width="418">

    If you set 'WP_MIN_NUMBER' to 10:
    • The first WP you start will become the PWP ('P' type)
    • The 10 next WPs you start will become regular WPs ('W' type)
    • Any additional WP will become a DWP ('D' type)

    The name set in the 'Value 1' field corresponds to the 'nodename' setting within the server's ini file (ucsrv.ini):

    1davyqqe8dsh.pnghttps://us.v-cdn.net/5019921/uploads/editor/j4/1davyqqe8dsh.png" width="353">

    Besides, if you have more than a server you can define a different number of WPs for each server. Each server must be referred to by his nodename, and separated with a semicolon.

    Example
    :

    iqy7avwrdl8q.png

    Best regards,
    Antoine



  • 5.  RE: Setting up Dialog work process for UC4 AWI

    Posted 02-19-2020 01:07 AM
    Thanks a lot for sharing details, it seems its working on our Dev instance.

    ------------------------------
    Thanks,
    Geetak
    ------------------------------



  • 6.  RE: Setting up Dialog work process for UC4 AWI

    Posted 02-25-2020 04:37 PM
    Hi Antoine,

    we did as per your suggestion, but its taking a lot time to open executions or report and keep loading for more than 2 and half minutes and then displays what we want, similar to below.

    it takes around 150 seconds to show executions



    ------------------------------
    Thanks,
    Geetak
    ------------------------------



  • 7.  RE: Setting up Dialog work process for UC4 AWI

    Posted 02-26-2020 03:13 AM
    Edited by Antoine Sauteron 06-16-2020 01:50 PM
    ​Hi Geetak,

    If you are facing performance problems, maybe the AWI / DWPs are not the culprits.
    It could be a DB latency issue. The tables that hold the reports (RH/RT) along with the one that contains statistical data (AH) need to be maintained on a regular basis to preserve performance.

    Is any DB maintenance in place in your system ?

    * DB Reorg / Unload with Automic utilities
    * Index rebuild on AH / RH / RT tables

    Best regards
    Antoine


  • 8.  RE: Setting up Dialog work process for UC4 AWI

    Posted 02-26-2020 05:11 AM

    Hi Antoine,

    We have bounced WPs and tested​, as of now it has started working. We are able to open the report in seconds. However, we will monitor it as it works intermittently.

    Can you please confirm of number of users also effects the performance or it is only due to DB Latency.

    Thank you.




  • 9.  RE: Setting up Dialog work process for UC4 AWI

    Posted 02-26-2020 08:37 AM
    Edited by Antoine Sauteron 06-16-2020 02:29 PM
    Hi​ Simerjeet,

    I cannot confirm anything without having a look at the system first... But I guess this would be a task for Broadcom support ;-)

    Anyway your concern is to know whether it's a sizing problem or a performance problem ?
    You can check these resources :

    * Sizing recommendations : https://docs.automic.com/documentation/webhelp/english/AA/12.3/DOCU/12.3/Automic%20Automation%20Guides/help.htm#Installation_Common/install_AWA_ARA_sys_requirements_sizing.htm

    * DB Maintenance : https://community.broadcom.com/enterprisesoftware/communities/community-home/digestviewer/viewthread?MessageKey=d878662b-2917-4481-b6a7-7d24cd65581c&CommunityKey=2e1b01c9-f310-4635-829f-aead2f6587c4&tab=digestviewer#bmdb0eb493-2f40-4199-9a71-6620f0f26245

    Best regards
    Antoine