Layer7 API Management

Expand all | Collapse all

Invalid resource error GMU

Jump to Best Answer
  • 1.  Invalid resource error GMU

    Posted 07-21-2019 02:24 PM
    Hi, 
    We are migrating our services through GMU to some new environments. But there is this one issue which we got in one environment alone, but the same bundle file has been deployed successfully in other new environments. I have got this blog post when searching the community https://community.broadcom.com/communities/community-home/digestviewer/viewthread?MID=783830#bm49bd7518-87e1-4657-a992-fb9f4c2c73d5. The post says restarting the gateway as solution. 
    To solve, I tried redeploying all the policies and services again to load everything to memory if in case something is missed as mentioned in post. But the problem still exists. 
    My queries 
    1. The log doesn't give much information on the invalid resource. So is there any other log other than ssg, GMU and audit alert where i can get some detailed information on this? 
    2. If restarting the gateway is the only solution, then do we need to restart it every time when new services and policies are deployed to new environments via GMU? 
    Note: the same bundle worked on other new environments. 

    Please suggest some solutions as early as possible. Thanks in advance

    ------------------------------
    With Regards,
    S giridharan
    ------------------------------


  • 2.  RE: Invalid resource error GMU
    Best Answer

    Posted 07-22-2019 03:58 PM
    Hi.

    Usually I see this error when RESTman was not installed on Gateway.
    Check if the /restman service is available on the faulting gateway

    ------------------------------
    Sr. Consultant Services
    HCL Enterprise Studio
    ------------------------------



  • 3.  RE: Invalid resource error GMU

    Posted 07-24-2019 08:23 AM
    Additional to Leandro Dantas, this could be the case, if the version of the gateway for source and target is different. It is for example possible that the GMU bundle, exported with a gateway v9.4, has some fields, which v9.1 can't import.

    ------------------------------
    Product Manager
    APIIDA AG
    ------------------------------