IT Process Automation

Expand all | Collapse all

installation of secondary node is failing

  • 1.  installation of secondary node is failing

    Posted 26 days ago

    we are trying to install a secondary node of ITPAM and we are getting below error. ip address shown below is our loadbalancer ip which is accessible.

    any suggestions please



  • 2.  RE: installation of secondary node is failing

    Posted 26 days ago
    Edited by Rajasheker Chittanur 26 days ago
    below is the error i see when i click on the Details,

    java.io.IOException: Server returned HTTP response code: 403 for URL: http://<<loadbalncer ip>>:80/c2orepository/.c2oagentresources/lib/jetty/jars/slf4j-api-1.6.1.jarjava.io.IOException: Server returned HTTP response code: 403 for URL: http://<<loadbalncer ip>>:80/c2orepository/.c2oagentresources/lib/jetty/jars/slf4j-api-1.6.1.jar at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(Unknown Source) at sun.net.www.protocol.http.HttpURLConnection.access$200(Unknown Source) at sun.net.www.protocol.http.HttpURLConnection$9.run(Unknown Source) at sun.net.www.protocol.http.HttpURLConnection$9.run(Unknown Source) at java.security.AccessController.doPrivileged(Native Method) at java.security.AccessController.doPrivilegedWithCombiner(Unknown Source) at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source) at com.sun.deploy.net.HttpUtils.followRedirects(Unknown Source) at com.sun.deploy.net.BasicHttpRequest.doRequest(Unknown Source) at com.sun.deploy.net.BasicHttpRequest.doHeadRequestEX(Unknown Source) at com.sun.deploy.cache.ResourceProviderImpl.checkUpdateAvailable(Unknown Source) at com.sun.deploy.cache.ResourceProviderImpl.isUpdateAvailable(Unknown Source) at com.sun.deploy.cache.ResourceProviderImpl.getResource(Unknown Source) at com.sun.deploy.cache.ResourceProviderImpl.getResource(Unknown Source) at com.sun.javaws.LaunchDownload$DownloadTask.call(Unknown Source) at java.util.concurrent.FutureTask.run(Unknown Source) at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) at java.lang.Thread.run(Unknown Source)


  • 3.  RE: installation of secondary node is failing

     
    Posted 24 days ago
    Hi Rajashekar,

    This is returning a 403 error, and not a 401 error. 
    https://httpstatuses.com/403
    https://en.wikipedia.org/wiki/HTTP_403

    This might mean that the authentication attempt is being made and acknowledged . . . but that the authentication is being rejected.
     
    Which could rule out things like a port issue (the request is getting through), but might suggest that the authentication itself is not being recognised. 


    Looking at issues logged for this message, here is one example of what could happen. I'm not saying it's it, just using it as an example:

    - - - -
    Issue was that the corporate proxy pointed at from the Windows "Internet Options" on the supplementary node was blocking the download of the files from the main node.

    Solution was to point "Connections -> LAN Settings" to "Automatically detect settings". Which, in our environment, points toward nothing at all. Thus, the corporate proxy.<STUFF HERE> wasn't being used, and wasn't blocking the connection.
    - - - -

    Kyle_R.