Symantec Access Management

Expand all | Collapse all

WebAgent Losing connection with Policy Server

  • 1.  WebAgent Losing connection with Policy Server

    Posted 13 days ago
    Hi Team,

    One of our team is running automated scripts to test their application which is getting interrupted multiple times because their webagent is losing connection with policy server. I don't see any errors in the policy server logs during the time frame they mentioned where it is not working. One of the reasons that I could think of is network glitches causing the connectivity unstable. Could you provide any other possible causes for this issue?

    Please find the below webagent logs for your reference -

    [12/20/2019][15:41:27][22539][469759744][CSmHighLevelAgent.cpp:395][ProcessRequest][000000000000000000000000c64012ac-580b-5dfd31f7-1bfff700-1bfa65057d54][*172.18.91.84][][qa3_myadm_wa][/cbma/index.html][][ProtectionManager returned SmNo, end new request.]
    [12/20/2019][15:41:27][22539][469759744][CSmLowLevelAgent.cpp:3466][ReportHealthData][][][][][][][Accumulating HealthMonitorCtxt.]
    [12/20/2019][15:41:27][22539][807704320][CSmHighLevelAgent.cpp:204][Shutdown][][][][][][][High Level Agent shutting down.]
    [12/20/2019][15:41:27][22539][807704320][CSmManager.cpp:82][Resource Manager][][][][][][][Shutdown.]
    [12/20/2019][15:41:27][22539][807704320][CSmManager.cpp:82][Session Manager][][][][][][][Shutdown.]
    [12/20/2019][15:41:27][22539][807704320][CSmManager.cpp:82][Response Manager][][][][][][][Shutdown.]
    [12/20/2019][15:41:27][22539][807704320][CSmManager.cpp:82][Session Manager][][][][][][][Shutdown.]
    [12/20/2019][15:41:27][22539][807704320][CSmProtectionManager.cpp:125][CSmProtectionManager::Shutdown][][][][][][][ProtectionManager shutdown.]
    [12/20/2019][15:41:27][22539][807704320][CSmManager.cpp:82][Credential Manager][][][][][][][Shutdown.]
    [12/20/2019][15:41:27][22539][807704320][CSmManager.cpp:82][Challenge Manager][][][][][][][Shutdown.]
    [12/20/2019][15:41:27][22539][807704320][CSmManager.cpp:82][Response Manager][][][][][][][Shutdown.]
    [12/20/2019][15:41:27][22539][807704320][CSmManager.cpp:82][Session Manager][][][][][][][Shutdown.]
    [12/20/2019][15:41:27][22539][807704320][CSmAuthenticationManager.cpp:124][CSmAuthenticationManager::Shutdown][][][][][][][AuthenticationManager shutdown.]
    [12/20/2019][15:41:27][22539][807704320][CSmManager.cpp:82][Response Manager][][][][][][][Shutdown.]
    [12/20/2019][15:41:27][22539][807704320][CSmManager.cpp:82][Variable Manager][][][][][][][Shutdown.]
    [12/20/2019][15:41:27][22539][807704320][CSmAuthorizationManager.cpp:124][CSmAuthorizationManager::Shutdown][][][][][][][AuthorizationManager shutdown.]

    After we noticed these logs, we asked the team to re-register the webagent  and check if they are facing similar problem. They came back to us stating the same issue -  "their webagent is losing connection with policy server"

    Hence, we couldn't come to a conclusion in this usecase, Kindly please help out with a solution.




    ------------------------------
    Lavanya
    ------------------------------


  • 2.  RE: WebAgent Losing connection with Policy Server

    Posted yesterday

    Hi Lavanya,

    Are you still having this problem?

    The High Level Agent (HLA) shutdown messages can be normal depending on web server type and configuration (such as during idle time) and are not the result of the web agent losing connection with the policy server.

    What does the agent trace log show when a request is received?  That log will show the resolved URL, resolved agentname, and the results of the IsProtected call made to the policy server.

    Regards,

    Pete




  • 3.  RE: WebAgent Losing connection with Policy Server

    Posted 4 hours ago
    Hi Pete,

    Yes, the issue still persists, as the webagent goes down, it doesn't record any trace log, so we don't see any trace log coming up with it. 

     

     



    ------------------------------
    Siteminder Engineer
    ------------------------------