DX NetOps

Expand all | Collapse all

How to Fix Sync Issues Between Vertica and Mysql for Missing Components within netqosportal DB?

  • 1.  How to Fix Sync Issues Between Vertica and Mysql for Missing Components within netqosportal DB?

    Posted 08-07-2017 03:16 PM

    Hi,

     

    We have created our own CAMM Pack and we notice that some components are missing in the t_component table from the netqosportal database whereas the LC and DCMD have collected these missing components correctly. Moreover, these missing components are available within the vertica database and the max timestamp proves that we are collecting data. 

     

    So, it clearly demonstrates that there is a synchronization issue, for some of the components, between Vertica database and Mysql database. The thing I could not explain is that it is working of the other CAMM Pack component. 

     

    Any one of you have ever got this type of issue ? If yes how did you fix it ?

     

     

    Log from the DM : 

    WARN | RIB-Query-16 | 2017-08-07 15:00:16,986 | com.ca.im.rib.engine.portal.id.ItemIDTranslator  | Item missing from known performance center items. Expected to find an item according to a local Item ID.
          Data Source ID: {3}
          Item Type Name: {*}
          Local/Data Source Item ID: {55557}

     

    Aurélien



  • 2.  Re: How to Fix Sync Issues Between Vertica and Mysql for Missing Components within netqosportal DB?

    Posted 08-08-2017 04:09 PM

    Hello Aurelien,

     

    Any chance a restart of all PC services, including MySql, forces an update on the PC side since the DR, DA, DC and CAM Components all appear aware of the missing info?

     

    Thanks,

    Mike