DX Infrastructure Manager

Expand all | Collapse all

Problem lost historic data from UIM Database

  • 1.  Problem lost historic data from UIM Database

    Posted 08-13-2020 12:48 PM

    Hi

    I have a problem with the historical data on UIM,  we see that the historical data is deleted  (3 months), but we check and the retention politics are configurated to 4 months from data engine, on qos all have configurated the default politics (4 monts),  we need to know if there is one vulnerability on the database or there is another configuration that we need check, on the database there in not jobs or script that delete data.

    Do you know what can be the problem?

    We attach some screen shot
    Could you help us please?

    Best regard.

    Attachment(s)

    log
    _data_engine.log   221 KB 1 version
    log
    data_engine.log   27 KB 1 version


  • 2.  RE: Problem lost historic data from UIM Database

    Broadcom Employee
    Posted 08-13-2020 12:52 PM
    compare your data_engine retention values to what is stored in tbn_de_DataMaintConfig
    They might be off and you need to make a change and save again.

    ------------------------------
    Gene Howard
    Principal Support Engineer
    Broadcom
    ------------------------------



  • 3.  RE: Problem lost historic data from UIM Database

    Posted 08-13-2020 02:07 PM
    Hi Gen

    we check the infrmation on the tbn_de_DataMaintConfig, on some parameters they match from politcs on the data engine and on the table tbn_de_DataMaintConfig,  on the next images attached we have some question, we dont know what information is.

    could you help us please.

    Best reardd.



  • 4.  RE: Problem lost historic data from UIM Database

    Broadcom Employee
    Posted 08-13-2020 12:52 PM
    how exactly are you verifying this as well?

    ------------------------------
    Gene Howard
    Principal Support Engineer
    Broadcom
    ------------------------------



  • 5.  RE: Problem lost historic data from UIM Database

    Broadcom Employee
    Posted 08-13-2020 01:19 PM
    RN tables are for RAW data only.
    Please see the below KB artciles:
    https://ca-broadcom.wolkenservicedesk.com/external/article?articleId=137764
    https://ca-broadcom.wolkenservicedesk.com/external/article?articleId=45990

    ------------------------------
    Gene Howard
    Principal Support Engineer
    Broadcom
    ------------------------------



  • 6.  RE: Problem lost historic data from UIM Database

    Broadcom Employee
    Posted 08-13-2020 02:17 PM

    Based on your DE setting you should have 92 days in your RN tables.
    You should have 180 days in HN tables and 744 in DN tables.
    The second KB article I provided explains this.



    ------------------------------
    Gene Howard
    Principal Support Engineer
    Broadcom
    ------------------------------



  • 7.  RE: Problem lost historic data from UIM Database

    Broadcom Employee
    Posted 08-13-2020 02:55 PM
    see the below KB on troubleshooting data retention
    https://ca-broadcom.wolkenservicedesk.com/external/article?articleId=9547

    ------------------------------
    Gene Howard
    Principal Support Engineer
    Broadcom
    ------------------------------