AutoSys Workload Automation

Expand all | Collapse all

Autosys 12sp1 and Oracle DB 12.2 compatibility.

  • 1.  Autosys 12sp1 and Oracle DB 12.2 compatibility.

    Posted 9 days ago
    Hi!
    I'd like to use my old event server (Oracle DB 12.2) with new version of CA WAAE(12sp1). On scheduler machine I use Oracle client, version 19c. I can connect to the event DB with SQLplus.
    I found information, that WAAE 12sp1 is compatible with Oracle DB 12. https://techdocs.broadcom.com/us/en/ca-enterprise-software/intelligent-automation/autosys-workload-automation/12-0/release-notes/ae-compatibility-matrix.html
    But during installation I got a mistake:

    [CAUAJM_E_112534] The "TST1UA99.WORLD for instance Q01" database is at a lower schema version. First upgrade the database schema.
    Is AutoSys Compatibility Matrix incorrect? How can I use current version of Oracle DB with new version of application?



  • 2.  RE: Autosys 12sp1 and Oracle DB 12.2 compatibility.

    Posted 8 days ago
    Hi,
    try to run to check the version. You may need to update

    SELECT * FROM ujo_alamode WHERE TYPE = 'AEDB_VERSION';

    INT_VAL
    ----------
    STR_VAL
    --------------------------------------------------------------------------------
    TYPE
    --------------------
    0
    12.0.01.00
    AEDB_VERSION





  • 3.  RE: Autosys 12sp1 and Oracle DB 12.2 compatibility.

    Posted 8 days ago
    Edited by Bohdan Zaiachkovskyi 8 days ago
    Got next mistake:
    ORA-00942: table or view does not exist


  • 4.  RE: Autosys 12sp1 and Oracle DB 12.2 compatibility.

    Posted 8 days ago
    I guess you need to check your installation and refer to the installation guide

    • In Installation Options, select 
      Install the product
       or 
      Create or refresh the database schema
      .