AutoSys Workload Automation

Expand all | Collapse all

Autosys box job dint kick off after it was set to IN from On Hold status.

Jump to Best Answer
  • 1.  Autosys box job dint kick off after it was set to IN from On Hold status.

    Posted 04-07-2017 08:45 AM

     Autosys box job dint kick off after it was set to IN from On Hold status.This box runs every 30mins but on that day, it dint kick off and when we tried to use autrep -j jobname -d then we could see the even was not up for the next run. What could be the possible reason for box not kicking off even after it was in Inactive state?  Finally we had to force start the job and since then its running fine as per its schedule.I have read somewhere that its not advisable to change the status of job to any other state than OFF HOLD from an ON HOLD state.

    Any insight on this issue would be helpful!

     

     

    Thanks

    Waseem Hasan

    Autosys Prod Support Anlayst



  • 2.  Re: Autosys box job dint kick off after it was set to IN from On Hold status.

    Posted 04-07-2017 09:54 AM

    You untimed it. good job.

    A timed job only knows when to run when inserted or after completion. It never completed.

    Do an update_job on it.

    With no other settings

    It will recalc the next start. And never go on hold to in again

     

     

     

    Steve C.

     

     

    Nothing in this message is intended to constitute an electronic signature unless a specific statement to the contrary is included in this message.

     

    Confidentiality Note: This message is intended only for the person or entity to which it is addressed. It may contain confidential and/or privileged material. Any review, transmission, dissemination or other use, or taking of any action in reliance upon this message by persons or entities other than the intended recipient is prohibited and may be unlawful. If you received this message in error, please contact the sender and delete it from your computer.



  • 3.  Re: Autosys box job dint kick off after it was set to IN from On Hold status.

    Posted 04-07-2017 10:44 AM

    Do you meant to say this is the normal behavior of Autosys? If yes then why other jobs which are in SU state will pick up its next run even we mark them to IN state. By doing update_job you meant i need to update the job with the same start_times so that it will recalculate the next start. Instead of that i can force start the job and then it will pick up its next run as we did with that particular job. 

    Usually we mark any On hold job to Off hold states but sometimes user without knowing much about Autosys will request us to mark it to IN which happened in this case and was set to IN by one of my colleague and as result job dint pick up its next run.



  • 4.  Re: Autosys box job dint kick off after it was set to IN from On Hold status.
    Best Answer

    Posted 04-10-2017 03:25 AM

    Hi Waseem,

     

    The next start time of a job is calculated when a job completes. So it explains on why it works for a job which are in success or failure states. You just need to do an update_job <job_name> and it will recalculate the next start time of the job according to the job definition.



  • 5.  Re: Autosys box job dint kick off after it was set to IN from On Hold status.

    Posted 04-21-2017 12:21 PM

    Reg my ego is bruised. how is it your answer is correct? when i gave the same complete answer first?

     

    :-p



  • 6.  Re: Autosys box job dint kick off after it was set to IN from On Hold status.

    Posted 04-07-2017 12:05 PM

    Hello Hasan,

     

    Good Day!!

     

    I echo with Steve Yes you untimed the job by marking job to inactive state, which should have been off-holded to run job immediately.

     

    Please go through below document for more information

    Starting Conditions - CA Workload Automation AE & Workload Control Center - CA Technologies Documentation 

     

    Hope this helps!

     

    Best Regards,

    Shiva Krishna.K



  • 7.  Re: Autosys box job dint kick off after it was set to IN from On Hold status.

    Posted 04-10-2017 03:50 AM

    Hello

     

    I ran same scenario in my lab with a job having these starting conditions:

     

    date_conditions: 1
    days_of_week: all
    start_mins: 0,10,20,30,40,50

     

    sendevent -E JOB_ON_HOLD -J HP6

     autorep -J HP6 -d

    Job Name Last Start Last End ST/Ex Run/Ntry Pri/Xit
    ________________________________________________________________ ____________________ ____________________ _____ ________ _______
    HP6 ----- ----- OH 0/0

    Status/[Event] Time Ntry ES ProcessTime Machine
    -------------- --------------------- -- -- --------------------- ----------------------------------------
    [JOB_ON_HOLD] 04/10/2017 02:52:41 0 PD 04/10/2017 02:52:42
    [STARTJOB] 04/10/2017 03:00:00 0 UP
    <Event was scheduled based on job definition.>

     

     sendevent -E CHANGE_STATUS -s INACTIVE -J HP6
     autorep -J HP6 -d

     

    Job Name Last Start Last End ST/Ex Run/Ntry Pri/Xit
    ________________________________________________________________ ____________________ ____________________ _____ ________ _______
    HP6 ----- ----- IN 0/0

    Status/[Event] Time Ntry ES ProcessTime Machine
    -------------- --------------------- -- -- --------------------- ----------------------------------------
    [JOB_ON_HOLD] 04/10/2017 02:52:41 0 PD 04/10/2017 02:52:42
    INACTIVE 04/10/2017 02:53:16 0 PD 04/10/2017 02:53:16
    [STARTJOB] 04/10/2017 03:00:00 0 UP
    <Event was scheduled based on job definition.>

     

    At 3:00:00 it ran fine

    ===============

     

    [04/10/2017 03:00:00] CAUAJM_I_40245 EVENT: STARTJOB JOB: HP6 TEXT: <Event was scheduled based on job definition.>
    [04/10/2017 03:00:00] CAUAJM_I_40245 EVENT: CHANGE_STATUS STATUS: STARTING JOB: HP6 MACHINE: war6u2b1
    [04/10/2017 03:00:00] CAUAJM_I_10082 [war6u2b1 connected for HP6 210127.700880.1]
    [04/10/2017 03:00:01] CAUAJM_I_40245 EVENT: CHANGE_STATUS STATUS: RUNNING JOB: HP6 MACHINE: war6u2b1 TEXT: <Executing at WA_AGENT>
    [04/10/2017 03:00:01] CAUAJM_I_40245 EVENT: CHANGE_STATUS STATUS: SUCCESS JOB: HP6 MACHINE: war6u2b1 EXITCODE: 0
    [04/10/2017 03:01:00] ----------------------------------------

    Job Name Last Start Last End ST/Ex Run/Ntry Pri/Xit


    autorep -J HP6 -d


    HP6 04/10/2017 03:00:00 04/10/2017 03:00:00 SU 700880/1 0

    Status/[Event] Time Ntry ES ProcessTime Machine
    -------------- --------------------- -- -- --------------------- ----------------------------------------
    STARTING 04/10/2017 03:00:00 1 PD 04/10/2017 03:00:00 war6u2b1
    RUNNING 04/10/2017 03:00:00 1 PD 04/10/2017 03:00:01 war6u2b1
    <Executing at WA_AGENT>
    SUCCESS 04/10/2017 03:00:00 1 PD 04/10/2017 03:00:01 war6u2b1
    [STARTJOB] 04/10/2017 03:10:00 0 UP
    <Event was scheduled based on job definition.>

     

    I would suggest you try to replicate what the end users reported to you and then look into the different events with autorep -J <your job> -d

    May be something else had been done for this specific run of this job

     

    See also: Resetting a Job Flow with Time Conditions Through INACTIVE Status Change - CA Workload Automation AE & Workload Control … 

    I would also recommend reading Basic Box Job Concepts - CA Workload Automation AE & Workload Control Center - CA Technologies Documentation 

    It might have impacts on your Box status when you change an inner job to Inactive

     

    Regards

    Jean Paul