Layer 7 Access Management

Expand all | Collapse all

ca-erp-sessionlinker-12.52-sp01-aix-64.bin  doesn't support Apache 2.4  Web Server

Jump to Best Answer
  • 1.  ca-erp-sessionlinker-12.52-sp01-aix-64.bin  doesn't support Apache 2.4  Web Server

    Posted 23 days ago

    Hi,


    ca-erp-sessionlinker-12.52-sp01-aix-64.bin  doesn't support Apache 2.4  Web Servers because it needs a  new file "libnpsapache24sessionlinker.so"  that doesn't available since "ca-erp-sessionlinker-12.52-sp01-aix-64.bin" is a pretty old installer created on 02/07/2014. 


    when we install  CA SSO  SessionLinker "ca-erp-sessionlinker-12.52-sp01-aix-64.bin" and try to configure, it is throwing below Error in  log file  /opt/netegrity/siteminder/sessionlinker-64/install_config_info/CA_SiteMinder_SessionLinker_Configuration_Install_08_01_2019_15_23_30.log


    Copy File:                Destination: /opt/netegrity/siteminder/webagent/bin/libnpsapache24sessionlinker.so

                              Status: WARNING

                              Additional Notes: WARNING - Source /opt/netegrity/siteminder/sessionlinker-64/bin/libnpsapache24sessionlinker.so does not exist.

    We tried pointing to existing "libnpsapache22sessionlinker.so" but throwing below error 

    httpd: Syntax error on line 180 of /prod/apache24/conf/httpd.conf.sm.erp.testa: Cannot load /opt/netegrity/siteminder/webagent/bin/libnpsapache22sessionlinker.so into server: rtld: 0712-001 Symbol ap_rputs/opt/netegrity/siteminder/webagent/bin/libnpsapache22sessionlinker.so was referenced\n      from module /opt/netegrity/siteminder/webagent/bin/libnpsapache22sessionlinker.so(), but a runtime definition\n\t    of the symbol was not found. 

    I tried going to check for CA SSO SESSIONLINKER 12.6.1 and i didn't find a IBM AIX Installer.  Only able to find Windows and Linux one. 

    Please work with your engineering team provide a updated installer where it contains " libnpsapache24sessionlinker.so" library. 



  • 2.  RE: ca-erp-sessionlinker-12.52-sp01-aix-64.bin  doesn't support Apache 2.4  Web Server
    Best Answer

    Posted 20 days ago
    Hi Venkata,

    On AIX, the only combination supported is :

    IBM HTTP Server 8.5 64bit on AIX 7.164bit

    Session Linker 64-bit application on the Web Agent
    https://casupport.broadcom.com/phpdocs/7/5262/5262_SessionLinker1252_Platsupp.pdf

    What are your exact versions ?

    Best Regards,
    Patrick